Deploying the TestStand Runtime

TestStand 2016 Help

Edition Date: August 2016

Part Number: 370052R-01

»View Product Info
Download Help (Windows Only)

Complete the following steps to deploy the TestStand Runtime.

  1. Select Tools»Deploy TestStand System in the TestStand Sequence Editor to launch the TestStand Deployment Utility.
  2. On the System Source tab, enable the Deploy Files»From TestStand Public Directories option to collect files from the <TestStand Public> directories. When you select this option, the deployment utility distributes to the test station computer any component file customizations, such as process models, step types, user interfaces, and language strings, you saved in the <TestStand Public> subdirectories.

Configuring the Installer

Complete the following steps to configure the installer.

  1. On the Installer Options tab, use the Installer Directory control to specify the directory to which the deployment utility copies the installer for the test system.
  2. On the Installer Options tab, enable the Install TestStand Runtime option.
  3. Click the Drivers and Components button to launch the Drivers and Components dialog box, in which you can select additional components to include in the installer.
  4. Unenable the Only display runtime installers option to display the TestStand product.
  5. Select the TestStand product to include the sequence editor in the TestStand Runtime installation.
  6. Click OK to apply the new settings and close the dialog box.
  7. Click Save and save the build as EngineInstaller.tsd.
  8. Click the Build button to build the installer.

Installing the Test System

Complete the following steps to install the test system.

  1. To use the installer, copy all the files from the installer directory you specified on the Installer Options tab to the distribution media you want to use or to a shared directory on a network.
  2. On the test station computer, insert the distribution media or connect to the network and run the setup.exe application to start the installer.
  3. When the installation completes, complete the following steps to verify that the TestStand Runtime installed correctly.
    • (Windows 8.1) Click the NI Launcher tile on the Start screen and select TestStand»TestStand Sequence Editor.
    • (Windows 7 or earlier) Select Start»All Programs»National Instruments»TestStand»TestStand Sequence Editor.
  4. Activate a license when the sequence editor prompts you.

See Also

Distributing a User Interface

WAS THIS ARTICLE HELPFUL?

Not Helpful