Configuration Files

TestStand 2017 Help

Edition Date: November 2017

Part Number: 370052W-01

»View Product Info

Download Help (Windows Only)
NI TestStand 2014 Help
NI TestStand 2014 SP1 Help
TestStand 2016 Help
TestStand 2016 SP1 Help
TestStand 2017 Help

TestStand stores configuration settings in .ini files in the <TestStand Application Data>\Cfg and <TestStand Application Data>\Cfg\ModelPlugins directories. You can add modified configuration files to a workspace to include the files in a deployment to alter the behavior of TestStand on the test station computer. If you do not include configuration files in the deployment, TestStand creates a version of the configuration files with default settings.

If you deploy a new test system that uses the TestStand 2012 or later process models to an existing system that uses the equivalent legacy TestStand 2010 process models, you must use the Legacy Model Switcher tool to migrate the report or database options to the TestStand 2012 or later process models. To build an installer that contains the default process models, enable the Install TestStand Runtime option on the Installer Options tab of the TestStand Deployment Utility.

The following table lists commonly modified configuration files, specifies the information TestStand stores in those files, and specifies whether to include those configuration files in a deployment.

File Contents Used in Execution Used in Editing Include in Deployment?
Analyzer.ini Settings for the TestStand Sequence Analyzer If you customize the default sequence analyzer settings
CustomRules.tsarules Information about custom sequence analyzer rules If you create custom sequence analyzer rules
ConnectionSource.ini Datalink list the Database and Legacy Property Loader step types use for configuration. If the test system loads properties from databases using the Legacy Property Loader steps or uses Database step types
ModelPlugins\ResultProcessing.cfg Configuration information for all result processing model plug-in instances If you use the TestStand process models and customized the default reporting, result logging, or database options
PLPropertyLoader.ini Configuration options for the Legacy Property Loader Import/Export Properties tool

Note: Legacy Property Loader steps do not use this file.
If the deployed test system uses the Import/Export Properties tool
ImportExportTool.ini Configuration options for the Import/Export Properties tool

Note: Property Loader steps do not use this file.
If the deployed test system uses the Import/Export Properties tool
StationGlobals.ini Definitions and values of station global variables If the test system uses station global variables
Templates.ini Templates configuration for the Insertion Palette pane in the TestStand Sequence Editor If you defined any templates to use in the test system
GeneralEngine.cfg Configuration Options for stations, the Insertion Palette pane, the file path history, and the type palette list If you defined custom configurations for the test system
Adapters.cfg Configuration for adapters If you defined custom adapter configurations for the test system
SearchDirectories.cfg Configuration for search directories If you defined custom search directories for the test system
TypePalettes.cfg Specifies locations of type palette files If you defined custom type palette files used in the deployment
StartupCfg.cfg Settings needed prior to engine construction If you defined custom engine settings for the test system
TestStandDatabaseSchemas.ini Database schemas for result logging If you use a custom or modified database schema to log data to a database
TestStandModelModelOptions.ini Model options for built-in process models If you use the TestStand process models and customized the default model options
ToolMenu.ini List of Tools menu items If you want to customize the Tools menu on the test station computer
Users.ini List of TestStand users If you want to configure the set of users on the test station computer
FileDiffer.ini Configuration for the TestStand File Diff and Merge Utility If you want to include customized file differ settings in the test system
DatabaseViewerOptions.ini Configuration for the TestStand Database Viewer Application If you want to include customized database viewer settings in the test system
ModelPlugins\Addons.cfg Configuration for the process model plug-in add-ons If you want to include process model add-ons in the test system

The following table lists commonly modified configuration files for the equivalent legacy TestStand 2010 process models, the information TestStand stores in those files, and whether to include those configuration files in a deployment.

File Contents Used in Execution Used in Editing Include in Deployment?
TestStandModelReportOptions.ini Report options for built-in process models If you use the TestStand process models and customized the default report options
TestStandDatabaseOptions.ini Database options for built-in process models If you use the TestStand process models and customized the default database options

You typically do not modify the following files for use in a deployment:

  • Deployment Utility Protected Folders.ini—List of directories that cannot be modified by the TestStand Deployment Utility.
  • Deployment Utility RecentFiles.ini—Most recently used file list for the TestStand Deployment Utility.
  • DeploymentUtilityOptions.ini—Configuration options for the deployment utility.
  • DocGen.ini—Configuration options for the Sequence File Documentation tool.
  • EngineParts.ini—The deployment utility uses this file when you include the TestStand Runtime in an installer. Do not edit or deploy this file.
  • ExpressMenu—Cache of the Express VI menu for the specified LabVIEW version installed on the computer. Do not deploy this file because the cache on the development computer might be different from the cache on the test station computer.
  • Filter.ini—List of files to exclude from deployment.
  • TestStandPersistedOptions.opt—Persisted breakpoints and watch expressions to use when no workspace is loaded.

User-Specific Application Data

TestStand stores the following sequence editor layout and user interface configuration files in the <TestStand Local Application Data> directory. You typically do not include these files in a deployment because users customize these files during normal TestStand use.

  • layout_current.bin—Layout of the sequence editor the last time it was closed, including window position, size, docked state, and other settings for the panes, menus, and toolbars.
  • SeqEdit.xml—Configuration options for the sequence editor, such as panel size and font settings used on the Insertion Palette pane and the Variables pane.
  • UserInterface.xml—Configuration options for the user interfaces, such as window and panel sizes, font settings, and sequences to load. You can customize the data stored in this file.

WAS THIS ARTICLE HELPFUL?

Not Helpful