Database Viewer Application

TestStand 2017 Help

Edition Date: November 2017

Part Number: 370052W-01

»View Product Info

Download Help (Windows Only)
NI TestStand 2014 Help
NI TestStand 2014 SP1 Help
TestStand 2016 Help
TestStand 2016 SP1 Help
TestStand 2017 Help

TestStand includes the Database Viewer application for viewing data in a database, editing table information, and executing SQL commands. You can access the Database Viewer application in the following ways:

  • Select Tools»Database Viewer in the TestStand Sequence Editor.
  • (Windows 8.1) Click the NI Launcher tile on the Start screen and select TestStand»Tools»TestStand Database Viewer.
  • (Windows 10 or 7) Select Start»All Programs»National Instruments»TestStand»Tools»TestStand Database Viewer.
  • Run <TestStand>\Components\Tools\DatabaseView\DatabaseView.exe.
  • Run <TestStand>\Components\Tools\DatabaseView\DatabaseView.exe from the command line.

The Database Viewer supports the following functionality:

  • Database Explorer—The Database Explorer pane displays information about open database connections. You can view and edit data, add or remove database tables, and open or close database connections.
  • Database Viewer Tabs—The Database Viewer contains Edit Data and Execute SQL tabs, which are associated with an open database connection. All operations performed in each tab execute on the database connection associated with that tab. The connection you select from the connection list when you create a tab becomes the connection associated with that tab.
  • Binary Data Viewer—The Binary Data Viewer allows you to view binary data that has been logged to the database. You can view the data as a table, a graph, or as the layout in memory.

See Also

Command Line Arguments

Configuring Connection Strings

Customizing the Database Viewer User Interface

Database Known Issues

Database Logging

Database Viewer Menu Bar

Edit Data Tab

Execute SQL Tab

WAS THIS ARTICLE HELPFUL?

Not Helpful