Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Data Logging

You can log time waveform, scalar, or Boolean signals you create or acquire in LabVIEW SignalExpress, and you can use steps to analyze and process logged signals. Use data logging to save, review, and analyze measurements you take in LabVIEW SignalExpress.

Note Note  LabVIEW SignalExpress also supports limited logging of frequency-domain signals.

Logging a Signal

If a project includes steps with valid output signals, you can begin logging immediately by clicking the Record button and selecting a signal from the Logging Signals Selection dialog box. LabVIEW SignalExpress runs the project and logs the signal continuously until you click the Stop button, and the log appears in the Logged Data window at the bottom of the Project View. LabVIEW SignalExpress logs signals in blocks that are equivalent to the block size, or number of samples, of the acquired signal. You configure the block size of a signal in the step you use to create or acquire the signal.

Like a step output, you can drag a logged signal from the Logged Data window to the Data View tab to display the data. You can scroll through the logged signal and view any alarms or events associated with the log. You also can switch to the Playback work area to play back and analyze logged signals.

Note Note  You must be in the Monitor/Record work area to log a signal.

LabVIEW SignalExpress saves logged data in the .tdms file format to the directory you specify on the Logging page of the Options dialog box. The .tdms file is a binary file that contains waveform data and stores waveform properties. You also can import logged data from .tdms files you previously created with LabVIEW SignalExpress.

Logging While Running

If you want to log a signal every time you run a project, you can specify the signal(s) to record in one of the following ways:

  • In the Project View, right-click a step output and select Enable Recording from the shortcut menu to enable data logging for the output.
  • Select View»Recording Options to display the Recording Options tab and select a signal or signals on the Signal Selection page.
Note Note  The Recording Options tab also includes pages you can use to configure advanced logging options, such as start and stop conditions, alarms, and events.

When you use one of the previous methods to select a signal or signals to record, the Record While Running button appears in the toolbar. Ensure that the Record While Running button is enabled, and click the Run button to begin logging the signals you selected.

Logging Frequency-Domain Signals

You can log the last known value of a frequency-domain signal and view the log on the Data View tab. The last known value of the signal is the value of the signal when the project stops running. In the Project View, right-click a frequency-domain output signal and select Record last value from the shortcut menu to log the last known value of the signal. LabVIEW SignalExpress saves logs of frequency-domain signals in the .tdms file format to the default location you specify on the Logging page of the Options dialog box.

Note Note  Because LabVIEW SignalExpress records a frequency-domain signal as a single value, you cannot play back a log of a frequency-domain signal.

Managing Multiple Data Logs

When you record multiple logs, the most recent log becomes the active log. If you are viewing the signal(s) you are logging on the Data View tab, the display updates to display the new active log. The name of the active log also appears in bold in the Logged Data window. If you are in the Playback work area, any steps that are using the logged signal as an input update to use the new active log as the input. You can change the active log at any time by right-clicking the name of a log in the Logged Data window and selecting Make Active Log from the shortcut menu.


Resources

WAS THIS ARTICLE HELPFUL?

Not Helpful