Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Logging Page (Options Dialog Box)

Select Tools»Options to display the Options dialog box and select Logging from the Category list to display this page.

Use this page to set options for logging data in LabVIEW SignalExpress. This page includes the following components:

  • Miscellaneous—Contains the following miscellaneous logging options:
    • Automatically export log to ASCII file—Specifies whether LabVIEW SignalExpress creates an ASCII text file of logged data every time you create a log. This option is similar to right-clicking a signal in the Logged Data window and selecting Convert to ASCII from the shortcut menu.
    • Activate new logs—Specifies whether a new data log becomes the active log by default.
    • Prepare log data for viewing—Specifies when and if LabVIEW SignalExpress prepares logged data for viewing on the Data View tab. Because most logging operations acquire numerous points of data, LabVIEW SignalExpress must process the log so you can view it on a reasonable scale in a display on the Data View tab. You can select from the following options:
      • During logging—(Default) LabVIEW SignalExpress prepares logged data for viewing as it logs the data.
      • After logging completes—LabVIEW SignalExpress prepares logged data for viewing after the log is complete. This option can improve logging performance on large data logs.
      • Never—LabVIEW SignalExpress does not prepare logged data for viewing. This option provides maximum performance benefits if you are recording a very large log, such as if you are logging for multiple days. If you want to view the data, you can right-click the log in the Logged Data window and select Make Log Viewable from the shortcut menu.
    • Disable UI updates while logging—Specifies whether LabVIEW SignalExpress disables updates of a signal graph on the Data View tab while you log the signal. Disabling UI updates can improve performance while logging.
    • Inherit playback configuration—Specifies whether a new log inherits the settings you specify on the Playback Options tab for the previous log. By default, LabVIEW SignalExpress resets playback options each time you create a new log.
    • Restart logging on error—Specifies whether LabVIEW SignalExpress restarts a logging operation if an error occurs.
    • Log naming convention—Specifies the naming convention LabVIEW SignalExpress uses for new logs. You can select from the following options:
      • Date & Time—(Default) LabVIEW SignalExpress names new logs using the date and time at which you record the log.
      • Time—LabVIEW SignalExpress names new logs using the time at which you record the log.
      • User-defined name—LabVIEW SignalExpress names new logs using a name that you define.
    • Save copy of project next to log files—Specifies whether LabVIEW SignalExpress saves a copy of the project you use to record a log in the directory in which you save the log.
    • Default storage directory—Specifies the default directory in which LabVIEW SignalExpress saves log files.
      Note  If you set Store log files next to project file to Yes, LabVIEW SignalExpress saves log files in the directory that contains the project regardless of the Default storage directory you specify.
    • Store log files next to project file—Specifies whether LabVIEW SignalExpress saves log files in the directory that contains the project by default. Setting this option to Yes overrides the Default storage directory you specify.

Resources

WAS THIS ARTICLE HELPFUL?

Not Helpful