Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Converting VIs

LabVIEW 2010 Help

Edition Date: June 2010

Part Number: 371361G-01

»View Product Info

You cannot open a VI saved in LabVIEW 3.x or earlier without contacting an NI representative for information about upgrading your code to VI formats compatible with LabVIEW 2010. To open a VI saved in LabVIEW 4.0 to 5.x, you first must open and save the VI in any LabVIEW version from 6.0 to 8.2.1 and then reopen the VI in LabVIEW 2010. When you open a VI last saved in LabVIEW 6.0 or later, LabVIEW 2010 automatically converts and compiles the VI. You must save the VI in LabVIEW 2010, or the conversion process, which uses extra memory resources, occurs every time you access the VI. Also, you might experience a large run-time degradation of performance for any VI that has unsaved changes, including a recompile.

Note  VIs you save in LabVIEW 2010 do not load in earlier versions of LabVIEW. To maintain compatibility with an earlier version, before you save VIs in LabVIEW 2010 after you convert them, keep a backup copy of VIs you plan to use in the previous version. You also can select File»Save for Previous Version to save VIs so they can run in a previous version.

If your computer does not have enough memory to convert all the VIs at once, convert the VIs in stages. Examine the hierarchy of VIs you want to convert and begin by loading and saving subVIs in the lower levels of the hierarchy. Then progress gradually to the higher levels of the hierarchy. Open and convert the top-level VI last. You also can select Tools»Advanced»Mass Compile to convert a directory of VIs. However, mass compiling converts VIs in a directory or LLB in a set order. Refer to the Fundamentals»Creating VIs and SubVIs»How-To»Saving VIs»Mass Compiling VIs topic on the Contents tab of the LabVIEW Help for a description of the order in which LabVIEW processes files when you mass compile. If the conversion process encounters a high-level VI first, mass compiling requires approximately the same amount of memory as if you opened the high-level VI first.

You can monitor memory usage by selecting Help»About LabVIEW to display a summary of the amount of memory you currently are using.

The following table shows compatibility between VIs saved in previous versions of LabVIEW and versions of LabVIEW for which National Instruments provides mainstream support. The indicates that the version can load a VI saved in that specific version of LabVIEW. The indicates that you must contact an NI representative to obtain conversion software to upgrade your code to VI formats compatible with LabVIEW 2010.

Refer to the Developer Zone on ni.com for more information about converting VIs to a different version of LabVIEW.

Localized versions of LabVIEW use the same executable as the U.S. version. Therefore, localized versions are compatible with the U.S. version.

Saved in
LabVIEW Version
Loaded in
LabVIEW 2010
Loaded in
LabVIEW 2009
Loaded in
LabVIEW 8.6
Loaded in
LabVIEW 8.5.x
Loaded in
LabVIEW 8.2.x
2010

SFP SFP SFP SFP
2009

SFP SFP SFP
8.6

SFP SFP
8.5.x

SFP
8.2.x

8.0.x

7.1.x

7.0.x

6.1.x

6.0.x

5.1.x

Save in 6.0
to 8.2.1 first

Save in 6.0
to 8.2.1 first

5.0.x

Save in 6.0
to 8.2.1 first

Save in 6.0
to 8.2.1 first

4.0.x

Save in 6.0
to 8.2.1 first

Save in 6.0
to 8.2.1 first

3.0.x


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit