Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Block Diagram Page (Options Dialog Box)

LabVIEW 2011 Help

Edition Date: June 2011

Part Number: 371361H-01

»View Product Info

Requires: Base Package

Select Tools»Options to display the Options dialog box and select Block Diagram from the Category list to display this page.

Use this page to set block diagram options.

This page includes the following components:

  • General—Use this section to set general block diagram options.
    • Place front panel terminals as icons—Displays terminals for new front panel objects you create as icons. This checkbox contains a checkmark by default. Remove the checkmark from this checkbox to display terminals for new front panel objects as data types. You also can right-click existing terminals to display the terminals as icons or data types.
    • Place structures with Auto Grow enabled—Resizes new structures you place on the block diagram to add space for any objects you place or move in the structure near its border. The new structure only resizes once you place objects on the block diagram. This checkbox contains a checkmark by default. You also can enable the automatic resizing behavior for existing structures.
    • Configure Express VIs immediately—Displays a configuration dialog box immediately after you place an Express VI on the block diagram. This checkbox contains a checkmark by default.
    • Auto-insert Feedback Node in cycles—Inserts a Feedback Node when you wire the output of a subVI, function, or group of subVIs and functions to the input of that same VI, function, or group. This checkbox contains a checkmark by default. Remove the checkmark from this checkbox if you do not want LabVIEW to insert Feedback Nodes automatically.
  • Tip Strips and Labeling—Use this section to configure block diagram tip strips and labels.
    • Show tip strips over terminals—Displays tip strips when you idle the Wiring tool over nodes and input or output terminals of VIs or functions. This checkbox contains a checkmark by default.
      • Use control caption for subVI tip strips—Displays object captions on subVI tip strips instead of object labels. This checkbox contains a checkmark by default.
    • Use transparent free labels—Uses transparent free labels for objects on the block diagram. This checkbox does not contain a checkmark by default.
    • Use transparent name labels—Uses transparent owned labels for objects on the block diagram. This checkbox contains a checkmark by default.
      Note  This option does not affect the transparency of labels on wires.
    • Labels locked by default—Locks labels and captions in place for new objects on the block diagram. This checkbox does not contain a checkmark by default.
      Note  This option does not lock labels to wires.
    • Default label position—Sets the default label position for objects on the block diagram. The default is the initial label position LabVIEW automatically sets for each object.
      Note  This option does not affect the position of labels on wires.
    • Show subVI names when dropped—Displays VI, function, and global variable name labels when you place them on the block diagram. This checkbox does not contain a checkmark by default.
  • Wiring—Use this section to set block diagram wiring options.
    • Enable automatic wire routing—Finds a route for wires as you wire them. LabVIEW routes a wire around existing objects on the block diagram, such as loops and structures. LabVIEW also routes a wire to decrease the number of bends in the wire. When possible, automatically routed wires from control terminals exit the right side of the terminal, and automatically routed wires to indicator terminals enter the left side of the terminal. This checkbox contains a checkmark by default. Remove the checkmark from this checkbox to disable automatic wire routing for all new wires. You can temporarily disable automatic wire routing and route a wire manually.
    • Enable auto wiring—Enables auto wiring. This checkbox contains a checkmark by default.
      • Minimum distance (pixels)—Indicates the minimum distance in pixels objects need between them so they can automatically wire. The default is 4 pixels.
      • Maximum distance (pixels)—Indicates the maximum distance in pixels objects can be separated and still automatically wire. The default is 32 pixels.
    • Show red Xs on broken wires—Displays broken wires as dashed black lines with red Xs in the middle. This checkbox contains a checkmark by default. Remove the checkmark from this checkbox to display broken wires as dashed black lines without red Xs in the middle.
    • Show dots at wire junctions—Displays a dot where a wire branches, helping to differentiate between a wire junction and the crossing of unconnected wires. This checkbox contains a checkmark by default. Remove the checkmark from this checkbox to display wire junctions without dots.
  • Error Handling—Use this section to set block diagram error handling options.
    • Enable automatic error handling in new VIs—Suspends execution, highlights the subVI or function where the error occurred, and displays an error dialog box for any error that occurs when running a new, blank VI. This checkbox contains a checkmark by default. Remove the checkmark from this checkbox to disable automatic error handling for all new, blank VIs. You also can disable automatic error handling for existing VIs. You also can use the Automatic Error Handling property to enable automatic error handling for a VI programmatically.
    • Enable automatic error handling dialogs—Suspends execution, highlights the subVI or function where the error occurred, and displays an error dialog box for any error that occurs when running an existing VI with automatic error handling enabled. This checkbox contains a checkmark by default. Remove the checkmark from this checkbox if you do not want LabVIEW to suspend execution and display an error dialog box when an error occurs, even when the VI has automatic error handling enabled. You also can disable automatic error handling for existing VIs.
  • Constant Folding—Use this section to set constant folding options.
    • Show constant folding of wires—Displays hash marks on wires attached to constants that are constant folded.
    • Show constant folding of structures—Displays gray hash marks inside structures that are constant folded.
  • Block Panel Grid—Use this section to set block diagram alignment grid options.
    • Show block diagram grid—Displays the grid on the block diagram of all open VIs. This checkbox does not contain a checkmark by default.
      • Default diagram grid size in pixels—Size in pixels of units on the block diagram grid for all new VIs. The default is 16 pixels. Use the Editor Options page of the VI Properties dialog box to set the size of the grid for the current VI.
      • Contrast with diagram background—Percentage of contrast with the block diagram background to use when displaying the grid in all open VIs.
      • Enable diagram grid alignmentEnables the grid alignment on the block diagram of all open VIs so objects align to the grid when you place, move, or resize them. This checkbox does not contain a checkmark by default. You also can select Edit»Enable Diagram Grid Alignment or Disable Diagram Grid Alignment to toggle this behavior. Alternatively, you can press the <G> key as you place, move, or resize a control to toggle the grid alignment.
      • Alignment grid draw style—Indicates whether to draw the grid using solid lines, dots at grid junctions, or major and minor lines similar to the lines on graphing paper. The default is solid lines. LabVIEW draws a small diamond at the absolute coordinates (0,0) to indicate the origin of the alignment grid and uses major lines to draw the origin grid lines. The origin of the alignment grid is located out of view in the upper left portion of all new front panel and block diagram windows. Use the Scrolling tool to scroll the window so you can see the origin of the alignment grid. Use the origin as a reference point when using the Position property to programmatically position controls.
  • Block Diagram Cleanup—Use this section to set block diagram clean-up options. Changes to these options take effect the next time you select Edit»Clean Up Diagram from the menu of the VI.
    • Horizontal block diagram spacing (pixels)—Specifies the minimum horizontal spacing in pixels between any two block diagram objects. The default is 10. LabVIEW considers visible labels as part of a block diagram object.
    • Vertical block diagram spacing (pixels)—Specifies the minimum vertical spacing in pixels between any two blocks. The default is 15. LabVIEW considers visible labels as part of a block diagram object.
    • Horizontal wire spacing (pixels)—Specifies the minimum horizontal spacing in pixels between any two wires or any wire and any block diagram object. The default is 3.
    • Vertical wire spacing (pixels)—Specifies the minimum vertical spacing in pixels between any two wires or any wire and any block diagram object. The default is 3.
    • Adjust spacing to reduce bends in wires—Reroutes wires to decrease the number of bends in the wires. LabVIEW might space block diagram objects or wires closer together than specified by Block spacing and Wire spacing. This checkbox contains a checkmark by default.
    • Move controls to the left of the containing diagram—Moves all controls to the left side of the block diagram. If a control is inside of a structure, LabVIEW moves the control near the left border of that structure. This checkbox does not contain a checkmark by default.
    • Move indicators to the right of the containing diagram—Moves all indicators to the right side of the block diagram. If an indicator is inside a structure, LabVIEW moves the indicator near the right border of that structure. This checkbox does not contain a checkmark by default.
    • Automatic tuning—Determines automatically how compact to make the block diagram and how much time to spend adjusting the block diagram objects and wires. This option is selected by default.
      Note  Automatic tuning uses VI dependent values for Horizontal compactness and Layout quality.
    • Manual tuning—Allows you to specify how compact to make the block diagram and how much time to spend adjusting the block diagram objects and wires.
      • Horizontal compactness—Determines how compact to make the block diagram. Higher compactness causes LabVIEW to take longer to clean up the block diagram and can cause LabVIEW to reroute wires under objects. This control is grayed out unless you select Manual tuning. LabVIEW considers labels as part of a block diagram object.
      • Layout quality—Determines how much time LabVIEW spends cleaning up the block diagram. A higher layout quality results in a more compact block diagram. LabVIEW dims this control unless you select Manual tuning.

 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit