Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Menus and Toolbars

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Use the menu and toolbar items to operate and modify objects in LabVIEW.

Menus

The menus at the top of a VI window contain items common to other applications, such as Open, Save, Copy, and Paste, and other items specific to LabVIEW. Some menu items also list keyboard shortcuts.

(Mac OS X) The menus appear at the top of the screen.

Note  Some menu items are unavailable while a VI runs.

Shortcut Menus

All LabVIEW objects have associated shortcut menus, also known as context menus, pop-up menus, and right-click menus. As you create a VI, use the shortcut menu items to change the appearance or behavior of front panel and block diagram objects. To access the shortcut menu, right-click the object.

(Mac OS X) Press <Control>-click to perform the same action as right-click.

While you are editing a VI, the shortcut menu of a control or indicator contains several common options. The menu items above the first two lines in the shortcut menu of a control or indicator are common to all controls and indicators. The menu items below the second line are customized for the object.

To perform a common operation on multiple objects simultaneously, select the objects and use the shortcut menu. Some objects may not support all the operations available on the shortcut menu. For example, if you select a numeric control and a structure and select Create»Reference from the shortcut menu, LabVIEW creates a reference for only the numeric control.

You also can customize the shortcut menu items that appear in the VI menu at run time.

Customizing Keyboard Shortcuts

You can change and customize the default LabVIEW keyboard shortcuts. Select Tools»Options to display the Options dialog box. Select Menu Shortcuts from the Category list to set keyboard shortcuts for VI menu items. The Menu Shortcuts page also lists the default LabVIEW shortcuts for menu items.

Note  LabVIEW does not respond to keyboard shortcuts for dimmed menu items or hidden VI toolbar buttons.

VI Toolbar

Use the buttons on the VI toolbar to run VIs, pause VIs, abort VIs, debug VIs, configure fonts, and align, group, and distribute objects.

Project Explorer Window Toolbars

Use the buttons on the Standard, Project, Build, and Source Control toolbars to perform operations in a LabVIEW project. The toolbars are available at the top of the Project Explorer window. You might need to expand the Project Explorer window to view all of the toolbars.

Note  The Unit Test Framework toolbar is available only if you install the LabVIEW Unit Test Framework Toolkit.

You can show or hide toolbars by selecting View»Toolbars and selecting the toolbars you want to show or hide. You also can right-click an open area on the toolbar and select the toolbars you want to show or hide.


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit