Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Organization of LabVIEW

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

This topic describes the structure of the LabVIEW file system and the suggested locations for saving files.

Organization of the LabVIEW Directory Structure

This section describes the structure of the LabVIEW file system on Windows, Mac OS X, and Linux. LabVIEW installs driver software for GPIB, DAQ, VISA, IVI, Motion Control, and IMAQ hardware depending on platform availability.

The labview directory contains the following groupings after you complete the installation.

Note  LabVIEW modules and toolkits you have installed might create additional directories within the labview directory.

Libraries

  • user.lib—Directory in which you can save controls and VIs you create. LabVIEW displays controls on User Controls palettes and VIs on User Libraries palettes. This directory does not change if you upgrade or uninstall LabVIEW.
  • vi.lib—Contains libraries of built-in VIs, which LabVIEW displays in related groups on the Functions palette. Do not save files in the vi.lib directory because LabVIEW overwrites these files when you upgrade or reinstall.
  • instr.lib—Contains instrument drivers used to control PXI, VXI, GPIB, serial, and computer-based instruments. When you install National Instruments instrument drivers and place them in this directory, LabVIEW adds them to the Instrument Drivers palette.

Structure and Support

  • menus—Contains files LabVIEW uses to configure the structure of the Controls and Functions palettes.
  • resource—Contains additional support files for the LabVIEW application. Do not save files into this directory because LabVIEW overwrites these files when you upgrade or reinstall.
  • project—Contains files that become items on the LabVIEW Tools menu.
  • ProjectTemplates—Contains starting points for common LabVIEW design patterns that you customize with the Create Project dialog box.
  • templates—Contains templates for common VIs.
  • wizard—Contains files that become items on the LabVIEW File menu.
  • www—Location of HTML files you can access through the Web Server.

Learning and Instruction

  • examples—Contains example VIs. Select Help»Find Examples to browse or search the examples.

Documentation

  • manuals—Contains documentation in PDF format.
  • help—Contains the help files. Access the LabVIEW Help by selecting Help»LabVIEW Help. This directory also contains files that become items on the LabVIEW Help menu.
  • readme—Contains the LabVIEW readme file and readme files for any modules or toolkits you installed. (Windows) Access the readme files by selecting Start»All Programs»National Instruments»LabVIEW»Readme or by navigating to the labview\readme directory. (Mac OS X and Linux) Access the readme files by navigating to the labview directory.

Suggested Location for Saving Files

LabVIEW installs the vi.lib and the resource directories for LabVIEW system purposes only. Do not save your files in these directories.

You can save your files in the following directories:

  • user.lib—Any controls or VIs you want to display on the User Controls or User Libraries palettes.
    Note   Save subVIs in the user.lib directory only if they are usable, without modification, across projects. Paths to VIs in user.lib are relative to the labview directory. Paths to subVIs you save elsewhere are relative to the parent VI. Therefore, copying a VI from user.lib to modify it for a special case does not change the path to its subVIs located in user.lib.


    If you want to copy a VI and its subVIs to another directory or computer, do not save the VIs in user.lib because when you run the top-level VI from the new location LabVIEW references the original subVIs in user.lib.
  • instr.lib—Any instrument driver VI you want to display on the Instrument Drivers palette.
  • project—VIs you use to extend LabVIEW capabilities. VIs you store in this directory appear on the Tools menu.
  • wizard—VIs you store in this directory appear on the File menu.
  • www—Location of HTML files you can access through the Web Server.
  • help—Any VIs, .hlp, and .chm files that you want to make available on the Help menu.
  • LabVIEW Data— Any data files LabVIEW generates, such as .lvm or .txt files.

You also can create a directory anywhere on your hard drive to store LabVIEW files that you create.

When you open a VI you place in the labview\help, labview\project, and labview\wizard directories from the Help, Tools, or File menu, LabVIEW opens the VI in a private application instance (NI.LV.Dialog).


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit