Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Front Panel Page (Options Dialog Box)

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Requires: Base Development System

Select Tools»Options to display the Options dialog box and select Front Panel from the Category list to display this page.

Use this page to set front panel options.

This page includes the following components:

  • General—Use this section to set general front panel options.
    • Connector pane terminals default to Required—Sets new terminals connected on any VI's connector pane to Required instead of Recommended. This applies to connections made using the wiring tool and to subVIs created using Create SubVI. This checkbox does not contain a checkmark by default.
    • Use localized decimal point—Uses the decimal separator for the operating system instead of the period. This checkbox contains a checkmark by default. Remove the checkmark from this checkbox if you want LabVIEW to use periods in all cases for the decimal point.
      Note  Changes to this option take effect the next time you start LabVIEW.
    • Use numbers in icons of new VIs (1 through 9)—Places numbers on the icons of the first nine VIs you create after you launch LabVIEW. This option does not affect VIs you create from templates. This checkbox contains a checkmark by default.
    • Open the control editor with double-click—Allows you to double-click a control to display the Control Editor window. Use the Control Editor window to customize the appearance of a front panel object. This checkbox does not contain a checkmark by default.
    • Blink delay for front panel controls (milliseconds)—Sets the blinking delay for front panel objects. Blinking is a basic property you enable with Property Nodes. The default is 1,000 ms.
  • Tip Strips and Labeling—Use this section to configure front panel tip strips and labels.
    • Show tip strips on front panel controls—Displays tip strips when you idle the Operating tool over objects. You also can use the Show FP Tip Strips property to enable tip strips programmatically. This checkbox contains a checkmark by default.
    • Labels locked by default—Locks labels and captions in place for new objects on the front panel. This checkbox does not contain a checkmark by default.
    • Default label position: controlsSets the default label position for new controls.
      Note  The label positions available in the pull-down menu describe where the label is in relation to the object. The first part of the label position specifies what side of the object the label is on, and the second part specifies how to align the label along the side of the object you select.
    • Default label position: indicatorsSets the default label position for new indicators.
  • Control Style for New VIs—Use this section to change the style of the control or indicator LabVIEW creates in new VIs when you right-click a terminal and select Create»Control or Create»Indicator from the shortcut menu. The default is Modern style. Select File»VI Properties and select Editor Options from the Category pull-down menu to change the style of the control or indicator LabVIEW creates in existing VIs.
    Note  When you right-click a subVI terminal and select Create»Control or Create»Indicator from the shortcut menu, LabVIEW creates a control or indicator in the style of the subVI front panel object that corresponds to the subVI terminal. When you right-click a control or indicator and select Create»Control or Create»Indicator from the shortcut menu, LabVIEW creates a control or indicator in the style of the control or indicator you right-clicked.
    • Modern style—Creates a modern style control or indicator when you right-click a VI or function and select Create»Control or Create»Indicator from the shortcut menu.
    • Classic style—Creates a classic style control or indicator when you right-click a VI or function and select Create»Control or Create»Indicator from the shortcut menu.
    • System style—Creates a system style dialog control or indicator when you right-click a VI or function and select Create»Control or Create»Indicator from the shortcut menu. If a system control or indicator does not exist for the data type of the terminal, LabVIEW creates a control or indicator in modern style.
    • Silver style—Creates a silver style control or indicator when you right-click a VI or function and select Create»Control or Create»Indicator from the shortcut menu.
  • Front Panel Grid—Use this section to set front panel alignment grid options.
    • Show front panel grid—Displays the grid on the front panel of all open VIs. This checkbox contains a checkmark by default.
      • Default panel grid size (pixels)—Size in pixels of units on the front panel grid for all new VIs. The default is 12 pixels. Use the Editor Options page of the VI Properties dialog box to set the size of the grid for the current VI.
      • Contrast with panel background—Percentage of contrast with the front panel background to use when displaying the grid in all open VIs.
      • Enable panel grid alignmentEnables the grid alignment on the front panel of all open VIs so objects align to the grid when you place, move, or resize them. This checkbox contains a checkmark by default. You also can select Edit»Enable Panel Grid Alignment or Disable Panel Grid Alignment to toggle this behavior. Alternatively, you can press the <G> key as you place, move, or resize a control to toggle the grid alignment.
        • Resize new objects to grid sizes—Resizes new front panel objects so they align on all possible sides with the grid. The default size of new objects might not align with the current grid size. This checkbox does not contain a checkmark by default. For objects you cannot resize in a particular direction, LabVIEW resizes the objects in other valid directions. For example, you cannot resize a digital numeric control vertically, so LabVIEW resizes the control horizontally to align with the grid.
      • Alignment grid draw style—Indicates whether to draw the grid using solid lines, dots at grid junctions, or major and minor lines similar to the lines on graphing paper. The default is solid lines. LabVIEW draws a small diamond at the absolute coordinates (0,0) to indicate the origin of the alignment grid and uses major lines to draw the origin grid lines. The origin of the alignment grid is located out of view in the upper left portion of all new front panel and block diagram windows. Use the Scrolling tool to scroll the window so you can see the origin of the alignment grid. Use the origin as a reference point when using the Position property to programmatically position controls.

 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit