Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Icon Editor Dialog Box

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Requires: Base Development System

Display this dialog box in one of the following ways:

  • Double-click the icon in the upper right corner of the front panel window, block diagram window, or Control Editor window.
  • Right-click the icon in the upper right corner of the front panel window, block diagram window, or Control Editor window and select Edit Icon from the shortcut menu.
  • Select File»VI Properties or File»Control Properties to display the VI Properties dialog box or Control Properties dialog box, respectively. Then select General from the Category pull-down menu and click the Edit Icon button.
  • Right-click a project library, statechart, class, or XControl item in the Project Explorer window and select Properties from the shortcut menu to display the corresponding Properties dialog box. Then click the Edit button on the General Settings page.

Use this dialog box to create and edit icons.

Note  The Icon Editor dialog box displays icons in 24-bit color. However, LabVIEW displays icons only in 8-bit color on the block diagram. Therefore, the icon you create in this dialog box might appear slightly different from the corresponding icon on the block diagram.

This dialog box includes the following pages and components:

  • Templates—Displays icon templates you can use as a background for the icon. This page displays all .png, .bmp, and .jpg files in the LabVIEW Data\Icon Templates directory.
    • Category—Lists categories of icon templates from which you can select. The names of the categories correspond to the names of the subfolders in the LabVIEW Data\Icon Templates directory. The All Templates category is always visible and includes all icon templates in the LabVIEW Data\Icon Templates directory.
    • Filter templates by keyword—Specifies a keyword to use to filter the list of icon templates. The Icon Editor dialog box displays all icon templates whose name contains the keyword you specify.
  • Icon Text—Specifies the text you want to display in the icon.
    • Line text—Specifies a line of text for the icon.
    • Line color—Specifies the color of the corresponding line of text for the icon.
    • Font—Specifies the font of all text you enter on the Icon Text page.
    • Alignment—Specifies the alignment of all text you enter on the Icon Text page.
    • Size—Specifies the font size of all text you enter on the Icon Text page.
    • Center text vertically—Specifies whether to center the lines of text vertically within the icon. If you use an icon template with a banner and place a checkmark in this checkbox, the Icon Editor dialog box centers the icon text vertically within the body of the icon.
    • Capitalize text—Specifies whether to capitalize all text you enter on the Icon Text page.
  • Glyphs—Displays glyphs you can include in the icon. The Icon Editor dialog box displays all .png, .bmp, and .jpg files in the LabVIEW Data\Glyphs directory. By default, this page includes all glyphs in the Icon Library at ni.com. Select Tools»Synchronize with ni.com Icon Library to display the Synchronize with Icon Library dialog box and synchronize the LabVIEW Data\Glyphs directory with the most recent glyphs in the Icon Library.
    Tip  Select Edit»Import Glyph from File to display a file dialog box where you can locate and import a specific graphic file.
    • Category—Lists categories of glyphs from which you can select. The names of the categories correspond to the names of the subfolders in the LabVIEW Data\Glyphs directory. The All Glyphs category is always visible and includes all glyphs in the LabVIEW Data\Glyphs directory.
    • Filter glyphs by keyword—Specifies a keyword to use to filter the list of glyphs. The Icon Editor dialog box displays all glyphs whose name contains the keyword you specify.
  • Layers—Displays all layers of the icon. Select Layers»Show Layers Page to display this page if it is not already showing.
    • Icon Text—Displays the preview, name, opacity, and visibility of the Icon Text layer. This layer consists of all text you enter on the Icon Text page of the Icon Editor dialog box. You can change only the opacity and visibility of this layer.
    • User Layers—Displays the preview, name, opacity, and visibility of all user layers. You can select a user layer by clicking the corresponding preview on the Layers page or by using the Move tool to select a layer in the Preview area of the Icon Editor dialog box.
      • Add Layer—Adds a user layer.
      • Remove Layer—Removes the layer(s) you select.
      • Move Up—Moves the layer(s) you select up one layer level.
      • Move Down—Moves the layer(s) you select down one layer level.
    • Icon Template—Displays the preview, name, opacity, and visibility of the Icon Template layer. This layer consists of the icon template you select on the Templates page of the Icon Editor dialog box. You can change only the opacity and visibility of this layer.
  • Preview—Displays a magnified preview of the icon. The Preview updates with each change you make in the Icon Editor dialog box.
  • Icon—Displays a preview of the icon at its actual size. The Icon updates with each change you make in the Icon Editor dialog box.
  • RGB—Displays the RGB color components of the pixel corresponding to the cursor location.
  • XYZ—Displays the x-y position of the pixel corresponding to the cursor location. The Z value represents the total number of user layers in the icon.
  • Tools—Displays editing tools you can use to modify the icon manually. If you left-click while using an editing tool, LabVIEW uses the Line Color. If you right-click while using an editing tool, LabVIEW uses the Fill Color.
  • Horizontal Flip—Horizontally flips the user layer you select. If you do not select a layer, this tool flips all user layers.
    Note  You also can press the <F> key to flip a user layer you select.
  • Clockwise Rotate—Rotates the user layer you select in a clockwise direction. If you do not select a layer, this tool rotates all user layers.
    Note  You also can press the <R> key to rotate a user layer you select.
  • Line Color—Specifies the color to use for lines or borders. Click the Line Color rectangle to access a color picker from which you can select new colors.
  • Fill Color—Specifies the color to use for fill areas. Click the Fill Color rectangle to access a color picker from which you can select new colors.
  • Swap Colors—Interchanges the Line Color and Fill Color.

You can modify the Icon Editor dialog box if you want to create a custom editing environment. To modify the Icon Editor dialog box, download the Icon Editor source files at ni.com. When you create a custom icon editor, you can call the Discover Who Invoked the Icon Editor VI at labview\resource\plugins\IconEditor\Discover Who Invoked the Icon Editor.vi to obtain the name, path, and application reference for the current item whose icon is being edited. You can use this information to customize the icon in a way you specify. For example, you might want to add a custom glyph to the icon based on the VI or library type.

When you create a custom icon editor, you must configure the VI to open its own front panel on call. For simple VIs that do not need to rearrange their front panels before opening, use the Execution:Show Front Panel on Call property. For more complex VIs that need to rearrange their front panels before opening, use the Front Panel:Open method.


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit