Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

LabVIEW MathScript Window Menus (MathScript RT Module)

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Select Tools»MathScript Window to display the LabVIEW MathScript Window.

The File menu includes the following components:

  • New VI—Creates a new, blank VI.
  • New—Displays the New dialog box, which you can use to create different components in LabVIEW that help you build an application. You also can use the New dialog box to create a new component based on a template.
  • Open—Displays a standard file dialog box you can use to navigate to and open a file. Use the <Shift> key or the <Control> key to select multiple files.

    When you open a template (.vit or .ctt), LabVIEW retains the template file extension when you save the file. Select a template in the New dialog box to create a new VI, control, or global variable based on an existing template.
  • Close—Closes the LabVIEW MathScript Window.
  • Close All—Closes all open files and the LabVIEW MathScript Window. A confirmation dialog box prompts you to save any unsaved changes.
  • New Script—Opens a blank script in the Script Editor.
  • New Script Editor—Opens a new Script Editor in a separate window. You also can right-click the Script Editor on the Script page and select New Script Editor from the shortcut menu. Floating Script Editor windows have additional menu items.
  • Open ScriptLoads your existing script into the Script Editor. You also can click the Open Script button on the Script page to load the script you want.
  • Save ScriptSaves your script in the Script Editor. If you are saving a new script for the first time, a dialog box prompts you to name the script and determine its location.
  • Save Script As—Saves a copy of your current script with a new filename. You also can click the Save Script button in the Script Editor to save the script.
  • Create Project—Opens the Create Project dialog box to create a new project.
  • Open Project—Displays a standard file dialog box you can use to navigate to and open a project file.
  • LabVIEW MathScript Properties—Opens the LabVIEW MathScript Properties dialog box from which you can configure settings for the LabVIEW MathScript Window and the MathScript RT Module engine.
  • Recent Projects—Opens the most recently opened project files (.lvproj).
  • Recent Files—Opens the most recently opened files.
  • Exit—Closes the LabVIEW MathScript Window.

The Edit menu includes some components from the LabVIEW Edit menu.

The View menu includes some components from the LabVIEW View menu.

The Operate menu includes the following components:

  • Run Script—Executes all commands in the Script Editor. You also can click the Run Script button on the Script page to run the script.
  • Load DataLoads an existing data file into the LabVIEW MathScript Window. Data files contain numerical values for variables. You also can right-click the Variable List on the Variables page and select Load Data from the shortcut menu to load the data file you want.
  • Save DataSaves the variables in the Variable List to a data file. You also can right-click the Variable List on the Variables page and select Save Data from the shortcut menu to save the variables to a data file.
  • Connect to Remote PanelConnects to and controls a front panel running on a remote computer.
  • Debug Application or Shared Library—Displays the Debug Application or Shared Library dialog box, which you can use to debug a stand-alone application or shared library that you enabled for debugging with the Application Builder.

The Tools menu includes some components from the LabVIEW Tools menu.

The Window menu includes some components from the LabVIEW Window menu.

The Help menu includes some components from the LabVIEW Help menu.


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit