Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Environment Page (Options Dialog Box)

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Requires: Base Development System

Select Tools»Options to display the Options dialog box and select Environment from the Category list to display this page.

Use this page to set miscellaneous options for the LabVIEW environment.

This page includes the following components:

  • General—Use this section to set general environment options.
    • Automatically close VISA sessions—Automatically closes VISA sessions left open by the application when the top-level VI becomes idle. This checkbox does not contain a checkmark by default.
    • End text entry with Enter key—Allows you to press the <Enter> key on the keyboard to end text entry. This checkbox does not contain a checkmark by default. If you place a checkmark in this checkbox, the <Enter> key on the keyboard works like the <Enter> key on the numeric keypad, ending text entry. Press the <Ctrl-Enter> keys on the keyboard to embed new lines in a text box. (Mac OS X) Press the <Option-Return> keys. (Linux) Press the <Alt-Return> keys.
    • Lock automatic tool selection—Keeps automatic tool selection enabled when you press the <Tab> or <Shift-Tab> keys. This checkbox contains a checkmark by default. Remove the checkmark from this checkbox to configure LabVIEW to disable automatic tool selection when you press the <Tab> key and to toggle automatic tool selection when you press the <Shift-Tab> keys.
    • Skip Getting Started window on launch—Opens a new, blank VI instead of the Getting Started window when you launch LabVIEW. This checkbox does not contain a checkmark by default.
    • Disable ni.com updates in Getting Started window—Allows you to disable the automatic check for the latest articles on the ni.com website. You can disable these updates if you do not want the Getting Started window to access the Internet for this information. If you disable these updates, LabVIEW displays information in the Getting Started window based on the last update from ni.com.
    • Separate compiled code from new files—Configures LabVIEW to store compiled code separately from the source file of all new VIs, custom controls, global variables, LabVIEW classes, project libraries, XControls, and statechart libraries.
    • Maximum undo steps per VI—Sets the maximum number of steps that you can undo. If Use default is checked, you cannot edit this field. The default is 99 steps. The maximum number you can enter is 99. The minimum number you can enter is 1.
    • Maximum entries in recent project templates list—Sets the maximum number of items LabVIEW lists below the Create Project button on the Getting Started window.
    • Maximum entries in recent files lists—Sets the maximum number of projects and files LabVIEW lists below the Open Existing button on the Getting Started window. This option also sets the maximum number of files LabVIEW lists when you select File»Recent Files or File»Recent Projects.
    • Clear Password Cache—Clears the LabVIEW password cache. If you have password-protected VIs, LabVIEW caches the password when you access the block diagrams so that you do not have to re-enter the password in the same session. If you clear the password cache, the next time you access a password-protected block diagram, you must re-enter the password. When you clear the password cache, LabVIEW closes any open block diagrams of password-protected VIs.
  • Tip Strips and Labeling—Use this section to configure environment tip strips and labels.
    • Show tip strips—Displays tip strips. This checkbox contains a checkmark by default.
    • Show created constant labels—Shows labels with the name of the terminal from which the constant was created. This checkbox does not contain a checkmark by default.
  • Saving VIs—Use this section to set how LabVIEW saves VIs.
    • Treat read-only VIs as locked—Primarily used for source control, this option restricts editing on read-only VIs. If you do not place a checkmark in this checkbox, you can edit VIs even though they are read-only, but you cannot save them. If you place a checkmark in this checkbox, a VI that is read-only opens as locked, and you cannot edit it.
      • Do not save automatic changes—Does not prompt you to save any changes automatically implemented by LabVIEW in read-only VIs. You do not need to save these changes because LabVIEW implements the changes each time the VI is loaded. Changes automatically implemented by LabVIEW include recompiling, converting from an older version, and updating type definitions or fonts. This checkbox does not contain a checkmark by default. To select Do not save automatic changes, you first must place a checkmark in the Treat read-only VIs as locked checkbox.
    • Enable automatic saving for recovery—Automatically saves open files at the specified intervals. In the event of an irregular shutdown or system failure, the Select Files to Recover window displays recoverable files the next time you launch LabVIEW.
      • Save before a VI runs—Backs up open files before you run a VI.
      • Save before a VI runs and periodically—Backs up open files before you run a VI and at the intervals specified in the minutes field.
        • minutes—Specifies how often LabVIEW backs up open files. You must select Save before a VI runs and periodically to enable this field.
  • Fonts—Use this section to configure three categories of predefined fonts: the Application Font, Dialog Font, and System Font. Select the category you want to configure from the pull-down menu above the text box.
    • Font Chooser—Selects the predefined font type to configure.
      • Application Font—Determines the font used for text in the Controls and Functions palettes, the context help, and tip strips.
      • Dialog Font—Determines the font used for text in dialog boxes and system controls.
      • System Font—Determines the font used for text in the menu bar and shortcut menus
    • Use default font—Selects the default LabVIEW setting for the predefined font. Uses the font characteristics defined in the Font Style dialog box. This option is selected by default.
    • Font Style—Displays the Font Style dialog box, where you change font characteristics.
    • Font Sample—Displays a preview of the selected font.
  • Colors—Use this section to set color options.
    • Use default colors—Uses the default colors for all items listed in this dialog box. This checkbox contains a checkmark by default. Remove the checkmark from the checkbox if you want to click a rectangle to change its color.
      • Front Panel—Selects a color for the front panel of new VIs but does not affect existing VIs.
      • Block Diagram—Selects a color for the block diagram of new VIs but does not affect existing VIs.
      • Coercion Dots—Selects a color for the dots that indicate coercion of numerical data. This option affects only how LabVIEW displays VIs. It does not affect the VIs themselves.
      • Scrollbar—Selects a color for scroll bars. This option affects only how LabVIEW displays VIs. It does not affect the VIs themselves.
      • Blink Foreground—Selects the foreground color for a blinking object. This option affects a blinking object only in its blink state. Blinking is a basic property you enable with Property Nodes.
      • Blink Background—Selects the background color for a blinking object. This option affects a blinking object only in its blink state. Blinking is a basic property you enable with Property Nodes.
      • Menu Text(Windows and Linux) Selects a color for the text in menus.
      • Menu Background(Windows and Linux) Selects a color for the background in menus.
    • Custom Colors—Displays the set of user-defined colors from the color picker in the User Colors dialog box.
  • Debugging—Use this section to set debugging options.
    • Show warnings in Error List dialog by default—Displays warnings in addition to errors in the Error list window. A warning does not mean that the VI is incorrect. It points out a potential problem on the block diagram or recommends an action for consideration. This checkbox contains a checkmark by default.
  • NI Error Reporting(Windows) Use this section to set the options for the NI Error Reporting dialog boxes.
    Note  This section is unavailable if NI Error Reporting is disabled.
    • Do not notify of internal warnings on exit—Disables the Internal Warning Reporter dialog box so it does not appear when one or more warnings were detected during the last run of the program.
      • Automatically send internal warning reports to National Instruments—Sends an internal warning report automatically to National Instruments if one or more warnings occurs. This option is available only if the Do not notify of internal warnings on exit checkbox is selected.
    • Relaunch LabVIEW on crash—Relaunches LabVIEW after you close the Crash Reporter dialog box. LabVIEW relaunches based on how you previously launched LabVIEW, such as by double-clicking the .EXE or passing in command-line arguments.
      Note  LabVIEW cannot relaunch if the total string length of the command-line argument exceeds 255 characters.


      Remove the checkmark from this checkbox if you do not want LabVIEW to restart after an internal LabVIEW error occurs.
    • Close Report Sender dialog when finish sending—Closes the Report Sender dialog box after the error report is finished sending. If an error occurs while sending, the Report Sender dialog box will not automatically close.
  • Internal Warnings and Errors—Use this section to set the options for the internal warnings and errors dialog boxes.
    Note  (Windows) This section is available if NI Error Reporting is disabled.
    • Prompt to investigate internal warnings and errors on startup(Mac OS X and Linux) Displays the Investigate Previous Internal Error or Warning window when you start LabVIEW after an internal LabVIEW error, such as panel.cpp, line 2978, occurs. This checkbox contains a checkmark by default. Remove the checkmark from this checkbox if you do not want LabVIEW to display the Investigate Previous Internal Error or Warning window when you start LabVIEW after an internal LabVIEW error occurs.
  • Compiler—Use this section to configure when the LabVIEW compiler prioritizes execution speed over editor responsiveness.
    • Compiler optimizations—Indicates how complex a VI must be before the compiler limits optimizations to improve editor responsiveness. If the complexity of a VI is lower than the threshold indicated by this slider, the compiler uses full compiler optimizations, thereby improving the execution speed of the VI. If the complexity of a VI is higher than the threshold, the compiler limits optimizations in order to improve editor responsiveness for the VI.

      To determine the complexity of a specific VI, refer to the Compiled Code Complexity value on the Memory Usage page of the VI Properties dialog box. Use this complexity value in conjunction with the optimizations slider to choose between editor responsiveness and VI execution speed.

      The following caveats and recommendations apply to this slider:
      • The value of the Compiler optimizations slider applies to all VIs. LabVIEW determines whether to apply compiler optimizations to every VI based on the single threshold indicated by the slider.
      • The compiler ignores the threshold indicated by the Compiler optimizations slider when building an application for targets running on PowerPC or ARM architecture (VxWorks and NI Linux Real-Time targets, respectively).
      • Changing the value of this slider does not automatically recompile any VIs.
      • National Instruments recommends that you reset the Compiler optimizations slider to 5 after you temporarily change the value to edit or compile complex VIs. A threshold of 5 correctly prioritizes editor responsiveness or execution speed for the vast majority of VIs.
  • Linux(Linux) Use this section to set environment options available only on Linux.
    • Use native appearance—Selects which user interface style to support on Linux. The default is auto.
    • Use Control as menu/meta key—Allows you to use the Control key for menu shortcut accelerators. This checkbox is checked by default.
    • Use pixel-based font sizes—Causes LabVIEW to use pixel size instead of point size to select which fonts to load. This checkbox is checked by default. Placing a checkmark in this checkbox causes text to be smaller on large (100 dpi) displays but results in higher-quality cross-platform VIs.
    • Show/hide floating windows on focus change—Causes LabVIEW to show or hide palettes and hide all floating windows when another application has window focus. This checkbox is checked by default.
      Note  This option works well only if you have to click a window to give it focus. If the focus policy of the window manager is configured to have focus follow the mouse, you should remove the checkmark from this checkbox.
    • Keep floating windows on top—Causes floating windows, such as the Controls and Functions palettes and the Context Help window, to appear on top of other windows. The window manager must support this feature or this option has no effect. Some versions of GNOME and KDE support floating windows. This checkbox is checked by default.

 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit