Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Adding Items to a Project

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Use the Project Explorer window to add LabVIEW files, such as VIs and libraries, as well as files not specific to LabVIEW, such as text files and spreadsheets, to a target in a LabVIEW project. When you add files to a project, LabVIEW creates items in the Project Explorer window to represent the files on disk. You can create an organizational structure for items in a project.

An item can appear only once under a target. For example, if you add a file from a directory on disk to the My Computer target and then add the entire directory to the My Computer target, LabVIEW does not include the file again.

From the Items page in the Project Explorer window, you can add items under a target in a project in the following ways:

  • Right-click a target and select New»VI from the shortcut menu to add a new, blank VI. You also can select File»New VI or Project»Add To Project»New VI to add a new, blank VI. You also can add a VI to the project by selecting the VI icon in the upper right corner of a front panel or block diagram window and dragging the icon to the target. When you add a VI to the project, LabVIEW automatically adds its entire hierarchy to the Project Explorer window under Dependencies.
  • Right-click a target and select New from the shortcut menu. Then select the item you want to add to the project.
  • Right-click a target and select New»Virtual Folder from the shortcut menu to add a virtual folder under a target. A virtual folder is a folder in the project that organizes project items and does not represent files on disk. You also can create subfolders by right-clicking a virtual folder and selecting New»Virtual Folder from the shortcut menu.
  • Right-click a target or a folder under the target, select Add»File from the shortcut menu, and select the file you want to add from the dialog box. You also can select the target, select Project»Add To Project»File, and select the file you want to add from the dialog box.
  • Right-click a target or a folder under the target, select Add»Folder (Snapshot) from the shortcut menu, and select the file(s) you want to add from the dialog box. You also can select the target, select Project»Add To Project»Folder (Snapshot), and select the file(s) you want to add from the dialog box.
  • Right-click a target or a folder under a target and select Add»Folder (Auto-populating) from the shortcut menu to display a file dialog box. You also can select a target and then select Project»Add To Project»Folder (Auto-populating).
  • Right-click a target, or a folder or library under a target, and select Add»Hyperlink from the shortcut menu. The Hyperlink Properties dialog box appears. You also can select the target and select Project»Add to Project»Hyperlink to display the Hyperlink Properties dialog box.
  • Use the Add File, Add Item, or Add Item From Memory method to add items to a project programmatically. Use the HyperLink Address property to set the address of a hyperlink item.
  • (Windows and Mac OS X) Select an item or directory on disk and drag it to the target.
Note  You cannot drag and drop items in the Project Explorer window to the file system.

You also can add new LabVIEW files to a project from the New dialog box. Select File»New or Project»Add To Project»New to display the New dialog box. In the New dialog box, select the item you want to add and place a checkmark in the Add to project checkbox. If you have multiple projects open, select the project to which you want to add the item from the Projects list.

Items you add to the Project Explorer window can include icons.


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit