Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Automatically Cleaning Up the Block Diagram

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

LabVIEW can reroute all existing wires and reorder objects on the block diagram.

Complete the following steps to reroute all existing wires and reorder all existing objects on the block diagram.

  1. Configure the clean up options. Select Tools»Options to display the Options dialog box and select Block Diagram from the Category list. On the Block Diagram page, you can configure LabVIEW to automatically move controls to the left side of the containing diagram and indicators to the right side of the containing diagram, place a certain number of pixels between block diagram objects and wires, and compact the block diagram layout.
  2. (Optional) Right-click a structure and select Exclude from Diagram Cleanup to allow LabVIEW to move the structure without reorganizing the contents of the structure.
  3. Select Edit»Clean Up Diagram. You also can click the Clean Up Diagram button on the block diagram toolbar or press the <Ctrl-U> keys. (Mac OS X) Press the <Command-U> keys. (Linux) Press the <Alt-U> keys.
Note Note  You also can select specific objects to clean up, such as wires or individual nodes. To select multiple objects, press <Shift>-click. When you select objects to clean up, the Clean Up Diagram button changes to indicate Partial Diagram Clean Up. LabVIEW cleans up only the objects that you select and not the entire block diagram. When you select specific wires to clean up, LabVIEW reorganizes only the wires and not objects attached to the wires.

You also can reroute wires and reorder objects you select on the block diagram.

Complete the following steps to reroute and reorder a selection of existing wires and objects on the block diagram automatically.

  1. (Optional) Right-click a structure and select Exclude from Diagram Cleanup to allow LabVIEW to move the structure without reorganizing the contents of the structure.
  2. Click and drag a selection rectangle around the items you want to clean up.
Note Note  LabVIEW does not clean up the block diagram if you do not select any structures and none of the objects you select overlap each other, or if the selection contains only wires without corresponding inputs and outputs.
  1. (Optional) Press the <Shift> key and click and drag a selection rectangle around additional objects to create multiple selections. You also can press the <Shift> key while you click objects you want to deselect.
  2. Select Edit»Clean Up Selection.

 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit