Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Creating a Library Icon

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Create an icon to represent a project library, statechart, class, or XControl graphically. Use the Icon Editor dialog box to create or edit icons.

LabVIEW applies a library icon to the icon of all objects in the library. National Instruments recommends creating only a banner for the library icon. The icon for each object in the library then includes the banner, and you can modify the body of the icon to provide information about the specific object.

Creating a Project Library Icon

Complete the following steps to create an icon for a new project library.

  1. Right-click the project library item in the Project Explorer window and select Properties from the shortcut menu to display the Project Library Properties dialog box. LabVIEW creates a banner as the default icon for a new project library. Notice the default project library icon in the VI Icon Template section of the General Settings page.
  2. Click the Edit button on the General Settings page to display the Icon Editor dialog box.
  3. (Optional) Use the Fill tool on the right side of the Icon Editor dialog box to fill the banner of the icon with a different color.
  4. Use the Text tool to enter text in the banner of the icon. While the text is active, you can move the text by pressing the arrow keys.
  5. (Optional) Select File»Save As»Template to display the Save Icon As dialog box and save the icon as a template for later use. LabVIEW saves icon templates as 256-color .png files.
  6. Click the OK button to save the icon information with the project library and close the Icon Editor dialog box. Notice that the 256 Colors icon on the General Settings page of the Project Library Properties dialog box displays the icon you created.
  7. Click the OK button to close the Project Library Properties dialog box.
Tip  You can use the Apply Icon to VIs button in the General Settings page of the Project Library Properties dialog box to automatically apply an existing project library icon to VIs in the project library.

Creating an Icon for a VI in the Project Library

Complete the following steps to create an icon for a new VI in the project library.

  1. Right-click the project library item in the Project Explorer window and select New»VI from the shortcut menu to create and open a new VI. Notice that the VI icon in the upper right corner of the front panel window includes the project library icon.
  2. Double-click the VI icon to display the Icon Editor dialog box.
  3. Select Layers»Show Layers Page to display the Layers page if it is not already showing. Notice the following items on this page:
    • The project library icon appears as a user layer called NI_Library.
      Note  LabVIEW reverts any changes you make to the opacity or visibility of the NI_Library user layer the next time you modify the project library icon. If you want to modify the opacity or visibility of the NI_Library user layer permanently, apply the changes to the project library icon directly.
    • A user layer called NI_IconNumber contains a number that indicates how many new VIs, up to nine VIs, you have opened since launching LabVIEW.
      Note  To disable this numbering, select Tools»Options»Front Panel and remove the checkmark from the Use numbers in icons of new VIs (1 through 9) checkbox.
    • A user layer called VI Icon contains a one-pixel black frame for the icon.
    • The VI icon uses the White w border template, as shown in the Icon Template section of the Layers page.
  4. (Optional) Click the preview of the NI_IconNumber user layer and press the <Delete> key to delete the layer.
  5. On the Icon Text page, enter up to four lines of icon text for the body of the icon. You can configure the font, alignment, size, and color of the text. If you place a checkmark in the Center text vertically checkbox, the Icon Editor dialog box centers the icon text vertically within the body of the icon.
  6. On the Glyphs page, drag and drop glyphs onto the Preview area.

    Press the <F> key or the <R> key to flip a glyph horizontally or rotate a glyph clockwise, respectively, as you move the glyph. You also can double-click a glyph to place the glyph in the top-left corner of the icon. You can browse glyphs by category or by keyword.
  7. Use the Move tool to move any glyph. Each glyph is on a separate layer and therefore moves separately. Notice that the rest of the icon becomes dimmed when you select a glyph so you can identify which selection you are moving.
  8. Use the editing tools on the right side of the Icon Editor dialog box to edit the icon further if necessary.

    The Icon Editor dialog box creates a new user layer for each non-consecutive use of the editing tools. Select Layers»Create New Layer to create a new user layer during consecutive uses of the editing tools.
    Note  You cannot modify the icon template or icon text with the editing tools on the right side of the Icon Editor dialog box. Use the Templates page and the Icon Text page to modify the icon template and icon text, respectively.
  9. Use the Layers page to configure the name, opacity, visibility, and order of the layers of the icon.
  10. Click the OK button to save the icon information with the VI and close the Icon Editor dialog box.

 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit