Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Customizing Controls and Indicators that are Parts of Controls and Indicators

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

A control or indicator can include other controls or indicators as parts. In this topic, controls and indicators used as parts of other controls and indicators are referred to as component controls and indicators. For example, a slide control uses a digital numeric control for a digital display, making the digital numeric control a component control. You can find out if part of a control or indicator is a component control or indicator by trying to move the part around the front panel. You can move a component control or indicator independently of the parent control or indicator.

Often, component controls or indicators also are made up of parts. When you edit the original control or indicator in the Control Editor window, the component control or indicator behaves as a single part. That is, you cannot change or move individual parts of the component control or indicator. However, you can customize the component control or indicator by displaying a second Control Editor window that contains only the component control or indicator. You do not have to place the original Control Editor window in customize mode to display a second Control Editor window unless you are unable to select the component control or indicator in edit mode.

Complete the following steps to customize a component control or indicator.

  1. In the front panel window, right-click a control or indicator that you want to customize and select Advanced»Customize from the shortcut menu to display the Control Editor window.
  2. Right-click the component control or indicator in the Control Editor window and select Advanced»Customize from the shortcut menu to display another Control Editor window that contains only the component control or indicator.
  3. Click the Change to Customize Mode button to place the new Control Editor window in customize mode.
  4. Make the changes you want to the individual parts of the component control or indicator. You can change the size, color, and relative position of the elements of a control or indicator and import images into the control or indicator.
  5. Select File»Apply Changes to apply the changes to the component control or indicator in the original Control Editor window. The Apply Changes menu item is available only after you make changes to the original component control or indicator. If you make changes to a component control or indicator and try to close the Control Editor window without selecting File»Apply Changes, LabVIEW displays a message asking if you want to replace the original component control or indicator with the custom component control or indicator.

You can nest Control Editor windows indefinitely. However, most controls or indicators use other controls or indicators as parts only at the top level. An exception is the graph, which uses complicated controls as parts that in turn use other controls as parts.

Component Parts Visible in the Front Panel Window

If a component control or indicator is visible in the front panel window, you can display a Control Editor window that contains only the component control or indicator directly from the front panel window.

Complete the following steps to customize a component control or indicator directly from the front panel window.

  1. Right-click the component control or indicator you want to customize and select Advanced»Customize from the shortcut menu to display a Control Editor window that contains only the component control or indicator.

    You also can use the Positioning tool to select the component control or indicator you want to customize and then select Edit»Customize Control to display the Control Editor window.
  2. Make the changes you want to the component control or indicator. You can change the size, color, and relative position of the elements of a control or indicator and import images into the control or indicator.
  3. Select File»Apply Changes to apply the changes to the component control or indicator. The Apply Changes menu item is available only after you make changes to the original component control or indicator. If you make changes to a component control or indicator and try to close the Control Editor window without selecting File»Apply Changes, LabVIEW displays a message asking if you want to replace the original component control or indicator with the custom component control or indicator.

 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit