Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Creating Custom Controls and Indicators from the Front Panel

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Complete the following steps to create a custom control or indicator from the front panel. You can edit only one control or indicator at a time. Refer to the caveats and recommendations before you begin creating custom controls and indicators.

  1. Use the Positioning tool to select a control or indicator you want to customize.
  2. Select Edit»Customize Control to display the Control Editor window.
    Note Note  You also can right-click the control or indicator you want to customize and select Advanced»Customize from the shortcut menu to display the Control Editor window.
  3. Make the changes you want to the control or indicator. You can change the size, color, and relative position of the elements of a control or indicator and import images into the control or indicator.
  4. Select File»Apply Changes to apply the changes to the control or indicator. The Apply Changes menu item is available only after you make changes to the original control or indicator. If you make changes to a control or indicator and try to close the Control Editor window without selecting File»Apply Changes, LabVIEW displays a message asking if you want to replace the original control or indicator with the custom control or indicator.
  5. (Optional) Select File»Save to save the custom control or indicator so you can use it in other VIs. You can save the custom control or indicator in a directory or in an LLB. If you do not want to save the custom control or indicator for use in other VIs, close the Control Editor window without saving the custom control or indicator.

You also can create a custom control or indicator using the New dialog box.

Note  It is not necessary to save a custom control to replace the original control. If the control you customized is a type definition and you replace the original control, LabVIEW prompts you to save the type definition when you close the calling VI.

 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit