Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Creating Custom Controls and Indicators Using the New Dialog Box

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Complete the following steps to create a custom control or indicator from the New dialog box. Refer to the caveats and recommendations before you begin creating custom controls and indicators.

  1. Select File»New to display the New dialog box.
  2. From the Create New list, select Other Files»Custom Control.
  3. Click the OK button to display the Control Editor window.
  4. Place a control or indicator in the Control Editor window.
  5. Make the changes you want to the control or indicator. You can change the size, color, and relative position of the elements of a control or indicator and import images into the control or indicator.
  6. Select File»Save to save the custom control or indicator so you can use it in other VIs. You can save the custom control or indicator in a directory or in an LLB. If you do not want to save the custom control or indicator for use in other VIs, close the Control Editor window without saving the custom control or indicator.
Note  When you add the custom control or indicator to a front panel, the custom control does not require the .ctl file. When you add a type definition to a front panel, the type definition requires the .ctl file.

You also can create a custom control or indicator using the Edit menu or by right-clicking My Computer in the Project Explorer window and selecting New»Control from the shortcut menu.


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit