Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Customizing Run-Time Shortcut Menus for Controls Statically

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Complete the following steps to customize a run-time shortcut menu for a control statically.

  1. Right-click a control and select Advanced»Run-Time Shortcut Menu»Edit from the shortcut menu to display the Shortcut Menu Editor dialog box.
Note  Controls or indicators with customized run-time shortcut menus that you add into an array shell use the shortcut menu of the array.
  1. Select Custom from the Menu Type pull-down menu of the dialog box.
  2. Select User Item from the Item Type pull-down menu. To add LabVIEW default menu items to a custom run-time shortcut menu, select Application Item and select the LabVIEW shortcut menu items you want.
  3. In the Item Name text box, type the text you want for this item. The same text appears in the Item Tag field. You can modify the tag name to give the shortcut menu item a unique identifier. The block diagram uses the tag name to identify the shortcut menu item programmatically. Shortcut menu item tags can have the same name as shortcut menu item names.
  4. Click the blue plus button on the toolbar to add more items to the shortcut menu. Click the red button to delete items.
  5. Select File»Save. In the dialog box that appears, select whether you want to save the shortcut menu with the control or save the shortcut menu to a file. If you select Save to file, the dialog box appears, allowing you to name the shortcut menu and select a location on disk to save to. When you load the VI, the customized shortcut menu automatically loads.
  6. Configure a Shortcut Menu Selection (User) event to handle the selection of the items.

You can arrange the shortcut menu hierarchy in the dialog box by clicking the arrow buttons on the toolbar, using the hierarchy manipulation options in the Edit menu, or by dragging and dropping. You can expand or collapse hierarchies by clicking the submenu glyphs or by choosing from the expand or collapse options in the Edit menu. To add separators, select Separator in the Item Type pull-down menu.


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit