Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Adding the Contents of a VI from the Functions or Controls Palette

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Add the contents of a VI from the Functions or Controls palette to a new or existing VI.

Adding the Contents of a VI Block Diagram from the Functions Palette

When you place a VI from the Functions palette, you can place the contents of the VI block diagram instead of a subVI call by using the Place VI Contents shortcut menu in the Edit Controls and Functions Palette Set dialog box.

Complete the following steps to add the block diagram contents of an existing VI from the Functions palette.

  1. Create a VI whose block diagram contains the contents you want to add to the block diagram when you select the VI icon on the Functions palette.
  2. Select Tools»Advanced»Edit Palette Set to display the Edit Controls and Functions Palette Set dialog box.
  3. Navigate to the location on the Functions palette where you want to add the VI.
  4. Right-click the palette and select Insert»VI(s) from the shortcut menu.
  5. In the file dialog box that appears, navigate to the VI you want to add to the palette.
  6. Select the VI you want to add to the palette and click the Open button.
  7. Right-click the VI icon and select Place VI Contents from the shortcut menu.
  8. Click the Save Changes button in the Edit Controls and Functions Palette Set dialog box to open the Preview Palette Changes dialog box and save the changes.
  9. Click the Continue button to accept the changes and close the Edit Controls and Functions Palette Set dialog box.
  10. Navigate to the location of the VI you added to the Functions palette.
  11. Click the VI icon and add it to a block diagram to add the entire contents of the VI block diagram from the palette.

Adding the Contents of a VI Front Panel from the Controls Palette

You can add VIs to the Controls palette. Unlike adding custom controls, VIs allow you to add multiple controls or decorations to the front panel.

Complete the following steps to add the front panel contents of an existing VI from the Controls palette.

  1. Create a VI whose front panel contains the contents you want to add to the front panel when you select the VI icon on the Controls palette. Save and close the VI.
  2. Select Tools»Advanced»Edit Palette Set to display the Edit Controls and Functions Palette Set dialog box.
  3. Navigate to the location on the Controls palette where you want to add the VI.
  4. Right-click the palette and select Insert»Custom Control(s) from the shortcut menu.
  5. In the file dialog box that appears, navigate to the VI you want to add to the palette. You may have to select the Files of type pull-down menu and include all file extensions in your search because you are navigating to a VI, not a control.
  6. Select the VI you want to add to the palette and click the Open button.
  7. Click the Save Changes button in the Edit Controls and Functions Palette Set dialog box to open the Preview Palette Changes dialog box and save the changes.
  8. Click the Continue button to accept the changes and close the Edit Controls and Functions Palette Set dialog box.
  9. Navigate to the location of the VI you added to the Controls palette.
  10. Click the VI icon and add it to a front panel to add the entire contents of the VI front panel from the palette.
Note Note  If the VI you create contains objects on both the front panel and block diagram and you add the VI from the Controls palette or the VI is marked as Place VI Contents from the Functions palette, LabVIEW adds those objects to the front panel or block diagram as well.

 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit