Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Application Methods

LabVIEW 2013 Help

Edition Date: June 2013

Part Number: 371361K-01

»View Product Info

Requires: Base Development System

View the class hierarchy.

MethodDescription
Bring To FrontOn Windows and Mac OS X, brings the application windows to the front. Details
Browse DataSocketLaunches the DataSocket Browser dialog box to establish a connection to a DataSocket item. Details
Class Operator:GetGets the operator VI associated with the specified class. Returns FALSE if it does not find the operator VI. Details
Class Operator:RemoveRemoves the operator VI associated with the specified class. Returns FALSE if it does not find the operator VI. Details
Class Operator:Remove AllRemoves all operator VIs associated with all classes. Details
Class Operator:SetSets an operator VI for the specified class. Returns FALSE if it fails. Details
Clear Application Builder CacheDeletes all VI object files from the object cache that a build specification compiles. Details
Clear Compiled Object CacheDeletes all compiled code in the User object cache. Details
Clipboard:EmptyClears the clipboard. Details
Clipboard:Get ImageReturns the image currently stored on the clipboard. Details
Clipboard:Read From ClipboardReads text from the system clipboard. Details
Clipboard:Write to ClipboardWrites text to the system clipboard. Details
Connection Responsiveness:CheckChecks if the VI Server connection is responsive. Details
Connection Responsiveness:InformationGets and sets how often LabVIEW checks if a VI Server connection is responsive. Details
Data Type ColorReturns the color associated with a data type. Details
Debug Connection:Close Debug ConnectionCloses the connection to the application or shared library specified in Debug Name. Details
Debug Connection:List Applications or Shared LibrariesReturns the list of applications and shared libraries you can debug on the computer specified by Server Address. Details
Debug Connection:Open Debug ConnectionOpens a connection to the application or shared library you can debug. Details
Get Active VI ReferenceReturns a reference to the VI whose window is currently active (focused). If the active window is not a VI, this method returns Not A Ref. Details
Get Environment Mode Display NameReturns the display name of the environment mode you specify. Details
Get VI Hierarchy Image ScaledGets the scaled image of the VI Hierarchy. Details
Get VI:BookmarksReturns the bookmark information for the VI specified in VI Path. You do not need to load the VI into memory in order to read the bookmark information. This method returns an error if the VI is password protected, if the VI is saved in an earlier version of LabVIEW and is not currently in memory, or if the VI does not have a block diagram. Details
Get VI:ConPane DataTypeReturns the data type of the connector pane as variant data without loading the VI. Details
Get VI:DescriptionReturns the description stored in the VI description field on the Documentation page of the VI Properties dialog box for the specified VI. Unlike the VI Description property, this method does not load the VI into memory. Details
Get VI:Editor VersionReturns the version of LabVIEW that last saved the VI. The version of LabVIEW that last saved the VI might be different from the file format version of the VI. For example, if you use LabVIEW 9.0.1 to save a VI, the VI has a file format version of 9.0. To obtain the file format version of the VI, use the Get VI:Version method. LabVIEW does not open the VI when retrieving the version information. If you specify a path to a file that is not a VI, LabVIEW returns error 6559. Details
Get VI:Help InfoReturns the Help path and Help tag that appear on the Documentation page of the VI Properties dialog box for the specified VI. This method does not load the VI into memory. Details
Get VI:IconReturns the icon of the specified VI without loading the VI into memory. Details
Get VI:Is ProbeReturns whether the specified VI is a probe without loading the VI. Details
Get VI:Qualified NameReturns the qualified name of the referenced VI without loading the VI. Details
Get VI:Revision HistoryReturns the revision history that appears when you click the Revision History button on the General page of the VI Properties dialog box of the specified VI. This method does not load the VI into memory. Details
Get VI:TitleReturns the name that appears in the title bar of the specified VI. This method does not load the VI into memory. Details
Get VI:VersionReturns the LabVIEW file format version of the VI. The file format version of the VI might be different from the version of LabVIEW in which the VI was last saved. For example, if you use LabVIEW 9.0.1 to save a VI, the VI has a file format version of 9.0. To obtain the version of LabVIEW in which the VI was last saved, use the Get VI:Editor Version method. LabVIEW does not open the VI when retrieving the version information. If you specify a path to a file that is not a VI, LabVIEW returns error 6559. Details
LabVIEW Class:All Methods of LVClassReturns an array of names and an array of paths for all methods of a class. The methods of the class are member VIs that can be called as subVIs. In other words, LabVIEW excludes global VIs, control VIs, and polymorphic VIs from the output arrays. Details
LabVIEW Class:CreateCreates a new LabVIEW class. Details
LabVIEW Class:Get Implementing VI PathReturns the path to the VI that implements the specified method within the specified class. If the specified class does not implement the method, this method returns an ancestor VI implementation. Details
LabVIEW Class:OpenOpens the LabVIEW class specified by Path. Details
Library:CreateCreates a new LabVIEW project library. Details
Library:Deploy LibrariesDeploys library files to the specified computer. Details
Library:Deploy LibraryDeploys a library file to the specified computer. Details
Library:Get File LabVIEW VersionReturns the LabVIEW file format version of the library. The file format version of the library might be different from the version of LabVIEW in which the library was last saved. For example, if you use LabVIEW 9.0.1 to save a library, the library has a file format version of 9.0. Details
Library:Get Ref By Qualified NameRetrieves a reference to a LabVIEW project library that is already loaded within the application instance. If the library cannot be found in memory, LabVIEW returns Not A Refnum. Details
Library:OpenOpens the LabVIEW project library specified by Path. Details
Library:Undeploy LibrariesUndeploys library files from the specified computer. Details
Library:Undeploy LibraryRemoves a library from a target. Details
LVRT:Disconnect From SlaveDisconnects the open connection between LabVIEW and an RT target. Details
Mass CompileLoads and compiles VIs in a directory, including VIs in subdirectories, for the specified application instance. Details
Menus:RefreshRefreshes the File, Tools, and Help menus from disk programmatically. Details
New LabVIEW DocumentCreates a new LabVIEW document. This method achieves the same results as when you create a new document in the New dialog box. Details
NI Security:Get Access RightsValidates the access control list with the current application user logged in. Details
NI Security:Invoke Login DialogInvokes the NI Security Login dialog box programmatically. Details
NI Security:LoginLogs a user into the NI domain. Details
NI Security:LogoutLogs the current user out of the NI domain and reverts to the default user. Details
Open:LabVIEW DocumentOpens a LabVIEW document. Details
Open:Recently Opened FileOpens the file specified by Index from the most recently used file list. Details
Open:Recently Opened ProjectOpens the project specified by Index from the most recently used project list. Details
Palettes:Close All PalettesCloses the Controls and Functions palette sets programmatically. To close the palette sets, add the Palettes:Close All Palettes method to the block diagram and run the VI. Details
Palettes:Get Palette Item PathReturns the path to the palette item you specify. Details
Palettes:RefreshUpdates the Controls and Functions palette set programmatically. To update the palette set, place the Palettes:Refresh method on the block diagram to the right of the Write Palette VI and run the VI. This method is similar to the Save Changes button on the Edit Controls and Functions Palette Set dialog box. Details
Project:Get File LabVIEW VersionReturns the LabVIEW file format version of the project. This version might be different from the version of LabVIEW in which the project was last saved. Details
Project:NewCreates a new, empty LabVIEW project. You also can use the Project Explorer window to create a new project. Details
Project:New with PromptsCreates a new, empty LabVIEW project and prompts the user to add any open VIs from the main application instance. Details
Project:OpenLoads a LabVIEW project from disk. If the project is already in memory, this method returns a reference to the existing project. You can use this reference with the Project properties. You also can select File»Open Project to navigate to and open a project. Details
Recently Opened:LV FilesGets the list of most recently used files from LabVIEW and displays the paths and filenames. This method returns the same list as if you selected File»Recent Files. Details
Recently Opened:LV ProjectsGets the list of most recently used LabVIEW projects from LabVIEW and displays the paths and project names. This method returns the same list as if you selected File»Recent Projects. Details
Remote Panel:Client Release ControlReturns control of the remote front panel to the server. The server grants control to the next client in the queue or regains control if no requests are in the queue. Details
Remote Panel:Client Request ControlRequests control of the front panel of a VI on the server computer. Details
Remote Panel:Close Connection To ServerCloses a connection to a VI on the server computer. Details
Remote Panel:Open Connection To ServerOpens a connection to a server and displays the front panel of a VI on the server computer. You also can request control of the front panel. Details
RestartQuits and then restarts LabVIEW. Details
Scene:Drawable:Geometry:New BoxCreates a geometry that you can use to set an object in a 3D scene to a box. Details
Scene:Drawable:Geometry:New ConeCreates a geometry that you can use to set an object in a 3D scene to a cone. Details
Scene:Drawable:Geometry:New CylinderCreates a geometry that you can use to set an object in a 3D scene to a cylinder. Details
Scene:Drawable:Geometry:New Height FieldCreates a new height field in a 3D scene. Details
Scene:Drawable:Geometry:New MeshCreates a new mesh in a 3D scene. Details
Scene:Drawable:Geometry:New SphereCreates a geometry that you can use to set an object in a 3D scene to a sphere. Details
Scene:Drawable:New TextCreates a new text object in a 3D scene. Details
Scene:New Clip PlaneCreates a new clip plane in a 3D scene. Details
Scene:New LightCreates a new light in a 3D scene. Details
Scene:New ObjectCreates a new object in a 3D scene. Details
Scene:New TextureGets a reference to a texture to apply to a geometry in a 3D scene. Details
Scene:New WindowCreates a new window in which LabVIEW generates the 3D scene. Details
Scene:Read Scene FileReads a 3D scene file that you create with the Scene:Write Scene File method. The file being read must have a .lvsg or .dae extension. Details
Scene:Write Scene FileWrites a new 3D scene file. The filename must end with a .lvsg or .dae extension. Details
Statechart:CreateCreates a new statechart. You must save the statechart to disk. Details
Statechart:OpenOpens the statechart specified by Path. Details
User Interaction:Hilight Palette Menu ItemOpens the Controls or Functions palette and highlights the specified control or function. Details
User Interaction:Invoke Menu ItemSimulates the user selecting a menu item. In general, this method works on global menu items but not document-specific menu items, in which case the method fails silently. Details
User Interaction:Place Object On CursorPlaces an object on the cursor so the object is ready to add to the front panel window or the block diagram window. You can specify the object using either style or path. Details
User Interaction:Place Palette Object on CursorPlaces a palette object on the cursor so the object is ready to add to the front panel window or the block diagram window. Details
VIs Strings:ExportExports to a tagged text file all the User Interface related strings of the VIs specified by VI Array. Details
VIs Strings:ImportImports to a tagged text file all the User Interface related strings of the VIs specified by VI Array. Details
Web Server:ConfigureConfigures the LabVIEW Web Server with the given file. If you do not wire Web Server to the configuration file, Web Server uses the default configuration file. Details
XControl:CreateCreates an XControl library. Details
XControl:OpenOpens an XControl library and returns a reference to it. Details

 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit