Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

1. Creating the Simulation Diagram (Control Design and Simulation Module)

LabVIEW 2012 Control Design and Simulation Module Help

Edition Date: June 2012

Part Number: 371894G-01

»View Product Info

You create a simulation diagram by placing a Control & Simulation Loop on the LabVIEW block diagram. The Control & Simulation Loop contains parameters that affect the simulation, such as which ODE solver to use and how long to run the simulation. Complete the following steps to create the simulation diagram.

  1. Launch LabVIEW and select File»New VI to create a new, blank VI.
  2. Select Window»Show Block Diagram to view the block diagram. You also can press the <Ctrl-E> keys to view the block diagram.
  3. If you are not already viewing the Functions palette, select View»Functions Palette to display this palette.
  4. Select Control Design & Simulation»Simulation to view the Simulation palette.
  5. Click the Control & Simulation Loop icon:

  6. Move the cursor over the block diagram. Click to place the top left corner of the loop, drag the cursor diagonally to establish the size of the loop, and click again to place the loop on the block diagram.

    The simulation diagram is the area enclosed by the Control & Simulation Loop. Notice the simulation diagram has a pale yellow background to distinguish it from the rest of the block diagram. You can resize the Control & Simulation Loop by dragging its borders.
    Home
Tutorial: Getting Started with Simulation
Next
2. Configuring Simulation Parameters

 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit