Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Version 2009 Features and Changes (Statechart Module)

LabVIEW 2009 Statechart Module Help

Edition Date: June 2009

Part Number: 372103C-01

»View Product Info

Refer to the readme_Statechart.html file in the labview\readme directory for information about system requirements and installation instructions, for a complete list of new features and changes, and for known issues.

The following sections describe the new features in the LabVIEW Statechart Module 2009.

Generating Documentation for Statecharts

You now can generate documentation that describes all components of a completed statechart. Print or save statechart documentation to keep a record you can refer to later.

You can generate statechart documentation from either the Project Explorer window or the Statechart Editor window. In the Project Explorer window, right-click the .lvsc item, or statechart library, for a statechart and select Generate Documentation from the shortcut menu. In the Statechart Editor window, select File»Generate Documentation. The LabVIEW Statechart Module generates an XML file that contains information about all components, including states, pseudostates, connectors, regions, and transitions, of the statechart. You can view the XML file in a Web browser.

You also can use the Generate Documentation method to generate statechart documentation programmatically.

Debugging Statecharts for FPGA Targets

You now can debug statecharts for field-programmable gate array (FPGA) targets executing on the host computer. LabVIEW can run the statechart on the host computer to allow you to debug the statechart before you deploy the statechart to the FPGA target. You cannot debug a statechart that runs on an actual FPGA. Select LabVIEW FPGA Target from the Execution Target pull-down menu on the Statechart Code Generation page of the Project Library Properties dialog box to specify that the statechart executes on an FPGA target.

Right-click a Run Statechart function and select Debug Statechart from the shortcut menu to debug a statechart for an FPGA target. This action is valid only when you have linked the Run Statechart function to a statechart that runs on the host computer and you have enabled debugging on the linked statechart. By default, statechart debugging for FPGA targets is disabled. You can enable statechart debugging for FPGA targets by selecting Enabled from the Debugging pull-down menu on the Statechart Code Generation page of the Project Library Properties dialog box. Enabling statechart debugging for FPGA targets increases the code size of the statechart.

No Code Generation Required for Guard or Action Changes

In earlier versions of the LabVIEW Statechart Module, when you modify a guard or action in a transition or static reaction, you must re-generate code for the statechart. Code generation can be time-consuming for large statecharts. In the LabVIEW 2009 Statechart Module, you no longer must re-generate code for a statechart when you make modifications to a non-empty guard or action. However, you still must re-generate code if you add code to a previously empty guard or action or if you delete all code from a guard or action.

Configuring Multiple States or Transitions Simultaneously

You now can configure multiple states and transitions simultaneously. Open multiple Configure State or Configure Transition dialog boxes from the Statechart Editor window. You may not otherwise edit the statechart diagram when you open a Configure State or Configure Transition dialog box. When you configure a state or transition, a wrench icon appears on the state () or transition () in the Statechart Editor window. The state or transition also changes color. You can customize the configuration color for states and transitions. The default configuration color is yellow.

Click the Jump to State button in the Configure State dialog box to highlight the corresponding state in the Statechart Editor window. Click the Jump to Transition button in a Configure Transition dialog box to highlight the corresponding transition in the Statechart Editor window.

Finding Objects and Text in Statecharts

You now can search statecharts for a particular object or string of text. Use the Find dialog box to find VIs, Express VIs, objects, or text in the guard and action code of a statechart or to find Statechart Development objects or text in the Statechart Editor window. Select Edit»Find and Replace in the Statechart Editor window to display the Find dialog box.

You also now can find all instances of triggers and groups in a statechart. Right-click a trigger or group on the Triggers/Groups page of the Configure State or Configure Transition dialog box and select Find Trigger/Group from the shortcut menu to find all static reactions and transitions that react to the trigger or group.

Browsing a Statechart Hierarchy

You now can browse the hierarchy of a statechart to identify the relationship of the statechart to other VIs. You can browse the statechart hierarchy from either the Statechart Editor window or the Project Explorer window.

You can browse the following elements of a statechart hierarchy:

  • .lvsc file—From the Statechart Editor window, select View»Browse Relationships»This VI's Statechart to find the corresponding .lvsc file, or statechart library, for the statechart. From the Project Explorer window, right-click a caller VI or subVI of the statechart and select Find»SubVIs or Find»Callers, respectively, from the shortcut menu to find the corresponding .lvsc file for the statechart.
  • Caller VIs—From the Statechart Editor window, select View»Browse Relationships»This VI's Callers to find the caller VIs of the statechart. You also can right-click the icon in the upper right corner of the Statechart Editor window and select Find All Instances from the shortcut menu to find all caller VIs of the statechart. From the Project Explorer window, right-click the .lvsc file for a statechart and select Find»Callers from the shortcut menu to find the caller VIs of the statechart. You can find caller VIs only if they are open in memory.
  • SubVIs—From the Statechart Editor window, select View»Browse Relationships»This VI's SubVIs to find the subVIs of the statechart. From the Project Explorer window, right-click the .lvsc file for a statechart and select Find»SubVIs from the shortcut menu to find the subVIs of the statechart.

Refer to the LabVIEW 2009 Features and Changes topic for more information about new features in LabVIEW 2009.


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit