Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Quick Start Guide (Unit Test Framework Toolkit)

LabVIEW 2013 Unit Test Framework Toolkit Help

Edition Date: June 2013

Part Number: 372584F-01

»View Product Info
Download Help (Windows Only)

Complete the following steps to create, configure, and execute tests in the Project Explorer window.

  1. Launch LabVIEW.
  2. Select File»New to display the New dialog box and select Project»Empty Project to create a new project.
  3. Add VIs you want to test to a target, such as My Computer, and select File»Save to save the project.
  4. Right-click a VI and select Unit Tests»New Test from the shortcut menu to create a test. A .lvtest file with the same name as the VI appears in the project tree.
  5. Right-click the .lvtest file and select Properties from the shortcut menu to display the Test Properties dialog box. Use this dialog box to configure tests.
  6. Use the Unit Test Framework Toolbar at the top of the Project Explorer window. Use the Project Properties dialog box to configure settings related to creating and executing tests.

Related Information

Configuring Tests

Creating Tests

Executing Tests

Managing a Project in LabVIEW


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit