Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Part 6: Comparing Trace Data

LabVIEW 2013 Desktop Execution Trace Toolkit Help

Edition Date: June 2013

Part Number: 372641C-01

»View Product Info
Download Help (Windows Only)

In Part 5 of this tutorial, you execute a second trace session and filter the trace data in the table pane. In Part 6 of this tutorial, you split the table pane or use the Compare Traces window to compare the traces you executed in previous parts of this tutorial.

Splitting the Table Pane

You can split the table pane into two to compare the trace data in two displays which contain the same trace data.

  1. In the Desktop Execution Trace Toolkit, select File»Open to open Desktop Execution Trace Toolkit.lvproj.det you saved in Part 5.
  2. Click the View tab and click the Split image to split the table pane horizontally. The toolkit displays the same trace data in two displays.
    Tip  You also can click the arrow below Split and select Split Pane (Up/Down) from the pull-down menu to split the table pane vertically.
  3. Identify the bookmarks for the sessions, which are green icons on the vertical scroll bars in the two displays. The Desktop Execution Trace Toolkit automatically creates bookmarks when you start a new trace session. In this example, the two bookmarks represent the two trace sessions you executed in Part 3 and Part 5 respectively.
  4. Hover over the first bookmark in the left display. The toolkit displays Navigate to Session 1: and the time when the first session starts. Click the bookmark to navigate to the first event of the first session.
  5. Click the second bookmark in the right display to navigate to the first event of the second session. Move the vertical scroll bar to display the first event at the top of the display.
  6. Compare the two sessions to locate the differences between the two trace sessions.
    Tip  You also can use the Split button to review different parts in a long trace.
  7. Click Reset Pane on the View tab to display the trace data in one display.

Using the Compare Traces Window

You also can use the Compare Traces window to compare two trace sessions of the same or different trace files. The Compare Traces window highlights the differences to make it easier to compare trace sessions.

  1. Click Compare Traces on the View tab to launch the Compare Traces window.
  1. Select Desktop Execution Trace Toolkit.lvproj.det: session 1 from the Session Name pull-down menu in the Compare 1 pane. The toolkit displays the number of the first event of this session in the Begin Index field and the number of the last event of this session in the End Index field.
  1. Select Desktop Execution Trace Toolkit.lvproj.det: session 2 from the Session Name pull-down menu in the Compare 2 pane.
    Note  If you cannot find the trace session that you want to compare, verify that you open the application instance of the trace session and click the refresh button next to the Session Name pull-down menu to refresh the information that the toolkit displays for the trace.
  1. Click Compare in the middle of the two panes to start comparing the two sessions. The toolkit automatically aligns the two sessions and highlights the differences in green.
  1. Click Next in the middle of the two panes to move to the next difference.
  1. Compare the two sessions to understand the differences between the two trace sessions.
    Note  You may notice that the second session does not display memory allocation events. By default, the toolkit does not capture memory allocation events. Before executing the first trace session in Part 3 of the tutorial, you specify the configurations in the Capture Settings dialog box to capture memory allocation events. You save the trace file by selecting File»Save. However, the toolkit saves only the trace data instead of capture settings. When you executed the second session in Part 5, the toolkit applies the default settings and does not capture memory allocation events.
  1. Close the Compare Traces window and save the trace file.

You also can compare the trace sessions of two trace files by clicking New Trace on the Home tab, opening a trace file or executing a trace session in the new trace window, and comparing the trace sessions of the two trace files in the Compare Traces window.

Tip  The Desktop Execution Trace Toolkit takes a long time to compare trace sessions with large amounts of data and the comparison results may be undesirable. You can specify a reasonable value in the Begin Index or End Index field to reduce the amount of trace data to compare. You also can click Filter Settings on the View tab to filter out the events you do not need to analyze.
Filtering Trace Data Saving or Exporting Trace Data

Related Information

Comparing Trace Data


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit