Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Part 7: Saving or Exporting Trace Data

LabVIEW 2013 Desktop Execution Trace Toolkit Help

Edition Date: June 2013

Part Number: 372641C-01

»View Product Info
Download Help (Windows Only)

In Part 6 of this tutorial, you compare the trace sessions that you executed in Part 3 and Part 5 of this tutorial. In Part 7 of this tutorial, you save or export the trace file.

Saving a Trace File

You may know that you can save traces by selecting File»Save or pressing <Ctrl-S>. The Desktop Execution Trace Toolkit saves traces as execution trace (.det) files that the toolkit can reload in the table pane.

Exporting a Trace File

If you need to review the trace data later by using Microsoft Excel spreadsheet software or any text editor without opening the toolkit, you can export the trace file.

  1. In the Desktop Execution Trace Toolkit, select File»Open to open Desktop Execution Trace Toolkit.lvproj.det you saved in Part 6 if it is not already open.
  2. Select File»Export or press <Ctrl-E> to export the trace to a .txt file.
  3. Navigate to the .txt file and open the file by using Microsoft Excel spreadsheet software or any text editor to review the contents of the export file.
  4. Close the export file.

You may notice that the toolkit separates the trace data in the export file by tab delimiter. You can change the default delimiter in export files.

  1. Select File»Options or click Options on the View tab to launch the Options dialog box.
  2. Select General from the category list.
  3. On the General page, select a delimiter from the Delimiter pull-down menu.
  4. (Optional) Select Custom from the Delimiter pull-down menu and specify a delimiter in the Custom field.
  5. Click OK to apply the setting.
Comparing Trace Data

Related Information

Saving or Exporting Trace Data


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit