Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Part 5: Filtering Trace Data

LabVIEW 2013 Desktop Execution Trace Toolkit Help

Edition Date: June 2013

Part Number: 372641C-01

»View Product Info
Download Help (Windows Only)

In Part 4 of this tutorial, you review the trace data that the Desktop Execution Trace Toolkit captures from Desktop Execution Trace Toolkit.lvproj. You may notice that executing a trace session even on a small application can capture hundreds of execution events. In Part 5 of this tutorial, you execute a second trace session and filter the events that the table pane displays to make the table pane easier to read.

  1. In the Desktop Execution Trace Toolkit, select File»Open to open Desktop Execution Trace Toolkit.lvproj.det you saved in Part 4.
  2. Click Start on the Home tab to execute a new trace session.
  3. In LabVIEW, open the Desktop Execution - Generate Trace Events VI if it is not already open.
  4. In LabVIEW, click Run to run the VI. In the toolkit, the table pane updates to display the trace data for the new trace session.
  5. In LabVIEW, click Load Dynamic VI on the front panel of the VI to load the Desktop Execution - Strip Chart SubVI. In the toolkit, the VI column in the table pane shows that events now occur in the Desktop Execution - Strip Chart SubVI VI.
  6. In the toolkit, click the View tab and select Filter Settings to display the Configure Displayed Events dialog box.
  7. Hover over the head of this dialog box, the toolkit displays an illustration about the filtering process. Make sure you understand the illustration. The toolkit continues to trace the events you deselect in the dialog box but does not display them in the table pane.
    Tip  If you do not want the toolkit to trace a specific type of events at all, you must click the arrow below Capture Settings on the Home tab and deselect the event type in the Capture Settings pull-down menu so that you can reduce the amount of data that the toolkit must process and that you must analyze.
  8. Select VIs from the type list to display the VIs page of the dialog box.
  9. On the VIs page, the toolkit displays all the VIs that the toolkit traces in the current application instance. Remove the checkmark from the Desktop Execution - Strip Chart SubVI.vi checkbox.
    Tip  You also can right-click the VI on the table pane and select Filter this VI from Display from the shortcut menu.
  10. Click OK to filter the events that occur in the subVI.
    Note  The filter settings you specify in the Configure Displayed Events dialog box is specific to not only the current trace session but the entire table pane. The trace data of the previous trace session in the table pane also updates to match the filter settings.
  11. Search the table pane to confirm that the toolkit updates not to display the filtered events.
    1. Click Search on the View tab or press <Ctrl-F> to launch the search bar at the bottom of the table pane.
    2. Enter Strip in the field and click Previous or Next to search the table pane for the events that occur in the Desktop Execution - Strip Chart SubVI VI. The toolkit prompts the message that the toolkit cannot find the text.
  12. Click Reset Filter to clear the filter settings and display the filtered events.
  13. On the search bar, click Previous or Next again to search the table pane for the events that contain the Strip keyword. You can find all the events that occur in the Desktop Execution - Strip Chart SubVI VI.
  14. In LabVIEW, click Stop on the front panel of the VI.
  15. Close the Desktop Execution - Generate Trace Events VI and Desktop Execution - Strip Chart SubVI VI.
  16. In the toolkit, click Stop on the Home tab to stop executing the trace session.
  17. Select File»Save to save the trace file.
  18. Click Clear on the Home tab or press <Ctrl-L> so that all the events disappear in the table pane.

Filtering events prevents those events from appearing in the table pane. You can use the Configure Displayed Events dialog box to specify events to filter or display at any time. The table pane updates to match the new configuration settings each time you click OK in the Configure Displayed Events dialog box.

After you filter the trace data, you can split the table pane or launch the Compare Traces window to compare the traces in Part 6 of this tutorial.

Reviewing Trace Data Comparing Trace Data

Related Information

Reviewing Trace Data


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit