Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

Part 4: Reviewing Trace Data

LabVIEW 2013 Desktop Execution Trace Toolkit Help

Edition Date: June 2013

Part Number: 372641C-01

»View Product Info
Download Help (Windows Only)

In Part 3 of this tutorial, you execute the trace session and capture the trace data from Desktop Execution Trace Toolkit.lvproj. In Part 4 of this tutorial, you review the trace data that the Desktop Execution Trace Toolkit captures and displays in the table pane.

  1. Select File»Open or press <Ctrl-O> to open Desktop Execution Trace Toolkit.lvproj.det you saved in Part 3 if it is not already open.
  2. Select a specific event in the table pane. Notice that the toolkit displays additional details about the event in the details pane, including the call chain and VI path.
  3. Right-click a VI Start Execution event in the table pane and select Highlight Paired Events from the shortcut menu. The toolkit highlights the VI Stop Execution event as the paired event for VI Start Execution.
  4. Right-click the table pane and select Time Stamp»Relative from the shortcut menu. The Time column displays the relative time between the current event and the first event in the table pane. By default, the Time column displays the absolute time, which is the actual time when an event occurs.
    Tip  You can change the time format on the General page of the Options dialog box.
  5. Click an event, press and hold down the <Ctrl> key, and click another event. The toolkit displays the duration between the two events in the details pane.
  6. Double-click an event which displays Object in the Highlight column. The toolkit opens the VI in which the event occurs and highlights the related object in the VI. If the event displays VI in the Highlight column, the toolkit only opens the VI.
    Note  You also can use one of the following methods to navigate to a VI related with the event you select:
    • Click Navigate on the View tab to navigate to the VI.
    • Right-click an event and select Navigate to Call Chain VIs from the shortcut menu. You can select in the chain of callers from the current VI to the top-level VI.
  7. Click the header of the Event column to sort the event names alphabetically. Notice that the column header displays an arrow to show that the toolkit groups the events in the table pane based on event types.
  8. Identify all the memory allocation events in the table pane.
    Note  You can change the highlight color for each event in the table pane. Select File»Options or click Options on the View tab to launch the Options dialog box, select Table Highlight from the category list, and click the color box for a specific event type to change the highlight color.
  9. Complete the following steps to review the trace data in an external application.
    1. Click the first memory allocation event in the table pane, press and hold down the <Shift> key, and click the last memory allocation event in the table pane to select all the memory allocation events in the table pane.
    2. Press <Ctrl-C> to copy the memory allocation events to the clipboard.
    3. Launch a text editor and open a blank file.
    4. Press <Ctrl-V> to paste the memory allocation events from the clipboard.
      Note  You can copy and paste the trace data in the toolkit to .txt files and .xls files.
    5. Save and close the file so that you can use the trace data for memory allocation events later without launching the toolkit.
  10. In the toolkit, click the header of the # column to display the events in the order the events occur, which is the default setting.
  11. (Optional) You also can right-click the table pane and select Columns from the shortcut menu to specify which columns the table pane displays.
  12. Select File»Save to save the trace.
  13. In LabVIEW, close the VI.

After you review the trace data, you can filter the trace data to make the table pane easier to read in Part 5 of this tutorial.

Executing a Trace Session Filtering Trace Data

Related Information

Reviewing Trace Data


 

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
Add Comments 1 2 3 4 5 submit