Création de commandes et d'indicateurs personnalisés, et de définitions de type

Aide LabVIEW 2014

Date d'édition : June 2014

Numéro de référence : 371361L-0114

»Afficher les infos sur le produit
Télécharger l'aide (Windows uniquement)

Utilisez les commandes et indicateurs personnalisés pour augmenter le nombre d'objets disponibles sur la face-avant. Dans une application, vous pouvez créer des objets d'interface utilisateur personnalisés dont l'apparence est différente des commandes et indicateurs standard de LabVIEW. Vous pouvez enregistrer une commande ou un indicateur personnalisé que vous avez créé dans un répertoire ou une LLB pour pouvoir l'utiliser sur d'autres faces-avant. Vous pouvez aussi créer une icône pour la commande ou l'indicateur personnalisé et l'ajouter à la palette Commandes. Reportez-vous aux mises en garde et recommandations avant de commencer à créer des commandes ou des indicateurs personnalisés.

Utilisez les définitions de type et les définitions de type strictes pour lier toutes les instances d'une commande ou d'un indicateur personnalisé à un fichier de commande ou d'indicateur personnalisé que vous avez enregistré. Vous pouvez éditer toutes les instances de la commande ou de l'indicateur personnalisé en modifiant uniquement le fichier de commande ou d'indicateur personnalisé, ce qui est utile si vous utilisez la même commande ou le même indicateur dans plusieurs VIs.

Remarque  Vous pouvez aussi utiliser des commandeX pour concevoir et créer des commandes et des indicateurs complexes dans LabVIEW. Contrairement aux commandes personnalisées, les commandeX ont un comportement de temps d'exécution et de temps d'édition dynamique défini par les VIs qui s'exécutent en arrière-plan. Vous pouvez créer et éditer des commandeX uniquement dans le système de développement professionnel de LabVIEW. Si un VI contient une commandeX, vous pouvez exécuter le VI dans toutes les versions LabVIEW.

Utilisation de la fenêtre de l'éditeur de commande

Utilisez la fenêtre de l'Éditeur de commande pour personnaliser des commandes et des indicateurs et pour définir la commande de données privées pour une classe LabVIEW. Par exemple, vous pouvez changer la taille, la couleur et la position relative des éléments d'une commande ou d'un indicateur, et importer des images dans la commande ou l'indicateur.

Vous pouvez afficher la fenêtre de l'éditeur de commande de plusieurs façons :

  • Cliquez avec le bouton droit sur la commande ou l'indicateur de la face-avant et sélectionnez Avancé»Personnaliser dans le menu local.
  • Utilisez l'outil Flèche pour sélectionner la commande ou l'indicateur que vous voulez personnaliser sur la face-avant et sélectionnez Édition»Personnaliser la commande.
  • Utilisez la boîte de dialogue Nouveau.
  • Cliquez avec le bouton droit sur une commande ou un modèle de commande existant et sélectionnez Ouvrir.
  • Cliquez avec le bouton droit sur Poste de travail dans la fenêtre de l'Explorateur de projet et sélectionnez Nouveau»Classe dans le menu local.
  • Créez une classe LabVIEW et double-cliquez sur la commande de données privées.
    Remarque  Si vous définissez la commande de données privées, la fenêtre de l'Éditeur de commande s'ouvre en affichant automatiquement le Cluster des données privées de classe sur le diagramme. De plus, LabVIEW définit par défaut la commande menu déroulant de la fenêtre de l'Éditeur de commande à Données privées de la classe, ce que vous ne pouvez pas changer.
  • Cliquez avec le bouton droit sur l'instance d'une définition de type ou définition de type stricte sur la face-avant ou le diagramme et sélectionnez Ouvrir la déf. de type dans le menu local.

Même si la fenêtre de l'Éditeur de commande ressemble à une face-avant, vous ne pouvez l'utiliser que pour personnaliser une commande ou un indicateur particulier. Pour une classe LabVIEW, cette commande doit être un cluster. La fenêtre de l'Éditeur de commande n'a pas de diagramme et ne peut pas s'exécuter.

La fenêtre de l'Éditeur de commande ne peut contenir qu'une seule commande ou un seul indicateur. Vous pouvez personnaliser une commande ou un indicateur de tableau ou de cluster qui contient d'autres sous-commandes ou sous-indicateurs. La commande est le tableau ou le cluster en lui-même. Le bouton Commande non valide apparaît sur la barre d'outils de la fenêtre de l'Éditeur de commande lorsque vous déplacez des commandes ou des indicateurs pour les insérer dans un tableau ou un cluster, ou les retirer. Cliquez sur le bouton Commande non valide pour afficher une explication de l'erreur dans la fenêtre Liste des erreurs.

Un bouton indicateur de mode sur la barre d'outils de la fenêtre de l'Éditeur de commande indique si vous êtes en mode Édition ou en mode Personnalisé . Cliquez sur ce bouton pour passer d'un mode à l'autre. Vous pouvez aussi passer d'un mode à l'autre en sélectionnant Exécution»Passer en mode Personnalisé ou Exécution»Passer en mode Édition. La fenêtre de l'éditeur de commande s'ouvre en mode Édition.

Utilisez le mode Édition pour changer la taille ou la couleur d'une commande ou d'un indicateur et pour sélectionner des options dans le menu local comme vous le feriez en mode Édition sur une face-avant.

Utilisez le mode Personnalisé pour changer considérablement les commandes et les indicateurs en modifiant leurs composantes individuelles.

Menus locaux du mode Personnalisé

En mode Personnalisé, le menu local de la commande ou de l'indicateur est remplacé par un menu local pour chacune de ses composantes. Les différentes composantes ont des menus locaux différents. Utilisez les menus locaux pour :

  • Personnaliser les composantes esthétiques, comme les objets de la palette Décorations ajoutés à une commande ou un indicateur personnalisé.
  • Personnaliser les composantes textuelles, comme l'étiquette du nom.
  • Personnaliser les commandes ou les indicateurs utilisés en tant que composantes, comme la commande numérique utilisée pour l'afficheur numérique d'une commande à glissière. Les boutons rotatifs, les compteurs et les graphes déroulants peuvent aussi utiliser une commande numérique pour un afficheur numérique. Certaines commandes sont plus compliquées. Par exemple, les graphes utilisent un commande arbre pour la composante d'affichage du curseur.

Personnalisation des composantes individuelles des commandes et des indicateurs

Composantes indépendantes des commandes et des indicateurs

Toutes les commandes et tous les indicateurs sont constitués de composantes plus petites. Par exemple, l'illustration suivante montre les différentes composantes d'une commande à glissière.

Lorsque vous passez en mode Personnalisé dans la fenêtre de l'Éditeur de commande, les composantes de la commande ou de l'indicateur deviennent indépendantes. Vous pouvez modifier chaque composante sans affecter les autres. Le mode Personnalisé montre toutes les composantes d'une commande ou d'un indicateur, y compris celles qui sont cachées en mode Édition, comme l'étiquette de nom ou la base d'une commande numérique. Comme les composantes de la commande ou de l'indicateur sont indépendantes les unes des autres, vous ne pouvez pas attribuer ou modifier la valeur de la commande ou de l'indicateur en mode Personnalisé.

En mode Personnalisé, vous pouvez utiliser l'outil Flèche pour sélectionner plusieurs composantes de la commande ou de l'indicateur et les réorganiser au moyen des menus déroulants Aligner les objets, Répartir les objets et Réorganiser de la barre d'outils.

Fenêtre Composantes de la commande

Sélectionnez Fenêtre»Afficher la fenêtre des composantes pour afficher la fenêtre Composantes de la commande. Utilisez la fenêtre Composantes de la commande pour dimensionner et positionner les différentes composantes d'une commande ou d'un indicateur. La fenêtre Composantes de la commande identifie les composantes de la commande ou de l'indicateur et montre avec précision la position et la taille de chaque composante en pixels.

La section Composante sélectionnée de la fenêtre Composantes de la commande contient l'image et le nom de la composante que vous avez sélectionnée dans la fenêtre de l'Éditeur de commande. Cliquez sur l'afficheur de Composante sélectionnée pour afficher et sélectionner parmi les composantes de la commande ou de l'indicateur. Cliquez sur la flèche d'incrémentation ou de décrémentation de Composante sélectionnée pour faire défiler les composantes de la commande ou de l'indicateur.

Lorsque vous déplacez ou que vous redimensionnez une composante dans la fenêtre de l'Éditeur de commande, LabVIEW met à jour la position et la taille dans les sections Composante sélectionnée et Position et dimensions de la composante de la fenêtre Composantes de la commande. Vous pouvez également saisir directement les valeurs de la position et de la taille dans la section Position et dimensions de la composante pour déplacer ou redimensionner la composante dans la fenêtre de l'Éditeur de commande, ce qui est utile lorsque deux composantes doivent être de taille identique ou alignées. Une fois les valeurs de position et de taille saisies dans la section Position et dimensions de la composante, appuyez sur la touche <Entrée> ou cliquez avec le bouton gauche de la souris pour que les changements deviennent effectifs.

Ajout de composantes esthétiques aux commandes et indicateurs personnalisés

Vous pouvez utiliser la fenêtre de l'Éditeur de commande pour ajouter des graphiques, du texte et des décorations à une commande ou un indicateur personnalisé, que ce soit en mode Édition ou en mode Personnalisé. Si vous collez un graphique ou du texte à partir du presse-papiers, que vous créez une étiquette avec l'outil Texte ou que vous sélectionnez une décoration dans la palette Décorations, l'objet devient une nouvelle composante de décoration de la commande ou de l'indicateur et apparaît avec la commande ou l'indicateur lorsque vous les placez sur une face-avant. Dans la fenêtre de l'Éditeur de commande, vous pouvez déplacer, redimensionner et changer l'ordre de superposition de la nouvelle composante de décoration ou la remplacer. Lorsque vous utilisez une commande ou un indicateur personnalisé sur la face-avant, vous pouvez changer la taille des composantes de décoration que vous avez ajoutées. Cependant, vous ne pouvez pas déplacer les composantes de décoration.

Éléments du menu local du mode Personnalisé pour les composantes esthétiques

Les composantes esthétiques peuvent avoir un graphique unique, plusieurs graphiques qui s'affichent à des moments différents ou plusieurs graphiques qui sont indépendants les uns des autres. Pour personnaliser les composantes esthétiques, mettez la fenêtre de l'Éditeur de commande en mode Personnalisé et cliquez avec le bouton droit de la souris sur la composante esthétique que vous voulez personnaliser. Les éléments disponibles dans le menu local dépendent du type de la composante esthétique.

Composantes esthétiques à un seul graphique

Le menu local des composantes esthétiques à un seul graphique comporte les éléments suivants :

  • Copier dans le presse-papiers—Place une copie de l'image de la composante dans le presse-papiers. Une fois la forme copiée dans le presse-papiers, cliquez avec le bouton droit sur une composante et sélectionnez Importer une image du presse-papiers dans le menu local pour importer la forme dans la composante.

    Si vous avez besoin de formes simples pour personnaliser les composantes esthétiques, vous pouvez copier les formes de composantes intégrées à d'autres commandes ou indicateurs plutôt que de les créer avec une application graphique. Par exemple, si vous avez besoin d'une forme rectangulaire, comme le logement illustré dans la figure 1, cliquez avec le bouton droit sur le logement et sélectionnez Copier dans le presse-papiers dans le menu local. Les graphiques provenant de composantes ou de décorations intégrées sont plus faciles à redimensionner que ceux qui ont été créés avec une application graphique. Par exemple, lorsque vous redimensionnez un rectangle dessiné avec une application graphique, le rectangle grandit uniformément, de sorte que sa surface devient plus grande et sa bordure plus épaisse. Si vous redimensionnez un rectangle copié d'une composante intégrée à une commande ou un indicateur, l'épaisseur de la bordure du rectangle ne change pas. 

    Les composantes copiées d'une commande ou d'un indicateur intégré ont la même apparence sur les écrans couleurs que sur les écrans noir et blanc. De plus, vous pouvez utiliser l'outil Pinceau pour ajouter des couleurs aux graphiques que vous copiez de composantes ou de décorations intégrées. Vous ne pouvez pas changer la couleur d'un graphique que vous importez d'une autre source car la couleur fait partie de la définition du graphique.
  • Importer une image du presse-papiers—Remplace l'image actuelle d'une composante esthétique par celle présente dans le presse-papiers. Par exemple, vous pouvez importer des graphiques de soupape ouverte ou fermée pour un commutateur booléen. Si le presse-papiers ne contient pas de graphique, l'élément Importer une image du presse-papiers n'est pas disponible.
  • Importer du presse-papiers avec la même taille—Remplace l'image actuelle par celle du presse-papiers en la diminuant ou en l'agrandissant pour que la composante conserve sa taille d'origine. Si le presse-papiers ne contient pas de graphique, l'élément Importer du presse-papiers avec la même taille n'est pas disponible.
  • Importer du fichier—Remplace l'image actuelle d'une composante esthétique par celle que vous sélectionnez dans la boîte de dialogue de fichier.
  • Importer du presse-papiers avec la même taille—Remplace l'image actuelle par celle que vous sélectionnez dans la boîte de dialogue de fichier et la diminue ou l'agrandit pour que la composante conserve sa taille d'origine.
  • Restaurer—Restaure l'apparence d'origine d'une composante sans déplacer cette dernière. Si vous affichez la fenêtre de l'Éditeur de commande pour une commande ou un indicateur de la face-avant et que vous modifiez une composante, le fait de sélectionner Restaurer dans le menu local restaure l'apparence d'origine de cette composante sur la face-avant. Si vous ouvrez un fichier de commande ou d'indicateur personnalisé dans la fenêtre de l'Éditeur de commande, l'option Restaurer n'est pas disponible.
  • Taille initiale—Restaure l'image d'une composante à sa taille d'origine, ce qui est utile pour les images que vous importez à partir d'autres applications et que vous redimensionnez. L'apparence de certains graphiques importés à partir d'autres applications n'est plus aussi bonne lorsqu'ils sont redimensionnés. Vous pouvez restaurer le graphique importé à sa taille initiale pour améliorer son apparence. Si vous n'importez pas de graphique, l'option Taille initiale n'est pas disponible.
Remarque  Vous pouvez aussi remplacer une décoration par une image du presse-papiers en sélectionnant la décoration et en sélectionnant Édition»Coller. Pour remplacer une décoration par une image provenant d'un fichier, cliquez avec le bouton droit sur la décoration et sélectionnez Importer du fichier dans le menu local.

Composantes esthétiques à plusieurs graphiques dépendants

Certaines composantes esthétiques comportent plusieurs graphiques qui s'affichent à des moments différents. Les différents graphiques sont de taille identique et utilisent les mêmes couleurs. Lorsque vous déplacez ou redimensionnez le graphique sélectionné de la composante esthétique, les autres graphiques se déplacent de la même distance et changent de taille proportionnellement. Par exemple, un commutateur booléen a quatre graphiques. Le premier graphique montre l'état FAUX. Le second graphique montre l'état VRAI. Le troisième graphique montre l'état Commutation au relâchement, c'est-à-dire l'état de transition entre VRAI et FAUX. Le quatrième graphique montre l'état Armement au relâchement, c'est-à-dire l'état de transition entre FAUX et VRAI. Lorsque la commande booléenne est dans l'état Commutation au relâchement ou Armement au relâchement, la valeur de la commande booléenne ne change pas tant que vous ne relâchez pas le bouton de la souris. Entre le moment où vous cliquez sur le bouton de la souris et celui où vous le relâchez, la commande booléenne montre le troisième ou le quatrième graphique comme état de transition.

Le menu local des composantes esthétiques à plusieurs graphiques dépendants comporte tous les éléments disponibles pour les composantes esthétiques à un seul graphique ainsi que l'élément Élément d'image. Vous pouvez sélectionner Élément d'image dans le menu local pour afficher tous les graphiques qui appartiennent à une composante esthétique. L'élément graphique sélectionné a une bordure plus foncée. Lorsque vous importez un graphique, voue ne changez que l'élément graphique sélectionné. Pour importer un graphique pour l'un des autres éléments graphiques, cliquez avec le bouton droit sur la composante, sélectionnez Élément d'image dans le menu local, sélectionnez l'élément graphique et importez le nouveau graphique.

Composantes esthétiques à plusieurs graphiques indépendants

Une composante esthétique à plusieurs graphiques peut comporter des graphiques de tailles et de couleurs différentes. Par exemple, la glissière utilise deux graphiques de tailles différentes pour représenter le pointeur actif sur une glissière à plusieurs valeurs. Le menu local des composantes esthétiques à plusieurs graphiques indépendants comporte tous les éléments disponibles pour les composantes esthétiques à un seul graphique et à plusieurs graphiques dépendants, ainsi que l'option Tailles indépendantes. Sélectionnez l'élément Tailles indépendantes dans le menu local et placez une marque à côté pour pouvoir déplacer et redimensionnez chaque graphique individuellement sans affecter les autres graphiques de la composante esthétique.

Composantes textuelles

Une composante textuelle est un graphique comportant du texte comme une étiquette, par exemple. Le menu local d'une composante textuelle comporte tous les éléments disponibles pour les composantes esthétiques à un seul graphique et les éléments disponibles pour les éléments textuels d'une face-avant en mode Édition. La fenêtre Composantes de la commande ne montre que le graphique d'arrière-plan pour la composante textuelle, sans le texte. Vous pouvez personnaliser le graphique d'arrière-plan mais pas le texte.

Option du mode Édition pour les commandes et les indicateurs booléens

Contrairement aux autres commandes et indicateurs, dans lesquels vous ne pouvez importer des graphiques que si la fenêtre de l'Éditeur de commande est en mode Personnalisé, vous pouvez importer des graphiques dans les commandes et les indicateurs booléens si la fenêtre de l'Éditeur de commande est en mode Édition. Lorsque la fenêtre de l'éditeur de commande est en mode Édition et que vous cliquez avec le bouton droit sur une commande ou un indicateur booléen, le menu local qui apparaît contient tous les éléments disponibles pour les commandes et les indicateurs booléens d'une face-avant en mode Édition, ainsi que l'option Importer une image du presse-papiers.

Association de commandes et d'indicateurs personnalisés à un fichier de commande ou d'indicateur personnalisé enregistré

Lorsque vous placez une commande ou un indicateur personnalisé dans un VI, il n'existe aucune connexion entre la commande ou l'indicateur personnalisé que vous avez enregistré et l'instance de cette commande ou de cet indicateur dans le VI. Chaque instance de commande ou d'indicateur personnalisé est une copie indépendante. Par conséquent, les modifications que vous effectuez sur une commande ou un indicateur personnalisé n'affectent pas les VIs qui l'utilisent déjà. Si vous voulez établir un lien entre les instances d'une commande ou d'un indicateur personnalisé et le fichier qui lui correspond, enregistrez la commande ou l'indicateur personnalisé en tant que définition de type ou définition de type stricte. Toutes les instances d'une définition de type ou d'une définition de type stricte sont liées au fichier d'origine à partir duquel elles ont été créées.

Lorsque vous enregistrez une commande ou un indicateur personnalisé comme définition de type ou définition de type stricte, les modifications de type de données de la définition de type ou la définition de type stricte affectent toutes les instances de la définition de type ou la définition de type stricte dans tous les VIs qui l'utilisent. De plus, les modifications esthétiques que vous apportez à une définition de type stricte affectent toutes les instances de cette définition de type stricte sur la face-avant.

Définitions de type et définitions de type strictes

Utilisez les définitions de type et les définitions de type strictes pour lier toutes les instances d'une commande ou d'un indicateur personnalisé à un fichier de commande ou d'indicateur personnalisé que vous avez enregistré. Vous pouvez éditer toutes les instances de la commande ou de l'indicateur personnalisé en modifiant uniquement le fichier de commande ou d'indicateur personnalisé, ce qui est utile si vous utilisez la même commande ou le même indicateur dans plusieurs VIs.

Définitions de type

Les définitions de type identifient le type correct des données pour chaque instance d'une commande ou d'un indicateur personnalisé. Lorsque le type de données d'une définition de type change, toutes les instances de cette définition de type sont automatiquement mises à jour. En d'autres termes, le type de données des instances de la définition de type change dans tous les VIs où elle est utilisée. Cependant, comme les définitions de type n'identifient que le type de données, seules les valeurs qui font partie du type de données sont mises à jour. Par exemple, sur les commandes numériques, la gamme de données ne fait pas partie du type de données. Par conséquent, les définitions de type des commandes numériques ne définissent pas la gamme de données des instances des définitions de type. De plus, comme les noms d'éléments des commandes menu déroulant ne définissent pas le type des données, le changement de ces noms dans une définition de type ne changera pas les noms d'éléments dans les instances de la définition de type. Néanmoins, si vous changez les noms d'éléments dans la définition de type pour une commande de type énuméré, les instances sont mises à jour car les noms d'éléments font partie du type de données. Une instance d'une définition de type peut comporter un sous-titre, une étiquette, une description, une info-bulle, une taille par défaut, une couleur ou un style de commande ou d'indicateur qui lui sont propres, comme un bouton rotatif plutôt qu'une glissière.

Si vous changez le type de données dans une définition de type, LabVIEW remplace l'ancienne valeur par défaut par le nouveau type de données dans les instances de la définition de type si c'est possible. LabVIEW ne peut pas conserver la valeur par défaut des instances si le type de données est transformé en type incompatible, comme de commande ou indicateur numérique à commande ou indicateur chaîne. Si le type de données d'une définition de type est transformé en type de données incompatible avec la définition de type précédente, LabVIEW définit la valeur par défaut des instances sur la valeur par défaut que vous avez spécifiée dans le fichier .ctl. Si vous ne spécifiez pas de valeur par défaut, LabVIEW utilise la valeur par défaut pour ce type de données. Par exemple, si vous changez la définition de type d'un type numérique à un type chaîne, LabVIEW remplace les valeurs par défaut associées à l'ancien type de données numérique par des chaînes vides.

Définitions de type strictes

Une définition de type stricte force tout ce qui concerne une instance à être identique à la définition de type stricte, à l'exception du sous-titre, de l'étiquette, de l'info-bulle, de la description et de la valeur par défaut. Comme pour les définitions de type, le type de données d'une définition de type stricte reste le même où que vous utilisiez la définition de type stricte. Les définitions de type strictes définissent aussi d'autres valeurs, comme la vérification de la gamme sur les commandes numériques et les noms d'éléments dans les commandes menu déroulant. Les seules propriétés de VI Serveur disponibles pour les définitions de type strictes sont celles qui affectent l'apparence de la commande ou de l'indicateur, comme Visible, Désactivé, Focus Clavier, Clignotant, Position et Limites.

Remarque   Si vous liez une constante à une définition de type stricte, la constante se comportera à l'inverse comme si le lien n'était pas strict. Les définitions de type strictes nécessitent que toutes les instances d'une définition de type conservent des attributs d'esthétique identiques. Cependant, la plupart des attributs d'esthétique ne sont pas valides sur le diagramme. Puisque les constantes ne se trouvent que sur le diagramme, elles ne conservent pas les attributs d'esthétique.

Vous ne pouvez pas empêcher une instance d'une définition de type stricte d'être mise à jour automatiquement à moins de supprimer le lien entre l'instance et la définition de type stricte.

Création et modification de définitions de type et de définitions de type strictes

Vous pouvez créer et éditer une définition de type ou définition de type stricte à partir de la face-avant ou du diagramme. Pour personnaliser les définitions de type et définitions de type strictes, utilisez la fenêtre de l'Éditeur de commande et les mêmes techniques que celles que vous utilisez pour personnaliser les commandes et les indicateurs.

Pour empêcher la mise à jour automatique d'une instance de définition de type

Pour empêcher une instance particulière d'une définition de type d'être mise à jour automatiquement lorsque le type de données de la définition de type change, cliquez avec le bouton droit sur l'instance et désélectionnez l'élément Mise à jour automatique de la déf. de type du menu local. La désélection de l'élément Mise à jour automatique de la déf. de type empêche la mise à jour automatique quand le type de données de la définition de type change mais préserve le lien entre l'instance et la définition de type. Vous pouvez supprimer le lien entre une instance et une définition de type en cliquant avec le bouton droit sur l'instance et en sélectionnant Déconnecter de la déf. de type dans le menu local.

Remarque  Vous ne pouvez pas empêcher une instance d'une définition de type stricte d'être mise à jour automatiquement à moins de supprimer le lien entre l'instance et la définition de type stricte.

Si vous désactivez la mise à jour automatique d'une instance d'une définition de type et que vous changez le type de données de l'instance ou que vous changez le type de données de la définition de type, l'instance apparaît grisée et le bouton Exécuter apparaît brisé. Pour mettre à jour l'instance manuellement, faites un clic droit sur l'instance et sélectionnez Revoir et mettre à jour à partir de la déf. de type pour afficher la boîte de dialogue Revoir et mettre à jour à partir de la déf. de type. Pour permettre à l'application de s'exécuter sans mettre à jour l'instance, faites un clic droit sur l'instance et sélectionnez Déconnecter de la déf. de type dans le menu local pour supprimer le lien définitivement entre l'instance et la définition de type.

Mise à jour manuelle des instances d'une définition de type

Si une instance d'une définition de type apparaît grisée, vous devez mettre à jour l'instance manuellement en utilisant la boîte de dialogue Revoir et mettre à jour à partir de la déf. de type.

Lorsque vous changez le type de données d'une définition de type, LabVIEW tente de mettre à jour automatiquement toutes les instances de cette définition de type. Si LabVIEW ne parvient pas à mapper les valeurs par défaut précédentes aux commandes ou constantes mises à jour lorsqu'il met à jour des instances, il place ces instances dans un état "non résolu". Une instance non résolue apparaît grisée, et le bouton Exécuter du VI dans lequel elle se trouve est brisé. Pour corriger les différences de mappage de données, vous devez manuellement mettre à jour les instances. Alternativement, vous pouvez supprimer le lien entre les instances non résolues et la définition de type pour permettre à l'application de s'exécuter.

Suppression du lien entre une instance et une définition de type ou une définition de type stricte

Vous pouvez supprimer définitivement le lien entre une instance d'une définition de type ou d'une définition de type stricte et la définition de type ou la définition de type stricte en cliquant avec le bouton droit sur l'instance et en sélectionnant Déconnecter de la déf. de type dans le menu local. La déconnexion de la définition de type ou de la définition de type stricte supprime les contraintes sur le type de données de l'instance et transforme l'instance en commande ou indicateur ordinaire.

Définitions de type et définitions de type strictes non disponibles

Pour chaque instance d'une définition de type ou d'une définition de type stricte, le VI qui contient l'instance maintient une connexion vers le fichier dans lequel vous avez enregistré la définition de type ou la définition de type stricte. Pour qu'un VI comportant une instance d'une définition de type ou d'une définition de type stricte puisse s'exécuter, il doit avoir accès au fichier qui contient la définition de type ou la définition de type stricte. Si vous ouvrez un VI et que LabVIEW n'arrive pas à trouver la définition de type ou la définition de type stricte dont le VI a besoin, LabVIEW désactive les instances de cette définition de type ou de cette définition de type stricte dans le VI, et le bouton Exécuter apparaît brisé. Pour que le VI puisse s'exécuter, recherchez et ouvrez la définition de type ou la définition de type stricte appropriée. Vous pouvez aussi cliquer avec le bouton droit sur l'instance désactivée et sélectionner Déconnecter de la déf. de type dans le menu local pour supprimer définitivement le lien entre l'instance et la définition de type ou la définition de type stricte.

Utilisation des définitions de type et des définitions de type strictes

Les définitions de type et les définitions de type strictes sont placées sur la face-avant ou sur le diagramme de la même façon que les commandes ou indicateurs personnalisés. Lorsque vous cliquez avec le bouton droit sur une instance de définition de type ou de définition de type stricte, le menu local comporte des options de définition de type. Vous pouvez ouvrir la définition de type ou la définition de type stricte à partir de la face-avant ou du diagramme en cliquant sur l'instance avec le bouton droit et en sélectionnant Ouvrir la déf. de type dans le menu local.

Vous pouvez identifier l'instance d'une définition de type ou définition de type stricte sur le diagramme par le petit triangle noir dans son coin supérieur gauche (). Si vous placez le curseur sur le triangle, une info-bulle affiche le nom de la définition de type ou définition de type stricte. Les modifications des définitions de type affectent les instances placées comme constantes sur un diagramme de la même façon que ces modifications affectent les instances sur la face-avant.

Remarque  Si vous modifiez une définition de type stricte, les instances placées sur les diagrammes en tant que constantes agissent comme si le lien n'était pas strict, et LabVIEW ne met à jour les constantes que lorsque le type de données change. Par exemple, si vous mettez à jour les valeurs des chaînes d'une commande menu déroulant enregistrée comme définition de type stricte, LabVIEW ne met pas à jour les instances de la définition de type stricte placées sur le diagramme car les valeurs des chaînes ne font pas partie du type de données de la commande menu déroulant.

Utilisation des définitions de type cluster et des définitions de type strictes cluster

Si vous placez une instance de définition de type cluster ou de définition de type stricte cluster sur une face-avant, utilisez les fonctions Assembler par nom et Désassembler par nom sur le diagramme pour accéder aux éléments du cluster. Contrairement aux fonctions Assembler et Désassembler, qui font référence aux éléments d'un cluster d'après l'ordre du cluster, les fonctions Assembler par nom et Désassembler par nom font référence aux éléments du cluster par leur nom. Par conséquent, la réorganisation des éléments ou l'ajout de nouveaux éléments à la définition de type cluster ou à la définition de type stricte cluster ne brise pas le VI.

Si vous supprimez un élément de la définition de type cluster ou de la définition de type stricte cluster câblée à la fonction Assembler par nom ou Désassembler par nom, vous devrez modifier le diagramme car la référence à l'élément manquant n'est plus valide. Les noms non valides dans les fonctions Assembler par nom et Désassembler par nom apparaissent en noir. Cliquez sur la fonction Assembler par nom ou Désassembler par nom pour afficher une liste des noms valides que vous pouvez sélectionner.

Lorsque vous créez des références à des commandes dans une définition de type cluster ou une définition de type stricte cluster, LabVIEW utilise l'ordre du cluster pour déterminer les commandes vers lesquelles les références pointent dans le cluster. De ce fait, si vous supprimez une commande de la définition de type cluster ou de la définition de type stricte cluster, la référence restante pointant vers la commande supprimée risque désormais de pointer vers une commande différente dans le cluster. Si vous supprimez une commande dans une définition de type cluster ou de type stricte cluster, assurez-vous que chaque référence pointe toujours vers la commande correcte dans le cluster.

CET ARTICLE VOUS A-T-IL ÉTÉ UTILE ?

Pas utile