Enregistrement des VIs

Aide LabVIEW 2014

Date d'édition : June 2014

Numéro de référence : 371361L-0114

»Afficher les infos sur le produit
Télécharger l'aide (Windows uniquement)

Sélectionnez Fichier»Enregistrer pour enregistrer un VI. Vous pouvez enregistrer les VIs en tant que fichiers individuels ou vous pouvez grouper plusieurs VIs et les enregistrer dans une LLB. Les fichiers LLB se terminent par l'extension .llb. National Instruments préconise l'enregistrement des VIs en tant que fichiers séparés, organisés en répertoires, en particulier si plusieurs développeurs travaillent sur le même projet.

National Instruments vous conseille d'enregistrer vos VIs dans certains répertoires. Pour que les VIs soient facilement accessibles, limitez le nombre et les niveaux de répertoires utilisés dans un projet.

Avantages de l'enregistrement des VIs en tant que fichiers individuels

La liste suivante présente les raisons susceptibles de vous inciter à enregistrer les VIs en tant que fichiers individuels :

  • Vous pouvez utiliser le système de fichiers pour gérer les fichiers individuels.
  • Vous pouvez utiliser des sous-répertoires.
  • Vous pouvez stocker des VIs et des commandes dans des fichiers individuels avec plus de sécurité que si vous stockiez votre projet entier dans le même fichier.
  • Vous pouvez utiliser des gestionnaires de contrôle de source fournis par des tiers.

Créez un répertoire pour tous les VIs d'une application et enregistrez les VIs de niveau principal dans ce répertoire, et les sous-VIs dans un sous-répertoire. Si les sous-VIs comportent des sous-VIs, continuez la hiérarchie de répertoire vers le bas. Lorsque vous créez le répertoire, organisez les VIs et les sous-VIs par modules selon la fonctionnalité des sous-VIs.

Avantages de l'enregistrement de VIs comme LLBs

La liste suivante énonce les raisons pour lesquelles les VIs devraient être enregistrés comme LLBs :

  • Vous pouvez utiliser 255 caractères pour nommer vos fichiers.
  • Il est plus facile de transférer une LLB à d'autres plates-formes que de transférer plusieurs VIs individuellement. Vous pouvez aussi vous assurer que l'utilisateur a bien reçu tous les fichiers nécessaires.
  • Vous pouvez réduire légèrement la taille du fichier de votre projet parce que les LLBs sont compressées pour réduire les besoins en espace disque.
  • Vous pouvez marquer les VIs contenus dans une LLB comme étant de niveau principal ; ainsi, lorsque vous ouvrez la LLB, LabVIEW ouvre automatiquement tous les VIs de niveau principal compris dans cette LLB.
Remarque  LabVIEW stocke la plupart de ses VIs et de ses exemples intégrés dans des LLBs afin que tous les emplacements de stockage soient cohérents sur toutes les plates-formes.

Si vous utilisez des LLBs, pensez à diviser votre application en plusieurs LLBs. Mettez les VIs de niveau principal dans une LLB et configurez d'autres LLBs pour qu'elles renferment des VIs organisés suivant leur fonction. L'enregistrement des modifications apportées à un VI contenu dans une LLB prend plus de temps que celui des modifications apportées à un VI individuel car le système d'exploitation doit écrire les changements dans un fichier de taille plus importante. Enregistrer les changements apportés à une LLB volumineuse peut nécessiter davantage de mémoire et réduire les performances. Essayez de limiter la taille de chaque LLB à environ 1 Mo.

Gestion de VIs groupés dans des LLBs

Utilisez la fenêtre Gestionnaire de LLBs, disponible en sélectionnant Outils»Gestionnaire de LLBs, pour copier, renommer et supprimer plus simplement des fichiers dans les LLBs. Vous pouvez également utiliser cet outil pour créer de nouvelles LLBs et de nouveaux répertoires, et pour convertir des LLBs en répertoires et des répertoires en LLBs. Ces opérations sont importantes si vous devez gérer vos VIs avec des outils de contrôle du code source.

Avant d'utiliser la fenêtre Gestionnaire de LLBs, fermez tous les VIs qui pourraient être affectés pour éviter d'effectuer une opération de fichier sur un VI déjà en mémoire.

Remarque  Vous ne pouvez pas annuler les modifications que vous avez effectuées dans la fenêtre Gestionnaire de LLBs.

(Windows) Vous pouvez aussi double-cliquer sur un fichier .llb dans l'explorateur Windows pour afficher la fenêtre du gestionnaire de LLB afin de pouvoir ouvrir, déplacer, copier, renommer ou supprimer des fichiers de la LLB.

Appellation des VIs

Lorsque vous enregistrez des VIs, utilisez des noms descriptifs. Les noms descriptifs, comme Moniteur de température.vi et Écrire et lire en série.vi, facilitent l'identification et l'utilisation du VI. Si vous utilisez des noms ambigus, comme VI_1.vi, l'identification des VIs sera difficile, surtout si vous avez enregistré plusieurs VIs.

Prévoyez si les utilisateurs utiliseront les VIs sur une autre plate-forme. Évitez d'utiliser les caractères que les systèmes d'exploitation réservent à des utilisations particulières, comme \ : / ? * < > et #.

Remarque  Si plusieurs VIs du même nom sont enregistrés sur votre ordinateur, prenez soin de les organiser dans des bibliothèques de projet ou LLBs différentes afin que LabVIEW ne fasse pas référence au mauvais sous-VI lorsqu'il exécute le VI de niveau principal. Reportez-vous aux astuces de la Liste de vérification de style LabVIEW pour choisir le nom des VIs, des LLBs et des répertoires.

Enregistrement pour une version précédente

Vous pouvez enregistrer des VIs, des projets LabVIEW et des bibliothèques de projet au format d'une version antérieure de LabVIEW afin de faciliter la mise à jour de LabVIEW et de vous aider à maintenir des fichiers dans plusieurs versions de LabVIEW si nécessaire.Sélectionnez Fichier»Enregistrer pour une version précédente afin d'enregistrer des VIs dans un format de version antérieure de LabVIEW.

Remarque   Pour enregistrer des bibliothèques de projet empaquetées pour une version précédente de LabVIEW, enregistrez les fichiers dans la bibliothèque empaquetée pour une version précédente et reconstruisez la bibliothèque empaquetée.

Lorsque vous enregistrez un VI au format d'une version précédente, LabVIEW convertit non seulement ce VI, mais aussi tous les autres VIs dans sa hiérarchie, à l'exclusion des fichiers se trouvant dans le répertoire labview\vi.lib.

Si un VI, un projet ou une bibliothèque de projet utilise une fonctionnalité qui n'est pas disponible dans la version précédente que vous choisissez, LabVIEW enregistre tout ce qu'il peut et génère un rapport sur ce qu'il n'a pas pu convertir. Le rapport apparaît immédiatement dans la boîte de dialogue Résumé des mises en garde d'enregistrement pour une version précédente. Cliquez sur le bouton Détails dans la boîte de dialogue Résumé des mises en garde d'enregistrement pour une version précédente pour ouvrir la boîte de dialogue Liste des mises en garde d'enregistrement et de chargement et consultez les informations détaillées sur chaque mise en garde. Vous pouvez aussi cliquer sur le bouton Ignorer pour accuser réception de ces mises en garde et fermer la boîte de dialogue qui en fait le récapitulatif. Cliquez sur le bouton Enregistrer dans un fichier dans la boîte de dialogue Liste des mises en garde d'enregistrement et de chargement afin d'enregistrer les mises en garde dans un fichier texte que vous pourrez consulter ultérieurement.

Si vous enregistrez un VI protégé par mot de passe pour une version précédente de LabVIEW, vous devez entrer le mot de passe. Vous pouvez aussi entrer le mot de passe par programmation comme entrée de la fonction Ouvrir une référence de VI.

Enregistrement automatique pour la récupération

En cas d'arrêt anormal ou de panne système, LabVIEW sauvegarde dans un emplacement temporaire tous les fichiers de VI (.vi), de VI modèle (.vit), de commande (.ctl), de modèle de commande (.ctt), de projet (.lvproj), de bibliothèque de projet (.lvlib), de commandeX (.xctl) ou de classe LabVIEW (.lvclass) modifiés et ouverts au moment de la panne ou de l'arrêt.

Remarque  Si vous entrez du texte n'importe où dans un fichier au moment de la sauvegarde automatique, LabVIEW n'enregistre pas ce fichier. Ceci empêche l'enregistrement automatique d'interrompre la saisie de texte.

Sélectionnez Outils»Options puis Environnement dans la liste Catégorie pour activer ou désactiver l'enregistrement à des fins de récupération et pour spécifier la fréquence de la sauvegarde automatique. Si vous activez l'enregistrement automatique, LabVIEW sauvegarde les fichiers avant d'exécuter un VI. Vous pouvez aussi configurer LabVIEW de manière à sauvegarder les fichiers à intervalles réguliers.

LabVIEW stocke les fichiers sauvegardés dans le sous-répertoire LVAutoSave du répertoire de données par défaut. N'accédez pas et ne modifiez pas les fichiers du répertoire LVAutoSave manuellement.

Si LabVIEW enregistre automatiquement des fichiers avant un arrêt anormal ou une panne système, la fenêtre Sélectionner les fichiers à récupérer apparaît la prochaine fois que vous lancez LabVIEW. Sélectionnez le fichier que vous voulez récupérer et cliquez sur le bouton Récupérer. Si vous ne souhaitez récupérer aucun fichier, désélectionnez tous les fichiers et cliquez sur le bouton Supprimer. Cliquez sur le bouton Annuler pour déplacer tous les fichiers sélectionnés dans le sous-répertoire LVAutoSave\archives du répertoire de données par défaut. Vous pouvez supprimer le contenu de ce sous-répertoire quand vous n'avez plus besoin des fichiers de sauvegarde.

Remarque   Le fait de sélectionner un projet ou une bibliothèque pour sa récupération ne récupère pas automatiquement les modifications apportées aux fichiers de ce projet ou de cette bibliothèque. Pour récupérer une bibliothèque ou un projet modifié et tous ses éléments modifiés, vérifiez que les cases à côté du fichier .lvlib ou .lvproj et de tous les fichiers contenus dans la bibliothèque ou le projet sont cochées.

Les fichiers enregistrés automatiquement n'écrasent pas les fichiers enregistrés manuellement. LabVIEW ne retient les fichiers enregistrés automatiquement que jusqu'à ce qu'ils soient enregistrés, supprimés ou archivés.

CET ARTICLE VOUS A-T-IL ÉTÉ UTILE ?

Pas utile