Page Environnement (boîte de dialogue Options)

Aide LabVIEW 2014

Date d'édition : June 2014

Numéro de référence : 371361L-0114

»Afficher les infos sur le produit
Télécharger l'aide (Windows uniquement)

Requiert : Système de développement de base

Pour afficher cette page, sélectionnez Outils»Options pour ouvrir la boîte de dialogue Options, puis sélectionnez Environnement dans la liste de Catégorie.

Utilisez cette page pour définir diverses options dans l'environnement LabVIEW.

Cette page comprend les éléments suivants :

  • Paramètres généraux — Utilisez cette section pour définir les options générales d'environnement.
    • Fermeture automatique des sessions VISA — Ferme automatiquement les sessions VISA laissées ouvertes par l'application lorsque le VI principal est devenu inactif. Par défaut, cette option n'est pas cochée.
    • Terminer la saisie de texte avec la touche Entrée — Vous permet d'appuyer sur la touche <Entrée> pour mettre fin à la saisie de texte. Par défaut, cette option n'est pas cochée. Si vous sélectionnez cette option, la touche <Entrée> du clavier et celle du pavé numérique ont le même effet : la saisie de texte est terminée. Appuyez sur les touches <Ctrl-Entrée> du clavier pour insérer de nouvelles lignes dans un champ. (Mac OS X) Appuyez sur les touches <Option-Return>. (Linux) Appuyez sur les touches <Alt-Return>.
    • Verrouiller la sélection automatique des outils — Laisse la sélection automatique de l'outil activée lorsque vous appuyez sur les touches <Tab> ou <Maj-Tab>. Par défaut, cette option est cochée. Désélectionnez cette case pour configurer LabVIEW de manière à désactiver la sélection automatique de l'outil lorsque vous appuyez sur la touche <Tab> et l'activer en appuyant sur les touches <Maj-Tab>.
    • Ne pas afficher la fenêtre de démarrage au lancement — Ouvre un nouveau VI vide, au lieu d'ouvrir la fenêtre Démarrage lorsque vous lancez LabVIEW. Par défaut, cette option n'est pas cochée.
    • Désactiver les mises à jour de ni.com dans la fenêtre de démarrage — Vous permet de désactiver la recherche automatique des tout derniers articles sur le site Web ni.com. Vous pouvez désactiver ces mises à jour si vous ne voulez pas que la fenêtre de démarrage accède à ces informations par le biais d'Internet. Si vous désactivez ces mises à jour, LabVIEW affiche des informations dans la fenêtre de démarrage basées sur la dernière mise à jour à partir de ni.com.
    • Séparer le code compilé des nouveaux fichiers — Configure LabVIEW pour stocker le code compilé séparément du fichier source pour tous les nouveaux VIs et toutes les nouvelles commandes personnalisées, variables globales, classes LabVIEW, bibliothèques de projet, commandeX et bibliothèques de diagrammes d'états-transitions.
    • Nombre max. de pas d'annulation par VI — Définit le nombre maximal d'étapes que vous pouvez annuler. La valeur par défaut est 99 pas. La valeur maximale que vous pouvez entrer est 99. La valeur minimale que vous pouvez entrer est 1.
    • Maximum d'entrées dans la liste de modèles de projets récents — Définit le nombre maximum d'éléments listés par LabVIEW sous le bouton Créer un projet sur la fenêtre de démarrage.
    • Maximum d'entrées dans la liste de fichiers récents — Définit le nombre maximum de projets et de fichiers listés par LabVIEW sous le bouton Ouvrir un fichier de la fenêtre de démarrage. Cette option définit également le nombre maximum de fichiers listés par LabVIEW quand vous sélectionnez Fichier»Fichiers récents ou Fichier»Projets récents.
    • Effacer les mots de passe en mémoire — Efface la mémoire cache des mots de passe LabVIEW. Si vous avez des VIs protégés par un mot de passe, LabVIEW met le mot de passe en mémoire lorsque vous accédez aux diagrammes, afin que vous n'ayez pas besoin de retaper le mot de passe au cours de la même session. Si vous effacez le cache des mots de passe, vous devrez retaper le mot de passe la prochaine fois que vous accédez à un diagramme protégé par un mot de passe. Lorsque vous effacez le cache des mots de passe, LabVIEW ferme tous les diagrammes de VIs protégés par mot de passe.
  • Info-bulles et étiquettes — Utilisez cette section pour configurer les info-bulles et les étiquettes d'environnement.
    • Afficher les info-bulles — Affiche les info-bulles. Par défaut, cette option est cochée.
    • Afficher les étiquettes des constantes créées — Affiche des étiquettes avec le nom du terminal à partir duquel la constante a été créée. Par défaut, cette option n'est pas cochée.
  • Enregistrement des VIs — Utilisez cette section pour définir la manière dont LabVIEW enregistre les VIs.
    • Verrouiller les VIs en lecture seule — Principalement utilisée pour le contrôle de source, cette option restreint l'édition des VIs en lecture seule. Si vous ne cochez pas cette case, vous pouvez éditer des VIs même s'ils ne sont qu'en lecture seule, mais vous ne pouvez pas les enregistrer. Si vous cochez cette case, un VI qui est en lecture seule s'ouvre en tant que VI verrouillé, et vous ne pouvez pas l'éditer.
      • Ne pas enregistrer les modifications automatiques — Ne vous invite pas à enregistrer tout changement automatiquement implémenté par LabVIEW dans les VIs en lecture seule. Vous n'avez pas besoin d'enregistrer ces modifications car elles sont automatiquement implémentées par LabVIEW à chaque chargement du VI. Les changements implémentés automatiquement par LabVIEW incluent la recompilation, la conversion depuis une version antérieure, et la mise à jour des définitions de type et des polices. Par défaut, cette option n'est pas cochée. Pour sélectionner Ne pas enregistrer les modifications automatiques, vous devez d'abord sélectionner l'option Verrouiller les VIs en lecture seule.
    • Enregistrement automatique pour la récupération — Enregistre automatiquement les fichiers ouverts aux intervalles de temps spécifiés. En cas d'arrêt anormal ou de panne système, la fenêtre Sélectionner les fichiers à récupérer affiche les fichiers récupérables au prochain démarrage de LabVIEW.
      • Enregistrer avant l'exécution d'un VI — Fait une sauvegarde des fichiers ouverts avant que vous n'exécutiez un VI.
      • Enregistrer avant l'exécution du VI ou toutes les — Sauvegarde les fichiers ouverts aux intervalles réguliers spécifiés dans le champ minutes et avant l'exécution d'un VI.
        • minutes — Spécifie la fréquence à laquelle vous souhaitez que LabVIEW sauvegarde les fichiers ouverts. Vous devez sélectionner Enregistrer avant l'exécution du VI ou toutes les : pour activer ce champ.
  • Polices — Utilisez cette section pour configurer trois catégories de polices prédéfinies : la police de l'application, la police des boîtes de dialogue et la police système. Sélectionnez la catégorie que vous voulez configurer dans le menu déroulant au-dessus de la boîte de texte.
    • Sélecteur de police — Sélectionne le type de police prédéfini à configurer.
      • Police de l'application — Détermine la police utilisée pour le texte des palettes Commandes et Fonctions, pour l'aide contextuelle et les info-bulles.
      • Police des boîtes de dialogue — Détermine la police utilisée pour le texte des boîtes de dialogue et des commandes système.
      • Police du système — Détermine la police utilisée pour le texte de la barre de menus et des menus locaux.
    • Utiliser la police par défaut — Sélectionne la configuration par défaut de LabVIEW pour la police prédéfinie. Utilise les caractéristiques de police définies dans la boîte de dialogue Style de police. Cette option est sélectionnée par défaut.
    • Style de police — Affiche la boîte de dialogue Style de police, qui vous permet de changer les caractéristiques de police.
    • Exemple de police — Affiche un aperçu de la police sélectionnée.
  • Couleurs — Utilisez cette section pour définir les options de couleur.
    • Utiliser les couleurs par défaut — Utilise les couleurs par défaut pour tous les éléments figurant dans cette boîte de dialogue. Par défaut, cette option est cochée. Désélectionnez cette option si vous voulez changer la couleur d'un rectangle en cliquant dessus.
      • Face-avant — Sélectionne une couleur pour la face-avant des nouveaux VIs, mais n'affecte pas les VIs existants.
      • Diagramme — Sélectionne une couleur pour le diagramme des nouveaux VIs, mais n'affecte pas les VIs existants.
      • Points de coercition — Sélectionne une couleur pour les points qui indiquent la coercition des données numériques. Cette option affecte seulement la façon dont LabVIEW affiche les VIs. Elle n'affecte pas les VIs eux-mêmes.
      • Barre de défilement — Sélectionne une couleur pour les barres de défilement. Cette option affecte seulement la façon dont LabVIEW affiche les VIs. Elle n'affecte pas les VIs eux-mêmes.
      • Premier plan de clignotement — Sélectionne la couleur de premier plan pour un objet clignotant. Cette option affecte un objet clignotant uniquement dans son état clignotant. Le clignotement est une propriété de base que vous activez par des nœuds de propriété.
      • Arrière-plan de clignotement — Sélectionne la couleur d'arrière-plan pour un objet clignotant. Cette option affecte un objet clignotant uniquement dans son état clignotant. Le clignotement est une propriété de base que vous activez par des nœuds de propriété.
      • Texte des menus(Windows et Linux) Sélectionne une couleur pour le texte des menus.
      • Arrière-plan des menus(Windows et Linux) Sélectionne une couleur pour l'arrière-plan des menus.
    • Couleurs personnalisées — Affiche l'ensemble des couleurs définies par l'utilisateur à partir du sélecteur de couleur de la boîte de dialogue Couleurs utilisateur.
  • Mise au point — Utilisez cette section pour définir les options de mise au point.
    • Visualiser les mises en garde dans la boîte de dialogue de la liste des erreurs — Affiche les mises en garde en plus des erreurs dans la fenêtre Liste des erreurs. Une mise en garde ne signifie pas que le VI est incorrect. Elle signale un problème potentiel dans le diagramme ou suggère une action recommandée. Par défaut, cette option est cochée.
  • Rapport d'erreur NI(Windows) Utilisez cette section pour définir les options des boîtes de dialogue de Rapport d'erreur NI.
    Remarque  Cette section n'est pas disponible si le Rapport d'erreur NI est désactivé.
    • Ne pas avertir des mises en garde internes à la fermeture — Désactive la boîte de dialogue Communicateur de mises en garde internes pour qu'elle n'apparaisse pas si une ou plusieurs mises en garde sont détectées lors de la dernière exécution du programme.
      • Envoyer automatiquement les rapports de mises en garde internes à National Instruments — Envoie automatiquement un rapport de mises en garde internes à National Instruments si une ou plusieurs mises en garde ont lieu. Cette option n'est disponible que si l'option Ne pas avertir des mises en garde internes à la fermeture est sélectionnée.
    • Relancer LabVIEW après un crash — Relance LabVIEW après la fermeture de la boîte de dialogue Communicateur de crash. LabVIEW se relance comme il avait été précédemment lancé (en double-cliquant sur le fichier .EXE ou via des arguments de ligne de commande, par exemple).
      Remarque  LabVIEW ne peut pas se relancer si la longueur totale de la chaîne de l'argument de la ligne de commande dépasse 255 caractères.


      Désélectionnez cette option si vous ne voulez pas que LabVIEW redémarre après qu'une erreur interne LabVIEW s'est produite.
    • Fermer la boîte de dialogue Envoi de rapport à la fin de l'envoi — Ferme la boîte de dialogue Envoi de rapport lorsque le rapport d'erreur a été envoyé. Si une erreur a lieu pendant l'envoi, la boîte de dialogue Envoi de rapport ne se ferme pas automatiquement.
  • Mises en garde et erreurs internes — Utilisez cette section pour définir les options des boîtes de dialogue d'erreurs et de mises en garde internes.
    Remarque  (Windows) Cette section est disponible si le Rapport d'erreur NI est désactivé.
    • Proposer d'étudier les erreurs et mises en garde internes au démarrage(Mac OS X et Linux) Affiche la fenêtre Investigate Previous Internal Error or Warning lorsque vous lancez LabVIEW après qu'une erreur interne LabVIEW (panel.cpp, line 2978, par exemple) s'est produite. Par défaut, cette option est sélectionnée. Désélectionnez cette option si vous ne voulez pas que LabVIEW ouvre la fenêtre Étudier l'erreur ou la mise en garde interne précédente lorsque vous lancez LabVIEW après une erreur interne.
  • Compilateur — Utilisez cette section pour configurer à quel moment le compilateur LabVIEW doit donner priorité à la vitesse d'exécution plutôt qu'à la réactivité de l'éditeur.
    • Optimisations du compilateur — Indique le degré de complexité qu'un VI doit avoir avant que le compilateur limite les optimisations pour améliorer la réactivité de l'éditeur. Si la complexité d'un VI est inférieure au seuil indiqué par cette glissière, le compilateur utilise toutes les optimisations, améliorant ainsi la vitesse d'exécution du VI. Si la complexité d'un VI est supérieure au seuil, le compilateur limite les optimisations afin d'améliorer la réactivité de l'éditeur pour le VI.

      Pour déterminer la complexité d'un VI spécifique, reportez-vous à la valeur de Complexité du code compilé sur la page Utilisation de la mémoire de la boîte de dialogue Propriétés du VI. Utilisez cette valeur de complexité avec la glissière d'optimisations pour choisir entre la réactivité de l'éditeur et la vitesse d'exécution du VI.

      Les mises en garde et recommandations suivantes s'appliquent à cette glissière :
      • La valeur de la glissière d'optimisations du compilateur s'applique à tous les VIs. LabVIEW détermine s'il faut appliquer les optimisations du compilateur à chaque VI en fonction du seuil indiqué par la glissière.
      • Le compilateur ignore le seuil indiqué par la glissière Optimisations du compilateur lors de la construction d'une application destinée à des cibles s'exécutant sur une architecture PowerPC ou ARM (respectivement, VxWorks et NI Linux temps réel).
      • Le fait de changer la valeur de cette glissière n'entraîne pas automatiquement la recompilation des VIs.
      • National Instruments vous recommande de redéfinir la glissière d'optimisations du compilateur à 5 après avoir momentanément changé la valeur pour éditer ou compiler des VIs complexes. Un seuil de 5 donne correctement la priorité à la réactivité de l'éditeur ou à la vitesse d'exécution pour la majorité des VIs.
  • Linux(Linux) Utilisez cette section pour définir les options d'environnement qui sont uniquement disponibles sous Linux.
    • Utiliser l'apparence native — Sélectionne le style d'interface utilisateur à supporter sous Linux. La valeur par défaut est auto.
    • Utiliser la touche Ctrl comme touche menu/meta — Vous permet d'utiliser la touche Contrôle pour les raccourcis clavier. Cette option est sélectionnée par défaut.
    • Tailles de police basées pixel — Force LabVIEW à utiliser une taille basée sur les pixels et non pas sur les points pour sélectionner les polices à charger. Cette option est sélectionnée par défaut. Si vous sélectionnez cette option, la taille du texte sera réduite sur les écrans à grande résolution (100 dpi) mais les VIs destinés à différentes plates-formes seront de meilleure qualité.
    • Afficher/masquer les fenêtres flottantes lorsque le focus change — LabVIEW affiche ou masque les palettes et masque toutes les fenêtres flottantes lorsqu'une autre application a le focus. Cette option est sélectionnée par défaut.
      Remarque  Cette option ne fonctionne bien que si vous devez cliquer sur une fenêtre pour qu'elle ait le focus. Si le gestionnaire de fenêtres est configuré pour que le focus soit donné suite à un clic de souris, vous devriez décocher cette option.
    • Garder les fenêtres flottantes au premier plan — Les fenêtres flottantes, comme les palettes de Commandes ou de Fonctions et la fenêtre d'Aide contextuelle apparaissent au-dessus de toutes les autres fenêtres. Le gestionnaire de fenêtres doit supporter cette fonctionnalité ; sinon, cette option n'a aucun effet. Certaines versions de GNOME et KDE supportent les fenêtres flottantes. Cette option est sélectionnée par défaut.

CET ARTICLE VOUS A-T-IL ÉTÉ UTILE ?

Pas utile