Création d'une icône de bibliothèque

Aide LabVIEW 2014

Date d'édition : June 2014

Numéro de référence : 371361L-0114

»Afficher les infos sur le produit
Télécharger l'aide (Windows uniquement)

Créez une icône pour représenter une bibliothèque de projet, un diagramme d'états-transitions, une classe ou une commandeX de manière graphique. Utilisez la boîte de dialogue de l'Éditeur d'icône pour créer ou éditer les icônes.

LabVIEW applique une icône de bibliothèque à l'icône de tous les objets de la bibliothèque. National Instruments vous recommande de créer uniquement une bannière pour l'icône de bibliothèque. L'icône pour chaque objet de la bibliothèque inclut alors la bannière et vous pouvez modifier le corps de l'icône pour fournir des informations sur l'objet spécifique.

Création d'une icône de bibliothèque de projet

Effectuez les étapes suivantes pour créer une icône pour une nouvelle bibliothèque de projet.

  1. Effectuez un clic droit sur l'élément bibliothèque de projet dans la fenêtre de l'Explorateur de projet et sélectionnez Propriétés dans le menu local pour afficher la boîte de dialogue Propriétés de la bibliothèque de projet. LabVIEW crée une bannière comme icône par défaut pour une nouvelle bibliothèque de projet. Remarquez l'icône de bibliothèque de projet par défaut dans la section Modèle d'icône de VI de la page Paramètres généraux.
  2. Cliquez sur le bouton Éditer l'icône de la page Paramètres généraux pour afficher la boîte de dialogue de l'Éditeur d'icône.
  3. (Facultatif) Utilisez l'outil Remplissage qui se trouve sur le côté droit de la boîte de dialogue de l'Éditeur d'icône pour remplir l'icône d'une autre couleur.
  4. Utilisez l'outil Texte pour saisir du texte dans la bannière de l'icône. Tant que le texte est actif, vous pouvez le déplacer en appuyant sur les touches fléchées.
  5. (Facultatif) Sélectionnez Fichier»Enregistrer sous»Modèle pour afficher la boîte de dialogue Enregistrer l'icône sous et enregistrez l'icône comme modèle pour un usage ultérieur. LabVIEW enregistre les modèles d'icônes comme fichiers .png à 256 couleurs.
  6. Cliquez sur le bouton OK pour enregistrer les informations sur l'icône avec la bibliothèque de projet et fermer la boîte de dialogue de l'Éditeur d'icône. Notez que l'icône 256 couleurs qui se trouve sur la page Paramètres généraux de la boîte de dialogue Propriétés de la bibliothèque de projet correspond à l'icône que vous avez créée.
  7. Cliquez sur le bouton OK pour fermer la boîte de dialogue Propriétés de la bibliothèque de projet.
Astuce  Vous pouvez utiliser le bouton Appliquer l'icône aux VIs, sur la page Paramètres généraux de la boîte de dialogue Propriétés de la bibliothèque de projet, pour appliquer automatiquement une icône de bibliothèque de projet existante aux VIs de la bibliothèque de projet.

Création d'une icône pour un VI d'une bibliothèque de projet

Effectuez les étapes suivantes pour créer une icône pour un nouveau VI d'une bibliothèque de projet.

  1. Cliquez avec le bouton droit sur l'élément bibliothèque de projet dans la fenêtre de l'Explorateur de projet et sélectionnez Nouveau»VI dans le menu local pour créer et ouvrir un nouveau VI. Remarquez que l'icône du VI qui se trouve en haut à droite sur la fenêtre de la face-avant comporte l'icône de la bibliothèque de projet.
  2. Double-cliquez sur l'icône du VI pour afficher la boîte de dialogue de l'Éditeur d'icône.
  3. Sélectionnez Calques»Afficher la page Calques pour afficher cette page si elle ne l'est déjà. Remarquez les options suivantes sur cette page :
    • L'icône de bibliothèque de projet apparaît sous forme d'un calque utilisateur appelé NI_Library.
      Remarque LabVIEW annule les changements d'opacité et de visibilité que vous avez effectuez sur le calque utilisateur NI_Library la prochaine fois que vous modifiez l'icône de bibliothèque de projet. Pour changer l'opacité ou la visibilité du calque utilisateur NI_Library de façon permanente, appliquez directement les changements sur l'icône de la bibliothèque de projet.
    • Un calque utilisateur appelé NI_IconNumber contient un chiffre qui indique combien de nouveaux VIs, jusqu'à 9, ont été ouverts depuis le lancement de LabVIEW.
      Remarque Pour désactiver cette numérotation, sélectionnez Outils»Options»Face-avant et désélectionnez l'option Utiliser des numéros dans les icônes des nouveaux VIs (de 1 à 9).
    • Un calque utilisateur appelé Icône du VI contient un cadre d'un pixel pour l'icône.
    • L'icône du VI utilise le modèle Blanc avec cadre, comme l'indique la section Modèle d'icône de la page Calques.
  4. (Facultatif) Cliquez sur l'aperçu du calque utilisateur NI_IconNumber et appuyez sur la touche <Suppr> pour supprimer le calque.
  5. Sur la page Texte de l'icône, entrez 4 lignes de texte au maximum pour le corps de l'icône. Vous pouvez configurer la police, la justification, la taille et la couleur du texte. Si vous sélectionnez l'option Centrer le texte verticalement, la boîte de dialogue de l'Éditeur d'icône centre le texte de l'icône verticalement dans le corps de l'icône.
  6. Sur la page Symboles, faites glisser les symboles pour les déposer sur la zone d'Aperçu.

    Pendant que vous déplacez le symbole, appuyez sur la touche <F> pour le retourner horizontalement ou sur la touche <R> pour le faire pivoter dans le sens des aiguilles d'une montre. Vous pouvez aussi double-cliquer sur un symbole pour le placer dans le coin supérieur gauche de l'icône. Vous pouvez parcourir les symboles par catégorie ou par mot-clé.
  7. Utilisez l'outil de déplacement pour déplacer un symbole. Chaque symbole se trouve sur un calque différent et est donc déplacé individuellement. Remarquez que le reste de l'icône devient grisé si vous sélectionnez un symbole. Ceci vous permet d'identifier quelle sélection vous êtes en train de déplacer.
  8. Utilisez les outils d'édition qui se trouvent sur côté droit de la boîte de dialogue de l'Éditeur d'icône pour éditer davantage l'icône si nécessaire.

    La boîte de dialogue de l'Éditeur d'icône crée un nouveau calque utilisateur à chaque fois que vous utilisez les outils d'édition de manière non consécutive. Sélectionnez Calque»Créer un nouveau calque pour créer un nouveau calque utilisateur pendant des utilisations consécutives des outils d'édition.
    Remarque Vous ne pouvez pas modifier le modèle d'icône ou le texte de l'icône avec les outils d'édition qui se trouvent à droite sur la boîte de dialogue de l'Éditeur d'icône. Utilisez la page Modèles pour modifier le modèle d'icône et la page Texte de l'icône pour modifier le texte de l'icône.
  9. Utilisez la page Calques pour configurer le nom, l'opacité, la visibilité et l'ordre des calques de l'icône.
  10. Cliquez sur le bouton OK pour enregistrer les informations sur l'icône avec le VI et fermer la boîte de dialogue de l'Éditeur d'icône.

CET ARTICLE VOUS A-T-IL ÉTÉ UTILE ?

Pas utile