Fonctionnalités et changements dans LabVIEW 2014

Aide LabVIEW 2014

Date d'édition : June 2014

Numéro de référence : 371361L-0114

»Afficher les infos sur le produit
Télécharger l'aide (Windows uniquement)

L'icône Échange d'idées indique une nouvelle fonctionnalité dérivée d'une suggestion figurant dans un commentaire à propos d'un produit dans les forums de discussion NI Idea Exchange à ni.com/fr.

Reportez-vous aux Notes de mise à jour LabVIEW 2014 pour obtenir la liste complète des nouvelles fonctionnalités et des changements, des informations concernant les problèmes de mise à niveau et de compatibilité spécifiques aux différentes versions de LabVIEW, et des instructions de mise à niveau.

Reportez-vous au fichier readme.html du répertoire labview pour en savoir plus sur les problèmes connus et obtenir la liste partielle des problèmes résolus, ainsi que des informations plus détaillées sur les problèmes de compatibilité et les fonctionnalités ajoutées tardivement à LabVIEW 2014.

Installation de LabVIEW

Reportez-vous au Guide d'installation de LabVIEW pour obtenir des informations d'installation pour LabVIEW, les modules et toolkits, les drivers et le matériel. Si vous rencontrez des difficultés lors de l'installation de LabVIEW, reportez-vous au Guide de dépannage de l'installation de LabVIEW.

Icônes de la barre d'état système spécifiques à la version et à la largeur de bits de LabVIEW

  LabVIEW 2014 introduit de nouvelles icônes sur la barre d'état système pour indiquer la version et la largeur de bit du logiciel LabVIEW installé :

Vous pouvez utiliser ces nouvelles icônes pour identifier plus facilement les différentes versions de LabVIEW installées sur un ordinateur. Par exemple, si LabVIEW 8.6 et LabVIEW 2014 sont installés, vous pouvez observer les icônes de la barre d'état système pour éviter d'ouvrir un VI dans la mauvaise version de LabVIEW. Comme les nouvelles icônes de la barre d'état système affichent aussi la largeur de bits, il est facile de différencier LabVIEW 2014 (32 bits) de LabVIEW 2014 (64 bits) si les deux sont installés.

Remarque  Les icônes de la barre d'état système spécifiques à la version et à la largeur de bits ne sont disponibles que sous les systèmes d'exploitation Windows et OS X.

|Idée soumise par Darren, membre de NI Discussion Forums.]

Installation et mise à jour des DataPlugins dans LabVIEW

Dans les versions antérieures de LabVIEW, vous devez télécharger les DataPlugins et les installer manuellement à partir de ni.com/dataplugins. Dans LabVIEW 2014, vous pouvez rechercher, installer et mettre à jour les DataPlugins directement en utilisant les VIs de la palette Stockage/DataPlugin.

Améliorations apportées au diagramme

Dans LabVIEW 2014, les améliorations suivantes ont été apportées au diagramme et aux fonctionnalités associées.

Création automatique de registres à décalage pour les boucles For et les boucles While

Dans LabVIEW 2014, si vous englobez du code existant dans une boucle For ou une boucle While, LabVIEW crée automatiquement des registres à décalage pour les entrées et sorties qui partagent le même type de données et une dépendance du flux de données comme, par exemple, les paramètres entrée d'erreur et sortie d'erreur.

Nouveau comportement par défaut des tunnels d'entrée des boucles For

Par défaut, si vous englobez du code existant dans une boucle For, LabVIEW crée automatiquement des tunnels d'entrée à indexation pour transférer les données au travers la boucle. LabVIEW crée des tunnels sans indexation si le fait d'englober du code existant dans une boucle For briserait le fil de liaison qui transfère les données du tunnel d'entrée à la boucle.

Nouveau comportement par défaut des tunnels d'entrée des boucles While

Par défaut, si vous englobez du code existant dans une boucle While, LabVIEW crée automatiquement des tunnels d'entrée sans indexation pour transférer les données au travers de la boucle si le fil de liaison qui sera connecté au tunnel d'entrée n'est pas brisé. Si le fil de liaison qui sera connecté au tunnel d'entrée est brisé avant même d'englober le code dans la boucle While, LabVIEW crée un tunnel d'entrée à indexation si cela corrigera le fil de liaison brisé.

[Idée soumise par jgcode, membre de NI Discussion Forums]

Remplacement d'un tunnel par un sélecteur de condition

Dans LabVIEW 2014, vous pouvez remplacer un tunnel d'entrée d'une structure Condition par le sélecteur de condition de cette structure. Cliquez sur un tunnel avec le bouton droit et sélectionnez Remplacer par un sélecteur de condition dans le menu local, et LabVIEW convertit le tunnel en sélecteur de condition. Si vous changez les données en entrée du sélecteur de condition, les conditions permises dans l'étiquette du sélecteur de condition peuvent changer. Si vous remplacez un tunnel par le sélecteur de condition, LabVIEW 2014 convertit aussi le sélecteur de condition d'origine en tunnel.

Remplacer par un sélecteur de condition

Après le remplacement par un sélecteur de condition

Vous pouvez aussi utiliser la méthode Remplacer par un sélecteur de condition pour convertir un tunnel en sélecteur de condition par programmation.

|Idée soumise par NelsonUWP, membre de NI Discussion Forums.]

Câblage automatique des objets dans un VI

Dans LabVIEW 2014, vous pouvez utiliser un raccourci de Placement rapide pour câbler rapidement des objets du diagramme les uns aux autres. Sélectionnez une ou plusieurs rangées d'objets parallèles et appuyez sur <Ctrl-Espace> pour ouvrir la boîte de dialogue Placement rapide. Lorsque la boîte de dialogue Placement rapide apparaît, appuyez sur <Ctrl-W>. LabVIEW câble automatiquement les objets sélectionnés les uns aux autres. Vous pouvez aussi appuyer sur <Ctrl-Maj-W> pour câbler les objets d'une ou de plusieurs rangées parallèles les uns aux autres sur le diagramme et nettoyer le code sélectionné.

Pour en savoir plus sur les raccourcis de placement rapide, reportez-vous à la rubrique Raccourcis clavier Placement rapide de l'Aide LabVIEW.

Améliorations apportées à la face-avant

Dans LabVIEW 2014, les améliorations suivantes ont été apportées à la face-avant et aux fonctionnalités associées.

Utilisation de commandes Argent

Dans LabVIEW 2014, utilisez la nouvelle palette Décorations de la palette Argent pour accéder facilement aux décorations de style Argent.

Améliorations apportées à l'environnement

Les améliorations suivantes ont été apportées à l'environnement de LabVIEW 2014.

Correction des erreurs causées par des sous-VIs manquants

Dans LabVIEW 2014, vous pouvez utiliser la fenêtre Liste des erreurs ou la fenêtre d'Aide contextuelle pour déterminer l'emplacement des sous-VIs manquants. Dans les versions antérieures de LabVIEW, la fenêtre Liste des erreurs indique si un sous-VI est manquant mais ne donne aucun détail sur son emplacement. Dans LabVIEW 2014, la fenêtre Liste des erreurs indique le driver, le toolkit ou le module qui contient le sous-VI manquant et fournit des informations permettant de corriger l'erreur causée par le sous-VI manquant. La fenêtre d'Aide contextuelle indique aussi le chemin du sous-VI manquant.

Revue et mise à jour des instances d'une définition de type

Dans LabVIEW 2013 et versions antérieures, lorsque vous appliquez les modifications d'une définition de type aux instances de cette définition de type, LabVIEW risque de perdre ou de conserver par erreur les valeurs par défaut des instances que vous voulez mettre à jour.

Dans la plupart des cas, LabVIEW 2014 conserve automatiquement les valeurs par défaut de chaque instance que vous mettez à jour à partir d'une définition de type. Si une instance ne peut pas être mise à jour automatiquement, LabVIEW la place dans un état "non résolu" jusqu'à ce que vous la mettiez à jour manuellement en utilisant la boîte de dialogue Revoir et mettre à jour à partir de la déf. de type.

Vous pouvez afficher la boîte de dialogue Revoir et mettre à jour à partir de la déf. de type en cliquant avec le bouton droit sur une instance non résolue et en sélectionnant Revoir et mettre à jour à partir de la déf. de type. L'élément Revoir et mettre à jour à partir de la déf. de type du menu local remplace l'élément Mettre à jour à partir de la déf. de type du menu local de LabVIEW 2013 et versions antérieures.

Rubriques apparentées

Mise à jour manuelle des instances d'une définition de type

Boîte de dialogue Revoir et mettre à jour à partir de la déf. de type

Améliorations apportées aux boîtes de dialogue

Les améliorations suivantes ont été apportées aux boîtes de dialogue de LabVIEW 2014.

Dépannage pour les codes d'erreur affichés dans les boîtes de dialogue d'erreurs

Dans LabVIEW 2014, vous pouvez facilement trouver des informations de dépannage pour les codes d'erreur affichés dans les boîtes de dialogue Expliquer l'erreur et VI Gestionnaire d'erreur simple. Cliquez sur le nouvel hyperlien Rechercher l'erreur sur ni.com pour afficher les résultats d'une recherche de l'erreur sur ni.com dans le navigateur Web par défaut. Par défaut, l'hyperlien apparaît également dans la boîte de dialogue du VI Gestionnaire d'erreur général. L'hyperlien n'apparaît que dans l'environnement de développement.

VIs, fonctions et nœuds nouveaux et modifiés

Fonctions, VIs et nœuds nouveaux

LabVIEW 2014 comprend les VIs, fonctions et nœuds nouveaux suivants.

Obtenir ou définir par programmation les informations de version d'une spécification de construction

La palette Application Builder inclut les nouveaux VIs suivants :

Utilisez ces VIs pour obtenir ou définir les informations de version par programmation pour toute spécification de construction qui a un numéro de version.

Communication avec des applications externes à partir de LabVIEW pour Mac OS X

LabVIEW 2014 pour Mac OS X inclut les palettes suivantes dotées de nouveaux VIs pour faciliter les communications avec les applications OS X externes à LabVIEW :

  • La palette Bibliothèques et exécutables inclut le VI Run AppleScript Code. Ce VI exécute du code AppleScript pour communiquer avec des applications OS X externes à partir de LabVIEW. Dans LabVIEW 2013 et versions antérieures, vous communiquez avec les applications Mac OS X externes à LabVIEW en utilisant les VIs Apple Event. Dans LabVIEW 2014, vous utilisez uniquement le VI Run AppleScript Code pour communiquer avec les applications Mac OS X externes à LabVIEW.
  • La palette Chaîne inclut le VI Uniformiser les fins de ligne. Ce VI convertit les fins de ligne de la chaîne que vous spécifiez au format de fin de ligne spécifié. Si vous ne spécifiez pas de format de fin de ligne, ce VI convertit les fins de ligne de la chaîne en fins de ligne attendues par la ligne de commande de la plate-forme actuelle. Utilisez ce VI pour que vos chaînes soient lisibles sous des plates-formes différentes ou dans la ligne de commande de la plate-forme actuelle.
  • La palette Conversions chemin/tableau/chaîne inclut les VIs suivants :
    • Path to Command Line String — Convertit le chemin en chaîne qui décrit ce chemin. Ce VI formate la chaîne de chemin avec le format de chemin de la ligne de commande de la plate-forme actuelle. Utilisez ce VI pour formater les chemins avant d'envoyer des commandes à la ligne de commande de la plate-forme actuelle.
    • Command Line String to Path — Convertit la chaîne spécifiée en chemin. La chaîne en entrée doit décrire un chemin dans le format standard de la ligne de commande de la plate-forme actuelle. Utilisez ce VI pour formater les chemins que vous recevez de la ligne de commande de la plate-forme actuelle afin de les utiliser avec LabVIEW.

VIs Framework d'acteur

LabVIEW 2014 comprend les nouveaux VIs suivants dans la palette Framework d'acteur :

  • Acteur : VI Lancer l'acteur racine — Lance un VI s'exécutant de manière asynchrone qui effectue des tâches et gère des messages pour l'Acteur. Ce VI renvoie une référence à un objet ajoutant des éléments à une file d'attente que vous pouvez utiliser pour envoyer des messages à l'acteur qui vient d'être lancé.
  • Acteur : VI Lancer un acteur imbriqué — Lance un VI s'exécutant de manière asynchrone qui effectue des tâches et gère des messages pour l'Acteur imbriqué. Utilisez ce VI pour lancer des acteurs imbriqués. Ce VI renvoie une référence à l'objet ajoutant des éléments à la file d'attente que vous pouvez utiliser pour envoyer des messages à l'acteur qui vient d'être lancé.
  • Acteur : VI Envoyer msg Lancer acteur imbriqué —Envoie un message contenant un acteur à un autre acteur. L'acteur recevant le message lancera l'acteur contenu dans le message comme un acteur imbriqué. Utilisez ce VI uniquement pour envoyer un message depuis un acteur à lui-même.

VIs et fonctions modifiés

Les VIs et fonctions suivants ont changé dans LabVIEW 2014.

VIs de stockage/DataPlugin

  • Ouvrir un stockage de données — Le bouton Obtenir d'autres DataPlugins sur ni.com/dataplugins de la boîte de dialogue de configuration de ce VI Express est remplacé par le bouton Installer/Mettre à jour des DataPlugins. Cliquez sur Installer/Mettre à jour des DataPlugins pour lancer la boîte de dialogue Installer/Mettre à jour des DataPlugins, qui vous permet de rechercher, installer et mettre à jour des DataPlugins à partir du site Web de National Instruments, à ni.com/dataplugins.
  • Lister les DataPlugins — Ce VI inclut la nouvelle entrée source, qui spécifie si LabVIEW liste les DataPlugins de l'ordinateur local ou du site Web de National Instruments.
  • Enregistrer un DataPlugin — Ce VI inclut la nouvelle instance Installer un DataPlugin d'après son nom. Vous pouvez utiliser cette instance pour installer des DataPlugins sur l'ordinateur local à partir de ni.com/dataplugins.

Modifications diverses apportées aux VIs et fonctions

LabVIEW 2014 comprend les changements de VIs et fonctions divers suivants :

  • Obtenir la hiérarchie d'une classe à partir du nom de la classe — Renvoie le tableau des noms des classes en ordre décroissant en utilisant un nom de classe spécifié qui hérite de Générique. Par exemple, si nom de classe est WhileLoop, ce VI renvoie le tableau suivant :

    [Generic, GObject, Node, Structure, Loop, WhileLoop]
  • Secondes relatives haute résolution — Renvoie la valeur du timer. Ce VI est semblable à la fonction Compteur d'impulsions d'horloge (ms) si ce n'est qu'il fournit un horodatage à une bien plus grande résolution. Vous pouvez utiliser ce VI pour établir un niveau de référence à haute précision pour du code.
  • Chemin non vide ? — Si Chemin a une valeur autre qu'un chemin vide ou <Pas un chemin>, ce VI renvoie VRAI. Sinon, ce VI renvoie FAUX.
  • Constante variant — Utilisez ce VI pour transmettre un variant vide au diagramme. LabVIEW dépose toujours un variant vide lorsque vous utilisez ce VI. LabVIEW ne vous autorise pas à éditer la valeur du variant.
  • Msg de rapport d'erreur : VI Envoyer un rapport d'erreur — Utilisez ce VI pour envoyer une erreur à un acteur. L'erreur sera gérée par le VI Gérer l'erreur de l'acteur. Si l'erreur n'est pas gérée là, l'acteur arrêtera de s'exécuter.
  • TDMS - Définir des propriétés — Cette fonction inclut les améliorations apportées à la propriété NI_MinimumBufferSize en vous permettant de définir la taille minimale du buffer au niveau du groupe ou du fichier pour un fichier .tdms.
  • Effacer les erreurs — Ce VI comprend la nouvelle entrée code d'erreur spécifique à effacer, qui ignore le code d'erreur spécifique relié à cette entrée. Ce VI comprend aussi la nouvelle sortie erreur spécifique effacée ? qui indique si l'erreur référencée par code d'erreur spécifique à effacer a été effacée.

Améliorations apportées à Application Builder

LabVIEW 2014 inclut les améliorations suivantes apportées à LabVIEW Application Builder et aux spécifications de construction.

Déploiement d'installeurs sur des cibles Windows Embedded Standard

Vous pouvez déployer un installeur construit sur une cible exécutant le système d'exploitation Windows Embedded Standard. Dans l'Explorateur de projet, sous la cible Windows Embedded Standard, cliquez avec le bouton droit sur la spécification de construction et sélectionnez Déployer ou Installer.

Améliorations apportées au chargement des bibliothèques de projet empaquetées et des bibliothèques partagées de la même version

Pour simplifier le chargement des bibliothèques partagées à partir de VIs et de bibliothèques de projet empaquetées, LabVIEW 2014 n'affiche plus la boîte de dialogue Résumé des mises en garde du chargement qui est lancée dans les versions antérieures de LabVIEW lorsque qu'il existe des références croisées dans les bibliothèques partagées ou les bibliothèques de projet empaquetées. Une référence croisée se produit lorsque vous chargez une bibliothèque partagée à partir d'un VI ou d'une bibliothèque de projet empaquetée, puis que vous chargez une autre bibliothèque partagée du même nom à partir d'un autre VI ou d'une autre bibliothèque de projet empaquetée se trouvant à un emplacement différent, alors que la première bibliothèque est encore en mémoire. Au moment de charger la seconde bibliothèque partagée, LabVIEW se lie à l'emplacement de la première bibliothèque partagée. Les bibliothèques partagés ou bibliothèques de projet empaquetées doivent avoir le même numéro de version pour que leur version soit la même.

Exclusion des bibliothèques de projet empaquetées et partagées dépendantes d'une spécification de construction

Dans LabVIEW 2014, vous pouvez réduire le nombre de fichiers que LabVIEW copie lorsque vous générez plusieurs constructions qui incluent les mêmes bibliothèques. Vous pouvez spécifier qu'il faut exclure les bibliothèques empaquetées et les bibliothèques partagées dépendantes d'une spécification de construction, et LabVIEW conserve les liens relatifs à l'emplacement source des fichiers exclus. Sinon, LabVIEW copie les bibliothèques de projet empaquetées et les bibliothèques partagées à chaque génération de construction ultérieure. Pour exclure ces bibliothèques, activez les options Exclure les bibliothèques empaquetées dépendantes et Exclure les bibliothèques partagées dépendantes sur la page Autres exclusions de la boîte de dialogue Propriétés de la spécification de construction.

Définition de la destination des bibliothèques de projet empaquetées et partagées incluses dans une spécification de construction.

Dans LabVIEW 2014, vous pouvez spécifier les destinations des bibliothèques de projet empaquetées et des bibliothèques partagées dépendantes incluses dans une configuration de spécification de construction. Pour spécifier les destinations des fichiers dépendants, sélectionnez Dépendances sur la page Paramètres des fichiers source d'une spécification de construction. Activez Définir une destination pour tous les éléments contenus et Définir la destination des biblio. empaquetées et partagées, et sélectionnez les destinations à partir du menu local.

Gestion de code compilé pour une distribution de code source

Dans LabVIEW 2013 et versions antérieures, vous pouvez utiliser l'option Supprimer le code compilé de la page Autres exclusions de la boîte de dialogue Propriétés pour réduire la taille d'une distribution de code source. LabVIEW 2014 fournit les options supplémentaires suivantes pour gérer le code compilé :

  • Préserver le code compilé — Conserve le code compilé de tous les fichiers.
  • Préserver les paramètres de fichier de chaque VI ou bibliothèque — Conserve les paramètres enregistrés de chaque fichier.

Fonctionnalités supplémentaires dues à la consolidation de compléments logiciels

Les consolidations de compléments logiciels suivantes fournissent des fonctionnalités supplémentaires à LabVIEW 2014 :

  • Les systèmes de développement complet et professionnel de LabVIEW 2014 comportent toutes les fonctionnalités du toolkit LabVIEW PID and Fuzzy Logic, à l'exception du VI Express PID (FPGA), qui fait partie du module LabVIEW 2014 FPGA.
  • Le système de développement professionnel de LabVIEW 2014 comporte désormais les toolkits suivants :
    • Toolkit LabVIEW Database Connectivity
    • Toolkit LabVIEW Desktop Execution Trace
    • Toolkit LabVIEW Report Generation
    • Toolkit LabVIEW Unit Test Framework
    • Toolkit LabVIEW VI Analyzer

Les consolidations de toolkits suivantes fournissent aussi des fonctionnalités supplémentaires :

  • Le toolkit LabVIEW 2014 Digital Filter Design inclut le toolkit LabVIEW Adaptive Filter Design.
  • Le module LabVIEW 2014 Control Design and Simulation et le toolkit LabVIEW 2014 Advanced Signal Processing incluent le toolkit LabVIEW System Identification.
  • Le module LabVIEW 2014 FPGA inclut le toolkit FPGA Compile Farm, désormais appelé FPGA Compile Farm Server, et FPGA IP Builder.
  • Le module LabVIEW 2014 Real-Time inclut Real-Time Trace Viewer.

Nouvelles suites LabVIEW

Afin de vous aider à répondre à vos besoins en matière de visualisation, d'analyse, de distribution et d'ingénierie logicielle, et à construire des systèmes avec assurance, les suites LabVIEW comprennent, dans un seul ensemble logiciel, l'édition professionnelle de LabVIEW ainsi que nos logiciels d'application les plus couramment utilisés et des compléments logiciels. Vous pouvez choisir parmi les trois suites LabVIEW suivantes, conçues pour différents domaines d'application :

  • Suite LabVIEW 2014 Automated Test
  • Suite LabVIEW 2014 Embedded Control and Monitoring
  • Suite LabVIEW 2014 HIL and Real-Time Test

Allez sur ni.com/labview/suites pour en savoir plus sur les nouvelles suites LabVIEW.

Améliorations apportées aux services Web LabVIEW

Dans LabVIEW 2014, les améliorations suivantes ont été apportées aux services Web LabVIEW et aux fonctionnalités associées.

Sécurité améliorée pour les services Web LabVIEW

LabVIEW 2014 met à jour les services Web pour utiliser la version 1.0.1g du protocole de sécurité OpenSSL.

Fournir une documentation personnalisée pour les VIs et les applications

Dans LabVIEW 2014, vous pouvez lier un VI à de la documentation Web ou locale à partir de la fenêtre d'Aide contextuelle. (Windows) Utilisez n'importe quel type de fichier pour la documentation personnalisée, à l'exception des fichiers texte. (OS X et Linux) N'utilisez que des fichiers HTML (.html et .htm) et PDF pour la documentation personnalisée.

Remarque  (Linux) Afin d'utiliser un fichier PDF pour de la documentation personnalisée, un des outils de visualisation PDF suivants doit être installé :
  • Acroread
  • Xpdf
  • KPDF
  • GGV

Dans LabVIEW 2014, vous pouvez aussi fournir de la documentation personnalisée à partir du menu Aide d'un VI ou d'une application.

Liaison des VIs à de la documentation Web

Pour lier un VI à de la documentation Web à partir de la fenêtre d'Aide contextuelle, sélectionnez l'option Aide Web dans le menu déroulant de la page Documentation de la boîte de dialogue Propriétés du VI. Utilisez le champ URL de l'aide pour spécifier l'URL de la rubrique à lier au VI.

Liaison des VIs à de la documentation locale

Pour lier un VI à de la documentation locale à partir de la fenêtre d'Aide contextuelle, sélectionnez l'option Fichier d'aide local dans le menu déroulant de la page Documentation de la boîte de dialogue Propriétés du VI. Utilisez le champ Chemin de l'aide pour naviguer jusqu'à la documentation personnalisée sur l'ordinateur local. Vous avez l'option d'utiliser la zone de texte Repère dans l'aide pour lier un VI à une rubrique HTML d'un fichier d'aide compilée ou pour lier un VI à un signet dans un fichier d'aide HTML. Sinon, laissez la zone de texte Repère de l'aide vide.

Par exemple, si vous spécifiez un fichier d'aide compilée nommé Mon aide personnalisée.chm dans la zone de texte Chemin de l'aide, vous pouvez entrer Initiation.html#Intro dans le champ Repère dans l'aide pour que le lien Aide détaillée et le bouton Aide détaillée de la fenêtre d'Aide contextuelle lient directement aux informations d'introduction fournies dans l'aide compilée personnalisée.

Lien d'un VI à de la documentation Web ou locale par programmation

Utilisez la propriété Aide:Utiliser URL Web de la classe VI pour indiquer qu'il faut lier un VI à un fichier d'aide Web. Pour spécifier l'URL du fichier d'aide, utilisez la propriété Aide:URL Web du document de la classe Propriétés.

Vous pouvez lier un VI à un fichier d'aide local en câblant la référence du VI à la propriété Chemin du document et en spécifiant l'emplacement du fichier d'aide sur l'ordinateur local. Vous pouvez aussi utiliser la propriété Aide:Repère du document pour lier un VI à une rubrique HTML spécifique d'un fichier d'aide compilé ou à un signet d'un fichier HTML.

Rubriques apparentées

Fourniture d'aide personnalisée à partir du menu Aide

Dans LabVIEW 2014, vous pouvez fournir de l'aide personnalisée à partir du menu Aide. (Windows) Utilisez n'importe quel type de fichier, mis à part les fichiers texte, pour la documentation personnalisée. (OS X et Linux) Vous ne pouvez utiliser que les fichiers HTML (.html et .htm) et PDF pour l'aide personnalisée.

Remarque  (Linux) Afin d'utiliser un fichier PDF pour de la documentation personnalisée, un des outils de visualisation PDF suivants doit être installé :
  • Acroread
  • Xpdf
  • KPDF
  • GGV

Effectuez les étapes suivantes pour afficher l'aide personnalisée dans le menue Aide :

  1. Placez le fichier d'aide personnalisée dans le répertoire labview\help.
  2. Placez un fichier texte qui porte le même nom que le fichier d'aide personnalisée dans le répertoire labview\help. Par exemple, si vous nommez le fichier d'aide Mon aide personnalisée.html, vous devez nommer le fichier texte qui contient le titre du menu Mon aide personnalisée.txt. Dans ce fichier texte, incluez le titre de l'aide que vous voulez afficher dans le menu Aide.
Remarque  La seule information à fournir dans le fichier texte est le titre de l'aide personnalisée que vous voulez afficher dans le menu Aide.

LabVIEW 2014 (64 bits) pour Mac OS X

LabVIEW 2014 introduit une version 64 bits du Système de développement LabVIEW pour OS X. LabVIEW 2014 (64 bits) pour Mac OS X inclut virtuellement toutes les fonctionnalités de l'environnement de développement de LabVIEW 2014 (32 bits) pour Mac OS X. Le tableau suivant décrit les différences entre LabVIEW 2014 (32 bits) et LabVIEW 2014 (64 bits) pour Mac OS X.

Pour tester les problèmes de compatibilité suivants dans des VIs existants, visitez le site Web de National Instruments sur ni.com/info, puis entrez l'info-code analyzevi pour télécharger des tests automatisés.

Différence LabVIEW 2014 (32 bits) LabVIEW 2014 (64 bits)
Emplacement de l'application 32-bit /Applications/National Instruments/LabVIEW 2014/LabVIEW.app 64-bit/Applications/National Instruments/LabVIEW 2014 64-bit/LabVIEW.app
Format Chaîne de chemin Mac classique (Macintosh HD:Users:johnd:Desktop) POSIX (/Users/johnd/Desktop)
Valeur constante fin de ligne CR (retour chariot) LF (retour à la ligne)
CIN Supporté Non supporté
Encodage de texte Encodage système Mac classique UTF-8
Aperçu Fonctionnalité d'aperçu d'impression non native Fonctionnalité d'aperçu d'impression à partir de la boîte de dialogue Impression
Remarque  LabVIEW 2014 (64 bits) pour Mac OS X supporte un nombre limité de drivers, modules et toolkits National Instruments. Reportez-vous à la Base de connaissances sur ni.com/info pour obtenir plus d'informations.

LabVIEW 2014 (64 bits) pour Linux

LabVIEW 2014 introduit une version 64 bits du Système de développement LabVIEW pour Linux. LabVIEW 2014 (64 bits) pour Linux supporte toutes les fonctionnalités de LabVIEW 2014 (32 bits) pour Linux à l'exception des fonctionnalités et compléments logiciels suivants :

  • Assistant de recherche de drivers d'instruments NI
  • Module LabVIEW Control Design and Simulation
  • Toolkit LabVIEW VI Analyzer

Changements dans les fonctionnalités du Touch Panel

Protection des données contre les modifications avec les VIs de Filtre d'écriture

LabVIEW 2014 inclut les VIs de Filtre d'écriture sur la palette VIs et fonctions de Fonctions de fichiers avancées. Les filtres d'écriture protègent les données de toute modification non intentionnelle en redirigeant les opérations d'écriture vers un autre emplacement ou couche. Utilisez les filtres d'écriture améliorés (EWF) pour protéger des volumes et rediriger les écritures vers un emplacement sur disque ou un autre volume, ou vers la RAM. Utilisez les filtres d'écriture basés sur fichiers (FBWF) pour protéger des fichiers et des dossiers d'un volume et rediriger les écritures vers la mémoire cache.

Auparavant, le module Touch Panel était requis pour utiliser les VIs de Filtre d'écriture. Dans LabVIEW 2014, les VIs de Filtre d'écriture sont disponibles lorsque vous développez une application pour cible à écran tactile dans la fenêtre de l'Explorateur de projet. LabVIEW Application Builder est requis pour que les applications pour cibles à écran tactile soient supportées ; il est disponible dans le système de développement professionnel de LabVIEW.

Utilisation du modèle de projet Écran tactile et de VIs modèle pour écran tactile

Le modèle de projet Écran tactile vous aide à créer des projets qui ciblent un périphérique à écran tactile exécutant le système d'exploitation Windows Embedded Standard 7. Ce modèle de projet inclut un VI modèle que vous pouvez adapter à votre propre application pour écran tactile. Sélectionnez Fichier»Créer un projet et rechercher le modèle Projet Écran tactile. Utilisez la boîte de dialogue Créer un projet pour configurer les paramètres du projet, y compris la cible à écran tactile et le VI modèle. Reportez-vous au dossier Project Documentation dans la fenêtre de l'Explorateur de projet pour obtenir des informations complémentaires sur la façon de modifier le projet.

Vous pouvez aussi ajouter un VI modèle pour écran tactile à une cible à écran tactile existante. LabVIEW inclut des modèles en mode portrait et en mode paysage dont les interfaces utilisateur sont prédéfinies pour le périphérique à écran tactile. Ces modèles comprennent les commandes et indicateurs communément utilisés dans les applications pour écran tactile. Faites un clic droit sur une cible à écran tactile et sélectionnez Nouveau VI modèle pour ajouter un VI modèle pour écran tactile à la cible. La boîte de dialogue Sélectionner un modèle apparaît. Sélectionnez le VI modèle à utiliser avec la cible.

Utilisation de cibles à écran tactile

LabVIEW 2014 inclut le support pour le développement, la mise au point et le déploiement d'applications LabVIEW vers une cible à écran tactile qui exécute le système d'exploitation Windows Embedded Standard 7. Dans le passé, le module LabVIEW Touch Panel était requis pour développer, mettre au point et déployer des applications pour des cibles à écran tactile. Avec LabVIEW 2014, vous pouvez développer et mettre au point des applications Écran tactile sur l'ordinateur hôte et vous déployez ces applications de l'ordinateur hôte sur la cible à écran tactile. Le support des cibles à écran tactile requiert LabVIEW Application Builder. La version Système de développement professionnel LabVIEW inclut Application Builder.

Toolkits nouveaux et modifiés

Toolkit LabVIEW Third Party Licensing and Activation

Avec le toolkit LabVIEW Third Party Licensing and Activation 2014, vous pouvez permettre aux utilisateurs de désactiver un complément logiciel dont la licence est regroupée avec celle du toolkit. Pour désactiver un complément logiciel, sélectionnez Aide»Activer des compléments logiciels pour lancer l'Assistant d'activation pour les compléments logiciels de tiers. Sélectionnez le complément logiciel, cliquez sur Désactiver et suivez les étapes dans l'assistant.

CET ARTICLE VOUS A-T-IL ÉTÉ UTILE ?

Pas utile