アイコンエディタダイアログボックス



LabVIEW 2018ヘルプ


発行年月: 2018年3月
製品番号: 371361R-0112
製品情報を参照

ダウンロード (Windowsのみ)


LabVIEW 2016ヘルプ
LabVIEW 2017ヘルプ
LabVIEW 2018ヘルプ
LabVIEW 2019ヘルプ
LabVIEW 2020ヘルプ

インストールパッケージ: ベース開発システム

以下の方法のいずれかでダイアログボックスを表示してください。

  • フロントパネルウィンドウ、ブロックダイアグラムウィンドウ、または制御器エディタウィンドウの右上隅で、アイコンをダブルクリックします。
  • フロントパネルウィンドウ、ブロックダイアグラムウィンドウ、または制御器エディタウィンドウの右上隅でアイコンをダブルクリックし、ショートカットメニューからアイコンを編集を選択します。
  • ファイル→VIプロパティまたはファイル→制御器プロパティを選択して、VIプロパティダイアログボックスまたは制御器プロパティダイアログボックスをそれぞれ表示します。 そして、カテゴリプルダウンメニューから一般を選択し、アイコンを編集ボタンをクリックします。
  • プロジェクトエクスプローラウィンドウでプロジェクトライブラリ、ステートチャート、クラス、またはXControl項目を右クリックし、ショートカットメニューからプロパティを選択して対応するプロパティダイアログボックスを表示します。 そして、一般設定ページで編集ボタンをクリックします。

このダイアログボックスを使用して、アイコンの作成や編集を実行します。

メモ アイコンエディタダイアログボックスは、アイコンを24ビットカラーで表示します。 しかし、LabVIEWのブロックダイアグラムではアイコンを8ビットカラーのみで表示します。 そのため、このダイアログボックスで作成したアイコンは、ブロックダイアグラム上の対応するアイコンとは多少異なって見える場合があります。

このダイアログボックスには以下のページおよびコンポーネントが含まれます。

  • テンプレート—アイコンの背景として使用できるアイコンテンプレートを表示します。 このページは、LabVIEW Data\アイコンテンプレートディレクトリのすべての.png.bmp、および.jpgファイルを表示します。
    • カテゴリ—選択可能なアイコンテンプレートのカテゴリを示します。 カテゴリの名前は、LabVIEW Data\アイコンテンプレートディレクトリのサブフォルダの名前に対応します。 すべてのテンプレートカテゴリは常に表示され、LabVIEW Data\アイコンテンプレートディレクトリのすべてのアイコンテンプレートが含まれます。
    • キーワードでテンプレートをフィルタ—アイコンテンプレートのリストのフィルタに使用するキーワードを指定する。 アイコンエディタダイアログボックスは、指定したキーワードが名前に含まれるすべてのアイコンテンプレートを表示します。
    • テンプレートをディスクから更新—テンプレートの内部キャッシュを更新します。 このボタンは、ライブラリにテンプレートを追加したり、ライブラリからテンプレートを削除したりするときに使用します。
  • アイコンテキスト—アイコンに表示するテキストを指定します。
    • ラインテキスト—アイコンのテキストラインを指定します。
    • 線の色—アイコンの対応するテキストラインの色を指定します。
    • フォントアイコンテキストページで入力したすべてのテキストのフォントを指定します。
    • アライメントアイコンテキストページで入力したすべてのテキストのアライメントを指定します。
    • サイズアイコンテキストページで入力したすべてのテキストのフォントサイズを指定します。
    • テキストを縦中央に配置—アイコン内でテキストラインを垂直方向に中央に表示するかどうかを指定します。 バナー付きのアイコンテンプレートを使用してチェックボックスをオンにした場合は、アイコンエディタダイアログボックスはアイコンの中でアイコンテキストを垂直方向に中心に表示します。
    • テキストを大文字にするアイコンテキストページで入力したすべてのテキストを大文字にするかどうかを指定します。
  • グリフ—アイコンに含めることが可能なグリフを表示します。 アイコンエディタダイアログボックスは、LabVIEW Data\Glyphsディレクトリのすべての.png.bmp、および.jpgファイルを表示します。 デフォルトで、このページにはni.comアイコンライブラリのすべてのグリフが含まれます。 LabVIEW Data¥Glyphsディレクトリとアイコンライブラリの最新のグリフを同期するには、ツール→ni.comアイコンライブラリと同期を選択してアイコンライブラリと同期ダイアログボックスを開きます。
    ヒント 編集→ファイルからグリフをインポートを選択すると、特定のグラフィックファイルを選択またはインポートするためのファイルダイアログボックスが開きます。
    • カテゴリ—選択可能なグリフのカテゴリを示します。 カテゴリの名前は、LabVIEW Data\Glyphsディレクトリのサブフォルダの名前に対応します。 すべてのグリフカテゴリは常に表示され、LabVIEW Data\Glyphsディレクトリのすべてのグリフが含まれます。
    • キーワードでグリフをフィルタ—グリフのリストのフィルタに使用するキーワードを指定する。 アイコンエディタダイアログボックスは、指定したキーワードが名前に含まれるすべてのグリフを表示します。
    • グリフをディスクから更新—グリフの内部キャッシュを更新します。 このボタンは、ライブラリにグリフを追加したり、ライブラリからグリフを削除したりするときに使用します。
  • レイヤ—アイコンのすべてのレイヤを表示します。 まだ表示されていない場合は、レイヤ→レイヤページを表示を選択してこのページを表示します。
    • アイコンテキストアイコンテキストレイヤのプレビュー、名前、不透明度、および可視性を表示します。 このレイヤは、アイコンエディタダイアログボックスのアイコンテキストページに入力したすべてのテキストから構成されています。 このレイヤの不透明度と可視性のみを変更できます。
    • ユーザレイヤ—すべてのユーザレイヤのプレビュー、名前、不透明度、および可視性を表示します。 各ユーザレイヤーを選択するには、レイヤページでプレビューをクリックするか、アイコンエディタダイアログボックスプレビュー領域での移動ツールを使用します。
      • レイヤを追加—ユーザレイヤを追加します。
      • レイヤを削除—選択したレイヤを削除します。
      • 上に移動—選択したレイヤを1つ上のレベルに移動します。
      • 下に移動—選択したレイヤを1つ下のレベルに移動します。
    • アイコンテンプレートアイコンテンプレートレイヤのプレビュー、名前、不透明度、および可視性を表示します。 このレイヤは、アイコンエディタダイアログボックスのテンプレートページで選択したアイコンテンプレートから構成されています。 このレイヤの不透明度と可視性のみを変更できます。
  • プレビュー—アイコンの拡大プレビューを表示します。 プレビューアイコンエディタダイアログボックスで変更する度にアップデートします。
  • アイコン—アイコンのプレビューを実際のサイズで表示します。 アイコンアイコンエディタダイアログボックスで変更する度にアップデートします。
  • RGB—カーソル位置に対応するピクセルのRGBカラー成分を表示します。
  • XYZ—カーソル位置に対応するピクセルのx-y位置を表示します。 Z値はアイコンでのユーザレイヤの合計数を示します。
  • 工具類—アイコンを手動で変更するのに使用できる編集ツールを表示します。 編集ツールを使用中に左クリックすると、LabVIEWはラインカラーを使用します。 編集ツールを使用中に右クリックすると、LabVIEWは塗りつぶしカラーを使用します。
  • 左右反転—選択したユーザレイヤを左右に反転します。 レイヤを選択しない場合、このツールはすべてのユーザレイヤを反転します。
    メモ <F>キーを押して選択したユーザレイヤを反転することもできます。
  • 右方向へ回転—選択したユーザレイヤを右方向へ回転します。 レイヤを選択しない場合、このツールはすべてのユーザレイヤを回転します。
    メモ <R>キーを押して選択したユーザレイヤを回転することもできます。
  • ラインカラー—直線または境界の色を指定します。 ラインカラーの長方形をクリックすると、新しい色を選択するためのカラーパレットが開きます。
  • 塗りつぶしカラー—領域を塗りつぶす色を指定します。 塗りつぶしカラーの長方形をクリックすると、新しい色を選択するためのカラーパレットが開きます。
  • カラーを入れ替えラインカラー塗りつぶしカラーを入れ替えます。

カスタム編集環境を作成した場合は、アイコンエディタダイアログボックスを変更できます。 アイコンエディタダイアログボックスを変更するには、ni.comからアイコンエディタソースファイルをダウンロードします。 カスタムのアイコンエディタを作成する場合、labview¥resource¥plugins¥IconEditor¥Discover Who Invoked the Icon Editor.viの「Discover Who Invoked the Icon Editor」VIを呼び出して、アイコンが編集中である現在の項目の名前、パス、およびアプリケーションリファレンスを取得できます。 この情報を使用して、ユーザが指定する方法でアイコンをカスタマイズできます。 たとえば、VIまたはライブラリのタイプに基づいて、アイコンにカスタムのグリフを追加したい場合があります。

カスタムアイコンエディタを作成するには、呼び出し時にフロントパネルが開くようVIを構成する必要があります。 開く前にフロントパネルを整列する必要がない簡単なVIでは、実行:呼び出されたらフロントパネルを表示プロパティを使用します。 開く前にフロントパネルを整列する必要がある複雑なVIでは、フロントパネル:開くメソッドを使用します。



この記事は役に立ちましたか。

役に立たなかった