メニューエディタダイアログボックス



LabVIEW 2018ヘルプ


発行年月: 2018年3月
製品番号: 371361R-0112
製品情報を参照

ダウンロード (Windowsのみ)


LabVIEW 2015ヘルプ
LabVIEW 2016ヘルプ
LabVIEW 2017ヘルプ
LabVIEW 2018ヘルプ
LabVIEW 2019ヘルプ

インストールパッケージ: ベース開発システム

このダイアログボックスを表示するには、編集→ランタイムメニューを選択します。

このダイアログボックスを使用して、ランタイムメニュー(RTM)ファイルを作成および編集し、それらをVIに関連付けます。

カスタムメニューの作成やLabVIEWのデフォルトメニューの変更は、VIの作成時に静的に行うか、あるいはVIの実行中にプログラム上で行います。

オプションダイアログボックスのメニューショートカットページを使用して、編集時のショートカットメニューをカスタマイズします。

このダイアログボックスには以下のコンポーネントが含まれています。

  • ダイアログボックスのメニューバーファイルおよび編集メニューを使用して、メニュー項目の作成と配置を制御します。
  • 挿入—選択項目の下に新しい項目を挿入します。
  • 削除—リストから選択項目を削除します。
  • —選択した項目の後ろの項目をサブ項目にします。
  • —選択した項目をその前のメニュー項目のサブ項目にします。
  • —選択した項目をメニューリストで1つ上に移動します。 選択した項目にサブ項目がある場合、サブ項目は選択した項目と共に移動します。
  • —選択した項目をメニューリストで1つ下に移動します。 選択した項目にサブ項目がある場合、サブ項目は選択した項目と共に移動します。
  • メニュータイプ—実行時にVIに関連付ける以下の3つのメニュータイプのうちの1つを示します。 プルダウンメニューからタイプを選択します。
    • デフォルト—標準メニューを表示します。
    • 最小—標準メニューの使用頻度の高い項目だけを表示します。
    • カスタム—カスタムメニューの作成、編集、RTMファイルへの保存を可能にします。
    デフォルトタイプおよび最小タイプはコピーできますが、編集は行えません。
  • プレビュー—作成するメニューのプレビューを表示します。 また、プレビューツリーに表示されるメニュー項目のアプリケーション項目タグを表示することもできます。
  • メニュー階層—ツリーにメニュー階層を表示します。
  • 項目タイプ—以下の3つのメニュー項目のうちの1つを示します。
    • ユーザ項目—ブロックダイアグラムでプログラム的に処理する必要がある新規項目を入力できます。 ユーザ項目には、メニューに表示される文字列の名前と大文字と小文字を区別する固有の文字列識別子のタグが含まれます。 タグによって、ブロックダイアグラム上のユーザ項目が識別されます。 名前を入力すると、LabVIEWはその名前をタグにコピーします。 タグは名前と異なるように編集できます。 メニュー項目を有効にするには、タグに値が割り当てられている必要があります。 項目タグテキストボックスには、無効なメニュー項目に対して疑問符が表示されます。 LabVIEWは、タグがメニュー階層に対して固有であることを確認し、必要に応じて数字を追加します。
    • 区切り線—メニューに区切り線を挿入します。 この項目に属性は設定できません。
    • アプリケーション項目—デフォルトメニュー項目を選択できます。 メニュー項目を挿入するには、アプリケーション項目を選択して、階層に従って追加する項目に移動します。個々の項目かサブメニュー全体を追加します。 LabVIEWは、自動的にアプリケーション項目を処理します。 これらの項目タグは、ブロックダイアグラムに表示されません。 アプリケーション項目の名前、タグ、またはその他の属性は変更できません。 LabVIEWは、APP_の接頭辞をアプリケーション項目タグのすべてに追加します。
  • 項目名—メニューに表示される文字列を表示します。
  • 項目タグ—メニュー項目の固有の識別子を表示します。 各メニュー項目には固有の識別子が必要です。 ブロックダイアグラムはこの文字列を使用してメニュー項目を識別します。 識別子は大文字と小文字を区別し、LabVIEWは末尾と先行の空白を無視します。 入力するタグが有効または固有でない場合、LabVIEWはタグを赤でハイライトします。
  • 有効—メニューの選択されたメニュー項目を有効にするか、または淡色表示にするかを指定します。
  • チェックマーク—チェックマークをメニュー上のメニュー項目の横に配置するかどうかを指定します。
  • ショートカット—メニュー項目にアクセスするために押すキーの組み合わせを表示します。 新しいショートカットを作成するには、このフィールドにカーソルを置き、ショートカットに使用するキーを押します。 <alphanumeric key>または<alphanumeric key-Shift>を押す際、LabVIEWは自動的に修飾キーとして<Ctrl>を追加します。 <Ctrl>キーを修正キーとして使用せずに、<F1>~<F24>ファンクションキーを使用できます。 (macOS) <Command>キーが修正キーとして使用されます。 重複しているショートカットには警告が表示されないため、ショートカットが重複しないように確認してください。 macOSでは、LabVIEWは、<VolumeUp>、<VolumeDown>、<F15>~<F24>のファンクションキーをショートカットキーとしてサポートしていません。


この記事は役に立ちましたか。

役に立たなかった