環境ページ(オプションダイアログボックス)



LabVIEW 2018ヘルプ


発行年月: 2018年3月
製品番号: 371361R-0112
製品情報を参照

ダウンロード (Windowsのみ)


LabVIEW 2016ヘルプ
LabVIEW 2017ヘルプ
LabVIEW 2018ヘルプ
LabVIEW 2019ヘルプ
LabVIEW 2020ヘルプ

インストールパッケージ: ベース開発システム

このページを表示するには、ツール→オプションを選択してオプションダイアログボックスを表示し、カテゴリリストから環境を選択します。

このページを使用してLabVIEW環境のその他のオプションを設定します。

このページには以下のコンポーネントがあります。

  • 一般—このセクションを使用して、一般的な環境オプションを設定します。
    • VISAセッションを自動的に閉じる—トップレベルVIがアイドル状態になったときに、アプリケーションによって開いたままになっていたVISAセッションを自動的に閉じます。 このチェックボックスは、デフォルトでオフになっています。
    • Enterキーでテキスト入力を終了—キーボードで<Enter>キーを押してテキスト入力を終了できるようにします。 このチェックボックスは、デフォルトでオフになっています。 このチェックボックスをオンにすると、キーボードの<Enter>キーは、テンキーボードの<Enter>キーと同様にテキスト入力の終了に使用できます。 新しい行をテキストボックスに追加するには、<Ctrl-Enter>キーを押します。 (macOS) <Option-Return>キーを押します。 (Linux) <Alt-Return>キーを押します。
    • 自動ツール選択をロック—<Tab>または<Shift-Tab>キーを押すと、自動ツール選択が有効な状態で維持されます。 このチェックボックスは、デフォルトでオンになっています。 このチェックボックスをオフにして、<Tab>キーを押すと自動ツール選択を無効にして、<Shift-Tab>キーを押すと自動ツール選択を切り替えるように、LabVIEWを構成します。
    • 起動時にスタートアップウィンドウをスキップ—LabVIEWを起動すると、スタートアップウィンドウの代わりに新規ブランクVIを開きます。 このチェックボックスは、デフォルトでオフになっています。
    • スタートアップウィンドウのni.comアップデートを無効ni.com/jpウェブサイトの最新記事の自動チェックを無効にできます。 スタートアップウィンドウがこの情報を更新するためにインターネットにアクセスしないようにするためには、これらのアップデートを無効にします。 アップデートを無効にすると、スタートアップウィンドウには最後にアップデートした時のni.comの情報が表示されます。
    • コンパイルコードを新規ファイルから分離する—すべての新規VI、カスタム制御器、グローバル変数、LabVIEWクラス、プロジェクトライブラリ、XControl、ステートチャートライブラリにおいて、ソースファイルからコンパイルコードを分離して保存するように指定します。
    • 最大取り消し回数取り消しできるステップの最大数を設定します。 デフォルト値は99ステップです。 入力可能な最大数値は99です。 入力可能な最小数値は1です。
    • 最近のプロジェクトテンプレートリスト中の最大エントリ—LabVIEWスタートアップウィンドウのプロジェクトを作成するボタンの下に表示する項目の最大数を設定します。
    • 最近使ったファイルリストの最大エントリ数—LabVIEWスタートアップウィンドウの既存のファイルを開くボタンの下に表示するプロジェクトとファイルの最大数を設定します。 このオプションにより、ファイル→最近使ったファイルまたはファイル→最近使ったプロジェクトを選択したときに表示される最大ファイル数も設定されます。
    • パスワードキャッシュ消去—LabVIEWのパスワードキャッシュを消去します。 VIがパスワードで保護されている場合、ブロックダイアグラムにアクセスすると、LabVIEWによってパスワードがキャッシュされます。このため、同じセッションでパスワードを再入力する必要はありません。 パスワードキャッシュをクリアすると、次回パスワード保護されているブロックダイアグラムにアクセスするにはパスワードを再入力する必要があります。 パスワードキャッシュをクリアすると、LabVIEWは開いているパスワード保護されたVIのブロックダイアグラムをすべて閉じます。
  • ヒントラベルとラベル—このセクションを使用して、環境のヒントラベルおよびラベルを構成します。
    • ヒントラベルを表示—ヒントラベルを表示します。 このチェックボックスは、デフォルトでオンになっています。
    • 作成した定数にラベルを表示—端子から定数を作成した場合にその端子名を定数のラベルとして表示します。 このチェックボックスは、デフォルトでオフになっています。
  • VIの保存—このセクションを使用して、LabVIEWがVIを保存する方法を設定します。
    • 読み取り専用のVIをロック—このオプションは、主にソース管理に使用されるものであり、読み取り専用のVIの編集を制限します。 このチェックボックスをオフにすると、読み取り専用VIの編集が可能となりますが、保存できません。 このチェックボックスをオンにすると、読み取り専用VIはロックされた状態で開かれるので編集はできません。
      • 自動変更を保存しない—読み取り専用VIでLabVIEWで自動的に実装された変更を保存するように促すプロンプトは表示されません。 これらの変更はVIがロードされるたびに実装されるため、保存する必要はありません。 LabVIEWによって自動的に行われる変更には、再コンパイル、旧バージョンからの変換、タイプ定義やフォントの更新などがあります。 このチェックボックスは、デフォルトでオフになっています。 自動変更を保存しないを選択するには、まず読み取り専用のVIをロックチェックボックスをオンにします。
    • 回復用に自動保存を有効—指定された区間で開かれているファイルを自動的に保存します。 異常なシャットダウンまたはシステム障害が発生すると、次回LabVIEWを起動する際、回復するファイルを選択ウィンドウで回復可能なファイルが表示されます。
      • VIを実行前に保存—VIを実行する前に開いているファイルをバックアップします。
      • VIを実行前および周期的に保存—VIを実行する前に、開いているファイルをフィールドで指定した間隔でバックアップします。
        • —LabVIEWが開いているファイルをバックアップする頻度を指定します。 VIを実行前および周期的に保存を選択して、このフィールドを有効にする必要があります。
  • フォント—このセクションでは、3つのカテゴリの定義済みフォント(アプリケーションフォント、ダイアログフォント、システムフォント)を構成します。 テキストボックスの上にあるプルダウンメニューから構成するカテゴリを選択します。
    • フォント選択—構成する定義済みのフォントタイプを選択します。
      • アプリケーションフォント制御器関数パレット、詳細ヘルプ、ヒントラベルに使用されるデフォルトのフォントを決定します。
      • ダイアログフォント—ダイアログボックスとシステム制御器のテキストに使用されるデフォルトフォントを決定します。
      • システムフォント—メニューバーとショートカットメニューのテキストに使用されるデフォルトフォントを決定します。
    • デフォルトフォントを使用—定義済みフォントに対してLabVIEWのデフォルト設定を選択します。 フォントスタイルダイアログボックスで定義されているフォントの属性を使用します。 このオプションはデフォルトで選択されています。
    • フォントスタイル—フォントの属性を変更するためのフォントスタイルダイアログボックスを表示します。
    • フォント例—選択したフォントのプレビューを表示します。
  • —このセクションを使用して、色のオプションを設定します。
    • デフォルトの色を使用—このダイアログボックスのリストに表示されたすべての項目に対してデフォルトの色を使用します。 このチェックボックスは、デフォルトでオンになっています。 チェックボックスをオフにすると、各四角形をクリックして色を変更できます。
      • フロントパネル—新規VIのフロントパネルの色を選択します。ただし既存のVIには影響しません。
      • ブロックダイアグラム—新規VIのブロックダイアグラムの色を選択します。ただし既存のVIには影響しません。
      • 強制ドット—数値データが強制的に変換されていることを示すドットの色を選択します。 このオプションは、LabVIEW VIの表示方法にのみ影響します。 VIそのものには適用されません。
      • スクロールバー—スクロールバーのカラーを選択します。 このオプションは、LabVIEW VIの表示方法にのみ影響します。 VIそのものには適用されません。
      • 点滅の前景色—点滅するオブジェクトの前景色を選択します。 このオプションは、点滅オブジェクトがその点滅状態にある場合にのみ作用します。 点滅は、プロパティノードで有効にする基本プロパティです。
      • 点滅の背景色—点滅するオブジェクトの背景色を選択します。 このオプションは、点滅オブジェクトがその点滅状態にある場合にのみ作用します。 点滅は、プロパティノードで有効にする基本プロパティです。
      • メニューテキスト(WindowsおよびLinux) メニューのテキストの色を選択します。
      • メニューの背景(WindowsおよびLinux) メニューの背景の色を選択します。
    • カスタムカラーユーザカラーダイアログボックスのカラーパレットからユーザ定義の色を表示します。
  • デバッグ—このセクションを使用して、デバッグオプションを設定します。
    • デフォルトで警告をエラーリストダイアログに表示エラーリストウィンドウにエラーの他に警告を表示します。 警告は、VIが正常でないことを意味しているとは限りません。 ブロックダイアグラム上のあり得るエラーを示すか、検討する操作を推奨します。 このチェックボックスは、デフォルトでオンになっています。
  • NIエラーレポート(Windows) このセクションでは、「NIエラーレポート」ダイアログボックスのオプションを設定します。
    メモ NIエラーレポートが無効にされている場合は、このセクションは設定できません。
    • 終了時に内部警告を通知しない—内部警告レポートダイアログボックスを無効にして、プロジェクトの最後の実行時に1つまたは複数の警告が検出されても表示されないようにします。
      • 内部警告を自動的にナショナルインスツルメンツに送信—警告が1つまたは複数発生した場合に、内部警告レポートを自動的にナショナルインスツルメンツに送信します。 このオプションは、終了時に内部警告を表示しないチェックボックスが選択されている場合にのみ使用できます。
    • クラッシュ時にLabVIEWを再起動クラッシュレポートダイアログボックスを閉じた後にLabVIEWを再起動します。 前回LabVIEWを起動した方法(.EXEのダブルクリックしたか、コマンドライン引数を渡したかなど)で起動されます。
      メモ コマンドライン引数の長さが255文字を超える場合には、LabVIEWを再起動できません。


      LabVIEWで内部エラーが発生したときにLabVIEWを再起動したくない場合は、このチェックボックスをオフにします。
    • 送信終了時に送信者に報告ダイアログを閉じる—エラーレポートの送信が完了した時にレポート送信ダイアログボックスを閉じます。 送信中にエラーが発生した場合は、レポート送信ダイアログボックスは自動的に閉じられません。
  • 内部警告およびエラー—このセクションでは、内部警告および内部エラーダイアログボックスのオプションを設定します。
    メモ (Windows) NIエラーレポートが無効にされている場合、このセクションは設定できます。
    • 開始時に内部警告およびエラーを調査するようにプロンプト(macOSおよびLinux) panel.cpp, line 2978などの内部LabVIEWエラーが発生した後LabVIEWを起動すると、前回の内部エラーもしくは警告を調査ウィンドウを表示します。 このチェックボックスは、デフォルトでオンになっています。 内部LabVIEWエラーが発生した後、LabVIEWを再度起動した際、前回の内部エラーもしくは警告を調査ウィンドウが表示されないようにするには、このチェックボックスをオフにします。
  • コンパイラ—このセクションでは、LabVIEWコンパイラによるエディタ応答速度と実行速度のバランス調整を構成します。
    • コンパイラ最適化—エディタの応答性を向上させるためにコンパイラ最適化の制限を開始するVIの複雑度を示します。 VIの複雑度がこのスライダで示されるしきい値よりも低い場合は、コンパイラは完全な最適化を行うので、VIの実行速度が向上します。 VIの複雑度がしきい値より高い場合は、VIに対するエディタの応答性を向上させるためにコンパイラの最適化が制限されます。

      各VIの複雑度は、VIプロパティダイアログボックスのメモリ使用ページのコンパイルコードの複雑度の値で確認できます。 この複雑度の値と最適化スライダによって、エディタの応答性とVIの実行速度のどちらを優先するかを決定できます。

      このスライダを設定する際は、以下の注意事項を考慮してください。
      • コンパイラ最適化スライダの値は、すべてのVIコンパイル時に適用されます。 つまり、各VIにコンパイラ最適化を適用するかどうかは、このスライダで指定されたしきい値を基準に決定されます。
      • PowerPCまたはARMアーキテクチャ上で稼動するターゲット(それぞれVxWorksとNI Linux Real-Timeターゲット)用にアプリケーションをビルドするときは、コンパイラは、コンパイラ最適化スライダで指定されたしきい値を無視します。
      • このスライダの値を変更しても、すべてのVIが自動的に再コンパイルされるわけではありません。
      • コンパイラ最適化スライダの値は、複雑なVIを編集またはコンパイルする場合以外は、5に設定することが推奨されます。 しきい値を5に設定すると、ほとんどのVIに対してエディタの応答性と実行速度が適切に調節されます。
  • Linux(Linux)このセクションを使用してLinux固有の環境オプションを設定します。
    • ネイティブの外観を使用—Linuxでサポートするユーザインタフェースのスタイルを選択します。 デフォルトはautoです。
    • メニュー/メタキーとしてコントロールを使用—メニューショートカットアクセラレータに<Ctrl>キーを使用できます。 このチェックボックスはデフォルトでオンになっています。
    • ピクセルベースのフォントサイズを使用—ロードするフォントがポイントサイズではなくピクセルサイズで選択されます。 このチェックボックスはデフォルトでオンになっています。 このチェックボックスにチェックマークを付けると、大型ディスプレイ(100 dpi)ではテキストが小さく表示されますが、結果的には高品質のクロスプラットフォームVIとなります。
    • フォーカス変更でフローティングウィンドウを表示/非表示—別のアプリケーションウィンドウがフォーカスされた時に、LabVIEWのパレットを表示または非表示にし、すべてのフローティングウィンドウを非表示にします。 このチェックボックスはデフォルトでオンになっています。
      メモ このオプションは、フォーカスするウィンドウをクリックする必要がある場合にのみ有効です。 ウィンドウマネージャのフォーカスポリシーがマウスに従うよう構成されている場合は、このチェックボックスをオフにしてください。
    • フローティングウィンドウを常に手前に表示制御器パレット、関数パレット、詳細ヘルプウィンドウなどのフローティングウィンドウを他のウィンドウの上に表示できます。 ウィンドウマネージャがこの特性をサポートしないと、このオプションの影響は全くなくなります。 GNOMEおよびKDEの一部のバージョンでは、フローティングウィンドウがサポートされています。 このチェックボックスはデフォルトでオンになっています。


この記事は役に立ちましたか。

役に立たなかった