ブロックダイアグラムを自動的にクリーンアップする



LabVIEW 2018ヘルプ


発行年月: 2018年3月
製品番号: 371361R-0112
製品情報を参照

ダウンロード (Windowsのみ)


LabVIEW 2016ヘルプ
LabVIEW 2017ヘルプ
LabVIEW 2018ヘルプ
LabVIEW 2019ヘルプ
LabVIEW 2020ヘルプ

ブロックダイアグラムのすべての既存のワイヤの経路を修正したり、オブジェクトを並べ替えることができます。

ブロックダイアグラムのすべての既存のワイヤの経路を修正し、オブジェクトを並べ替えるには、以下の手順に従ってください。

  1. クリーンアップオプションを設定します。ツール→オプションを選択してオプションダイアログボックスを表示し、カテゴリリストでブロックダイアグラムを選択します。ブロックダイアグラムページで、ブロックダイアグラムの左側に制御器、右側に表示器を自動的に移動したり、ブロックダイアグラムのオブジェクトとワイヤの間のピクセル数を指定したり、ブロックダイアグラムのレイアウトの自動縮小を指定することができます。
  2. (オプション)ストラクチャの内部を変更することなくストラクチャを移動するには、ストラクチャを右クリックしてダイアグラムクリーンアップの対象から排除を選択します。
  3. 編集→ダイアグラムをクリーンアップを選択します。ブロックダイアグラムツールバーのダイアグラムをクリーンアップボタンをクリックするか、<Ctrl–U>キーを押して、ブロックダイアグラムをクリーンアップすることもできます。(macOS) <Command-U>キーを押します。(Linux) <Alt-U>キーを押します。
メモ メモ  ワイヤや個々のノードなど、特定のオブジェクトを選択してクリーンアップすることもできます。複数のオブジェクトを選択するには、<Shift>キーを押しながらクリックします。クリーンアップするオブジェクトを選択すると、ダイアグラムをクリーンアップボタンが部分的にダイアグラムをクリーンアップという表示に変わります。この場合、ブロックダイアグラムの選択したオブジェクトだけがクリーンアップされます。特定のワイヤを選択してクリーンアップすると、ワイヤの位置だけが修正され、ワイヤに接続されているオブジェクトの位置は修正されません。

ブロックダイアグラムの特定のワイヤの経路を修正したり、特定のオブジェクトだけを並べ替えることもできます。

ブロックダイアグラムの特定のワイヤの経路を修正したり、特定のオブジェクトだけを並べ替えるには、以下の手順に従ってください。

  1. (オプション)ストラクチャの内部を変更することなくストラクチャを移動するには、ストラクチャを右クリックしてダイアグラムクリーンアップの対象から排除を選択します。
  2. クリーンアップする項目を、周囲をクリックしてからドラッグして四角形で囲むように選択します。
メモ メモ  ストラクチャを1つも選択せず、選択されたオブジェクトが1つも重複していない場合、また対応する入力と出力がないワイヤだけを選択した場合、ブロックダイアグラムはクリーンアップされません。
  1. (オプション)複数のオブジェクトを同時に選択するには、<Shift>キーを押しながらドラッグして追加するオブジェクトを選択します。一旦選択したオブジェクトを選択解除するには、<Shift>キーを押しながらオブジェクトをクリックします。
  2. 編集→セレクションをクリーンアップを選択します。


この記事は役に立ちましたか。

役に立たなかった