アプリケーションメソッド



LabVIEW 2018ヘルプ


発行年月: 2018年3月
製品番号: 371361R-0112
製品情報を参照

ダウンロード (Windowsのみ)


LabVIEW 2015ヘルプ
LabVIEW 2016ヘルプ
LabVIEW 2017ヘルプ
LabVIEW 2018ヘルプ
LabVIEW 2019ヘルプ

インストールパッケージ: ベース開発システム

クラス階層を参照してください。

メソッド説明
DataSocketを参照DataSocketブラウザダイアログボックスを起動して、DataSocket項目への接続を確立します。 詳細
LabVIEWクラス:LVクラスのすべてのメソッドクラスのすべてのメソッド名の配列とメソッドパスの配列を返します。クラスのメソッドは、サブVIとして呼び出せるメンバVIです。言い換えれば、グローバル変数、制御器、多態性VIは出力配列から除外されます。 詳細
LabVIEWクラス:開くパスで指定されたLabVIEWクラスを開きます。 詳細
LabVIEWクラス:作成新規のLabVIEWクラスを作成します。 詳細
LabVIEWクラス:実装VIパスを取得指定されたクラス内の指定されたメソッドを実装するVIのパスを返します。指定されたクラスがそのメソッドを実装しない場合、このメソッドは先祖VI実装を返します。 詳細
LVRT:スレーブから切断LabVIEWとRTターゲット間で開いている接続を解除します。 詳細
NIセキュリティ:アクセス権を取得アクセス管理リストをログインされた現在のアプリケーションユーザで認証します。 詳細
NIセキュリティ:ログアウト現在のユーザをNIドメインからログアウトして、デフォルトユーザに戻します。 詳細
NIセキュリティ:ログインユーザをNIドメインでログイン状態にします。 詳細
NIセキュリティ:ログインダイアログを呼び出すNIセキュリティログインダイアログボックスをプログラム的に呼び出します。 詳細
VIを取得:アイコン指定されたVIのアイコンを、VIをメモリにロードせずに返します。 詳細
VIを取得:エディタバージョンVIを最後に保存したLabVIEWのバージョンを返します。VIを最後に保存したLabVIEWのバージョンは、VIのファイル形式バージョンと異なる場合があります。たとえば、LabVIEW 9.0.1を使用してVIを保存した場合、VIのファイル形式はバージョン9.0になります。 VIのファイル形式バージョンを取得するには、VIを取得:バージョンメソッドを使用します。 バージョン情報の抽出中、LabVIEWはこのVIを開きません。VIでないファイルへのパスを指定すると、LabVIEWはエラー6559を返します。 詳細
VIを取得:コネクタペーンデータタイプVIをロードせずに、コネクタペーンのデータタイプをバリアントデータとして返します。 詳細
VIを取得:タイトル 指定されたVIのタイトルバーに表示される名前を返します。このメソッドはVIをメモリにロードしません。 詳細
VIを取得:バージョンVIのLabVIEWファイル形式バージョンを返します。VIのファイル形式バージョンは、VIが最後に保存されたLabVIEWのバージョンと異なる場合があります。たとえば、LabVIEW 9.0.1を使用してVIを保存した場合、VIのファイル形式はバージョン9.0になります。 VIが最後に保存されたLabVIEWのバージョンを取得するには、VIを取得:エディタバージョンメソッドを使用します。 バージョン情報の抽出中、LabVIEWはこのVIを開きません。VIでないファイルへのパスを指定すると、LabVIEWはエラー6559を返します。 詳細
VIを取得:ブックマークVIパスで指定したVIのブックマーク情報を返します。ブックマーク情報を読み取るために、VIをメモリにロードする必要はありません。このメソッドは、VIがパスワード保護されているか、以前のバージョンのLabVIEWで保存されており、メモリにロードされていないか、またはVIにブロックダイアグラムがない場合、エラーを返します。 詳細
VIを取得:プローブ指定されたVIプローブであるかどうかを、そのVIをロードせずに返します。 詳細
VIを取得:ヘルプ情報指定されたVIのVIプロパティダイアログボックスのドキュメントページからヘルプパスヘルプタグ使用するヘルプヘルプURLを返します。このメソッドはVIをメモリにロードしません。 詳細
VIを取得:リビジョン履歴指定されたVIのVIプロパティダイアログボックスの一般ページでリビジョン履歴ボタンをクリックしたときに表示されるリビジョン履歴を返します。このメソッドはVIをメモリにロードしません。 詳細
VIを取得:修飾名参照されているVIの修飾名を、そのVIをロードせずに返します。 詳細
VIを取得:説明指定されたVIのVIプロパティダイアログボックスのドキュメントページのVIの説明フィールドに保管されている説明を返します。このメソッドは、VIの説明プロパティとは異なり、VIをメモリにロードしません。 詳細
VI階層画像(スケール済み)VI階層のスケールされた画像を取得します。 詳細
VI文字列:インポートVI配列で指定されたVIのユーザインタフェースに関連する文字列をタグ付きのテキストファイルにインポートします。 詳細
VI文字列:エクスポートVI配列で指定されたVIのユーザインタフェースに関連する文字列をタグ付きのテキストファイルにエクスポートします。 詳細
XControl:開くXControlライブラリを開いて、そのライブラリへのリファレンスを返します。 詳細
XControl:作成XControlライブラリを作成します。 詳細
アクティブなVIリファレンスを取得現在、ウィンドウがアクティブな(フォーカスが当たっている)VIのリファレンスを返します。アクティブなウィンドウがVIでない場合、このメソッドは非Refnumを返します。 詳細
アプリケーションビルダキャッシュをクリアビルド仕様でコンパイルされるオブジェクトキャッシュからすべてのVIオブジェクトを削除します。 詳細
ウェブサーバ:構成指定されたファイルでLabVIEWウェブサーバを構成します。ウェブサーバは、構成ファイルに配線しないとデフォルトの構成ファイルを使用します。 詳細
クラスオペレータ:すべてを削除すべてのクラスに関連付けられたすべてのオペレータVを削除します。 詳細
クラスオペレータ:削除指定されたクラスと関連付けられたオペレータVIを削除します。オペレータVIが見つからない場合はFALSEを返します。 詳細
クラスオペレータ:取得指定されたクラスと関連付けられたオペレータVIを取得します。オペレータVIが見つからない場合はFALSEを返します。 詳細
クラスオペレータ:設定指定したクラスにオペレータVIを設定します。失敗するとFALSEを返します。 詳細
クリップボード:クリップボードから読み取るシステムのクリップボードからテキストを読み取ります。 詳細
クリップボード:クリップボードに書き込むシステムのクリップボードにテキストを書き込みます。 詳細
クリップボード:画像を取得現在、クリップボードに保管されている画像を返します。LabVIEWランタイムエンジンでは、クリップボード:画像を取得メソッドはサポートされていません。ビルドアプリケーションにこのメソッドを含めた場合、メソッドは正しく動作しません。 詳細
クリップボード:空クリップボードをクリアします。 詳細
コンパイルオブジェクトキャッシュをクリアユーザオブジェクトキャッシュ内のコンパイルコードをすべて削除します。 詳細
シーン:シーンファイル書き込み 3Dシーンファイルを作成します。ファイル名の末尾には、拡張子.lvsgまたは.daeを付ける必要があります。 詳細
シーン:シーンファイル読み取りシーン:シーンファイル書き込みメソッドで作成する3Dシーンファイルを読み取ります。読み取りされているファイルに拡張子.lvsgまたは.daeが付けられます。 詳細
シーン:新規ウィンドウLabVIEWが3Dシーンを生成する新規ウィンドウを生成します。 詳細
シーン:新規オブジェクト3Dシーンで新規オブジェクトを作成します。 詳細
シーン:新規クリップ面3Dシーンで新規クリップ面を作成します。 詳細
シーン:新規テクスチャテクスチャへのリファレンスを取得して、3Dシーンでジオメトリを適用します。 詳細
シーン:新規の光3Dシーンで新規光を作成します。 詳細
シーン:描画領域:ジオメトリ:新規の円錐3Dシーンでオブジェクトを円錐に設定するのに使用可能なジオメトリを作成します。 詳細
シーン:描画領域:ジオメトリ:新規の円柱3Dシーンでオブジェクトを円柱に設定するのに使用可能なジオメトリを作成します。 詳細
シーン:描画領域:ジオメトリ:新規の球3Dシーンでオブジェクトを球に設定するのに使用可能なジオメトリを作成します。 詳細
シーン:描画領域:ジオメトリ:新規ハイトフィールド3Dシーンで新規ハイトフィールドを作成します。 詳細
シーン:描画領域:ジオメトリ:新規ボックス3Dシーンでオブジェクトをボックスに設定するのに使用可能なジオメトリを作成します。 詳細
シーン:描画領域:ジオメトリ:新規メッシュ3Dシーンで新規メッシュを作成します。 詳細
シーン:描画領域:新規テキスト3Dシーンで新規テキストオブジェクトを作成します。 詳細
ステートチャート:開くパスで指定されたステートチャートを開きます。 詳細
ステートチャート:作成新しいステートチャートを作成します。作成されたステートチャートはディスクに保存する必要があります。 詳細
データタイプの色データタイプに関連する色を返します。 詳細
デバッグ接続:アプリケーションまたは共有ライブラリをリストサーバアドレスで指定されたコンピュータ上でデバッグ可能なアプリケーションまたは共有ライブラリのリストを返します。 詳細
デバッグ接続:デバッグ接続を開くデバッグ可能なアプリケーションまたは共有ライブラリへの接続を開きます。 詳細
デバッグ接続:デバッグ接続を閉じるデバッグ名で指定されたアプリケーションまたは共有ライブラリへの接続を閉じます。 詳細
パレット:すべてのパレットを閉じる制御器および関数パレットのセットをプログラム的に閉じます。パレットセットを閉じるには、パレット:すべてのパレットを閉じるメソッドをブロックダイアグラムに追加し、VIを実行します。 詳細
パレット:パレット項目パスを取得指定するパレット項目へのパスを返します。 詳細
パレット:更新制御器パレットと関数パレットのセットをプログラム的に更新します。 パレットセットを更新するには、ブロックダイアグラムで「パレットを書き込む」VIの右側にパレットをパレット:更新メソッドを配置します。 このメソッドは、制御器および関数パレットを編集ダイアログボックスの変更を保存ボタンと同じ動作をします。 詳細
プロジェクト:ファイルLabVIEWバージョンを取得プロジェクトのLabVIEWファイル形式バージョンを返します。このバージョンはプロジェクトが最後に保存されたLabVIEWのバージョンとは異なる場合があります。 詳細
プロジェクト:開くディスクからLabVIEWプロジェクトをロードします。プロジェクトが既にメモリに存在する場合は、このメソッドはそのプロジェクトへのリファレンスを返します。このリファレンスはプロジェクトプロパティと使用できます。 また、ファイル→プロジェクトを開くを選択して、プロジェクトに移動し、プロジェクトを開くことができます。 詳細
プロジェクト:新規新規で空のLabVIEWプロジェクトを作成します。また、プロジェクトエクスプローラウィンドウを使用して、新規プロジェクトを作成することもできます。 詳細
プロジェクト:新規作成してプロンプト新しい空のLabVIEWプロジェクトを作成して、メインアプリケーションインスタンスから開いているVIを追加するかどうかを尋ねるメッセージを表示します。 詳細
メニュー: 更新ディスクからファイル、ツール、ヘルプメニューをプログラム的に更新します。 詳細
ユーザによる操作:カーソルにオブジェクトを配置カーソルにオブジェクトを配置して、オブジェクトをフロントパネルウィンドウまたはブロックダイアグラムウィンドウに追加できるように準備します。スタイルまたはパスのいずれかを使用してオブジェクトを指定できます。 詳細
ユーザによる操作:カーソルにパレットオブジェクトを配置カーソルにパレットオブジェクトを配置して、オブジェクトをフロントパネルウィンドウまたはブロックダイアグラムウィンドウに追加できるように準備します。 詳細
ユーザによる操作:パレットオブジェクト詳細ヘルプを表示パレットのメニュー項目の上にマウスカーソルを置いたときと同様に、指定したパレットオブジェクトのコンテンツを表示するように詳細ヘルプウィンドウを更新します。 詳細
ユーザによる操作:パレットメニュー項目をハイライト制御器または関数パレットを開き、指定した制御器または関数をハイライトします。 詳細
ユーザによる操作:メニュー項目をインボークユーザによるメニュー項目の選択をシミュレーションします。このメソッドは一般的にグローバルメニュー項目に対してのみ動作します。ドキュメント固有のメニュー項目に対しては動作せず、警告なしにそのまま終了します。 詳細
ライブラリ:ファイルLabVIEWバージョンを取得ライブラリのLabVIEWファイル形式バージョンを返します。ライブラリのファイル形式バージョンは、ライブラリが最後に保存されたLabVIEWのバージョンと異なる場合があります。たとえば、LabVIEW 9.0.1を使用してライブラリを保存した場合、ライブラリのファイル形式はバージョン9.0になります。 詳細
ライブラリ:ライブラリをデプロイ(単一)指定されたコンピュータへ単一のライブラリファイルをデプロイします。 詳細
ライブラリ:ライブラリをデプロイ(複数)指定されたコンピュータへ複数のライブラリファイルをデプロイします。 詳細
ライブラリ:ライブラリをデプロイ解除ターゲットからライブラリを削除します。 詳細
ライブラリ:ライブラリをデプロイ解除ターゲットからライブラリを削除します。 詳細
ライブラリ:開くパスで指定されたLabVIEWプロジェクトライブラリを開きます。 詳細
ライブラリ:作成新規のLabVIEWプロジェクトライブラリを作成します。 詳細
ライブラリ:修飾名でリファレンスを取得アプリケーションインスタンス内にすでにロードされたLabVIEWプロジェクトライブラリへのリファレンスを取得します。ライブラリがメモリにない場合、LabVIEWは非refnumを返します。 詳細
リモートパネル:クライアント制御を要求サーバコンピュータ上のVIのフロントパネルの制御を要求します。 詳細
リモートパネル:クライアント制御解除リモートフロントパネルの制御をサーバに返します。サーバはキュー内の次のクライアントに制御を許可するか、キューに要求がない場合は制御を再度取り戻します。 詳細
リモートパネル:サーバ接続を開くサーバに接続を開き、サーバコンピュータ上のVIのフロントパネルを表示します。また、フロントパネルの制御を要求できます。 詳細
リモートパネル:サーバ接続を閉じるサーバコンピュータのVIへの接続を閉じます。 詳細
一括コンパイル指定されたアプリケーションインスタンスに対してディレクトリにあるVI(サブディレクトリのVIを含む)をロードおよびコンパイルします。 詳細
開く:LabVIEWドキュメントLabVIEWドキュメントを開きます。 詳細
開く:最後に開かれたファイル最近使用されたファイルのリストから目次で指定されたファイルを開きます。 詳細
開く:最後に開かれたプロジェクト最近使用されたプロジェクトのリストから目次で指定されたプロジェクトを開きます。 詳細
環境モード表示名を取得指定する環境モードの表示名を返します。 詳細
再起動LabVIEWを終了して再起動します。このメソッドは、Windowsでのみサポートされます。 詳細
最後に開かれた:LVファイルLabVIEWから最近使用されたファイルのリストを取得して、パスとファイル名を表示します。このメソッドはファイル→最近使ったファイルを選択した場合と同じリストを返します。 詳細
最後に開かれた:LVプロジェクトLabVIEWから最近使用されたLabVIEWプロジェクトのリストを取得して、パスとプロジェクト名を表示します。このメソッドはファイル→最近使ったプロジェクトを選択した場合と同じリストを返します。 詳細
新規LabVIEWドキュメント新規LabVIEWドキュメントを作成します。このメソッドは、新規ドキュメントを新規ダイアログボックスで作成する際と同じ結果を提供します。 詳細
接続応答性:確認VIサーバ接続が応答するかどうかをチェックします。 詳細
接続応答性:情報VIサーバ接続が応答するかどうかをLabVIEWがチェックする頻度を取得および設定します。 詳細
前面へ移動WindowsおよびMac OS Xで、アプリケーションのウィンドウを前面に表示します。 詳細


この記事は役に立ちましたか。

役に立たなかった