회사 이벤트 아카데믹 커뮤니티 기술 지원 솔루션 제품 및 서비스 문의 MyNI

LabVIEW 설치 문제 해결 가이드

LabVIEW 2013 도움말

개정 날짜: June 2013

파트 번호: 371361K-0129

제품 정보 보기

모든 플랫폼

Windows

OS X

Linux

추가적인 도움


NI LabVIEW 어플리케이션 빌더 설치하기(모든 플랫폼)

어플리케이션 빌더 설치 방법은 LabVIEW 패키지에 따라 다릅니다.

  • LabVIEW Professional Development System―LabVIEW Professional Development System에는 어플리케이션 빌더가 포함되어 있으며, 자동으로 설치됩니다. 그러므로 어플리케이션 빌더를 별도로 설치하지 않습니다. (Windows) 설치 과정에서 LabVIEW 시리얼 번호를 사용하여 어플리케이션 빌더가 정품인증됩니다.
  • LabVIEW Full Development System 또는 Base Development System―어플리케이션 빌더를 구입한 경우, 별도의 패키지로 배송됩니다.
    • (Windows) LabVIEW 플랫폼 DVD 1을 사용하여 LabVIEW를 설치합니다. 설치 과정에서 어플리케이션 빌더의 시리얼 번호를 입력해야 합니다. 이 시리얼 번호는 LabVIEW 애드온 소프트웨어 패키지의 소유권 인증서에서 찾을 수 있습니다. 설치 과정에서 어플리케이션 빌더를 정품인증하지 않는 경우, 평가판 모드로 실행됩니다. 또한 LabVIEW를 설치한 후 시작할 때 나타나는 라이센스 상태 페이지에서 어플리케이션 빌더를 정품인증할 수 있습니다.
    • (OS X 및 Linux) LabVIEW의 설치를 완료한 후, 어플리케이션 빌더의 설치 미디어를 삽입합니다.

LabVIEW 이전 버전이 이미 설치되어 있는 컴퓨터에 LabVIEW 2013 설치하기(모든 플랫폼)

각 LabVIEW 버전은 별도의 디렉토리에 저장되기 때문에, LabVIEW 2013을 설치해도 컴퓨터에 이미 설치되어 있는 LabVIEW의 이전 버전을 덮어쓰지 않습니다. LabVIEW 이전 버전의 user.lib 디렉토리에서 파일을 사용하려면, 이 파일을 LabVIEW 2013의 user.lib 디렉토리에 복사합니다.

LabVIEW 이전 버전으로부터 VI 및 프로젝트를 업그레이드할 때의 권장사항은 LabVIEW 업그레이드 노트를 참조하십시오.

찾을 수 없는 모듈 또는 툴킷 기능 검색하기(모든 플랫폼)

모듈 또는 툴킷을 LabVIEW 2013과 함께 사용하려면, LabVIEW 2013과 호환되는 버전의 모듈 또는 툴킷을 설치해야 합니다. 그렇지 않으면, 모듈 또는 툴킷과 관련된 VI, 프로젝트 아이템, 대화 상자 및 다른 기능이 LabVIEW에서 나타나지 않습니다.

다음 단계를 완료하여 모듈 및 툴킷을 찾습니다:

(Windows)

  1. 모듈 또는 툴킷을 찾아 설치합니다.
    • LabVIEW 플랫폼 DVD에 포함되는 모듈 및 툴킷—LabVIEW 플랫폼 DVD 1을 삽입하고 모듈 또는 툴킷의 시리얼 번호를 입력합니다. 모듈 또는 툴킷이 LabVIEW 플랫폼 DVD에 포함되어 있는지 알려면 LabVIEW 플랫폼 Readme를 참조하십시오.
    • 다른 LabVIEW 모듈 및 툴킷플랫폼에 포함되지 않은 애드온의 설치 설명을 따릅니다.
    • 타사 애드온—LabVIEW의 시작하기 윈도우에서 드라이버 및 애드온 찾기≫LabVIEW 애드온 찾기를 선택하여 최신 버전의 타사 애드온을 찾을 수 있습니다.
  2. 디바이스 드라이버를 수정합니다. 디바이스 드라이버를 설치한 후 LabVIEW 또는 애드온을 설치하는 경우, LabVIEW는 디바이스 드라이버를 인식하지 못합니다.

(OS X와 Linux)

LabVIEW 2013과 호환되는 버전의 모듈 또는 툴킷을 설치합니다. 다음 위치에서 모듈 또는 툴킷의 호환되는 버전을 구할 수 있습니다:

  • 모든 NI 애드온ni.com/downloads에서 최신 버전의 애드온을 다운로드합니다.
  • 타사 애드온ni.comLabVIEW Tools Network에서 최신 버전의 애드온을 다운로드합니다.

설치 설명서는 모듈 또는 툴킷의 설치 미디어에 있는 readme 파일을 참조하십시오.

LabVIEW 새 버전에서 변경된 VI 동작 문제 해결하기(모든 플랫폼)

LabVIEW 이전 버전에서 생성된 VI가 LabVIEW 2013에서 다르게 동작하는 경우, VI에서 이 문제를 발생하는 부분을 찾으려면 LabVIEW 업그레이드 노트업그레이드와 호환성 문제 섹션을 참조하십시오. 이 VI가 생성된 버전보다 이후 버전의 LabVIEW에서 이 섹션을 검토하십시오.

LabVIEW 2013이 LabVIEW 이전 버전의 VI를 열 수 없는 이유 알아내기(모든 플랫폼)

LabVIEW 5.1 또는 이전 버전으로부터 VI를 업그레이드하는 경우, LabVIEW 2013에서 이 VI를 열 수 없습니다. 이러한 버전의 LabVIEW에서 생성된 VI를 업그레이드하는 경우에는 먼저 VI를 중간 버전의 LabVIEW로 업그레이드하거나, LabVIEW Conversion Kit를 사용하십시오. 특정 LabVIEW Legacy 버전에서 업그레이드하기에 대한 더 자세한 정보는 ni.com에서 NI Developer Zone을 참조하십시오.

LabVIEW 제거하기(모든 플랫폼)

지속적인 설치 문제를 해결하려면, LabVIEW 및 다른 NI 소프트웨어를 제거하고 컴퓨터에 아무 것도 설치되지 않은 상태에서 다시 설치해보십시오.

(Windows)

  1. LabVIEW를 설치할 때 같이 설치되는 하드웨어 설정 프로그램인 Measurement & Automation Explorer (MAX)에서 시스템 설정 리포트를 생성합니다. 시스템 설정 리포트에는 NI 소프트웨어 설치에 대한 모든 정보를 지우기 전의 시스템 상태를 기록합니다. ni.com/ask에서 서비스 요청을 신청하는 경우, 문제 해결을 위해 NI 엔지니어는 이 정보를 필요로할 수도 있습니다.
    1. MAX를 엽니다.
    2. 파일≫반입을 선택하고 시스템 전체에 대한 리포트를 생성합니다.
    3. MAX 시스템 설정 리포트 생성에 대한 더 자세한 설명은 ni.com에서 기술지원 데이터베이스를 참조하십시오.
  2. 시스템 설정 리포트 및 모든 VI를 USB 또는 네트워크 드라이브와 같은 외부 위치에 저장합니다.
  3. 컴퓨터의 전원을 끄고, 모든 NI 하드웨어를 제거하거나 연결을 끊으십시오.
  4. 제어판의 프로그램 및 기능에서 National Instruments 소프트웨어를 선택하여 LabVIEW 2013을 제거합니다. LabVIEW, 모듈, 툴킷 및 디바이스 드라이버를 선택하고, 제거합니다.
  5. 컴퓨터를 다시 시작하십시오.

(OS X)

  1. LabVIEW 2013 디렉토리에서 수정하거나 새로 추가한 모든 파일을 다른 위치에 저장합니다.
  2. LabVIEW 2013을 제거하려면, 터미널 쉘에서 설치 미디어의 Uninstall.sh 쉘 스크립트 파일을 실행합니다.
노트 노트  LabVIEW를 설치한 후에 LabVIEW 2013 디렉토리를 이동한 경우, LabVIEW는 사용자가 디렉토리를 기본 위치로 이동하지 않는 이상, LabVIEW 2013 디렉토리를 설치 해제하거나 제거하지 않습니다.

(Linux)

설치 미디어에서 UNINSTALL 스크립트를 실행합니다. 이 스크립트는 설치 미디어에만 있습니다.

모듈 또는 툴킷이 LabVIEW 플랫폼 DVD에 있는지 확인하기(Windows)

LabVIEW 플랫폼 DVD 1에서 LabVIEW 플랫폼 Readme를 참조하십시오. 이 문서에서는 LabVIEW 플랫폼 DVD에 실려있는 모든 모듈과 툴킷의 리스트를 보여줍니다.

NI 디바이스 드라이버 DVD에 포함되어 있지 않은 디바이스 드라이버 찾기(Windows)

NI 디바이스 드라이버 DVD에는 대부분의 NI 하드웨어 디바이스에 사용할 수 있는 LabVIEW 2013 디바이스 드라이버가 포함되어 있습니다. 설치 프로그램의 구성 요소 스크린에서 특정 드라이버를 찾지 못한 경우, 다음 위치 중 한 곳에서 드라이버를 설치할 수 있습니다:

  • NI 디바이스—디바이스와 함께 배송된 드라이버 미디어를 사용하거나, ni.com/drivers에서 최신 버전의 드라이버를 다운로드합니다.
  • 타사 디바이스ni.comInstrument Driver Network에서 타사 인스트루먼트용 드라이버를 검색하여 다운로드합니다.

LabVIEW 플랫폼 DVD에 포함되지 않은 모듈 및 툴킷 설치하기(Windows)

일부 LabVIEW 모듈과 툴킷은 LabVIEW 플랫폼 DVD와 별도로 출시됩니다. 다음 단계를 따라 플랫폼에 포함되지 않은 LabVIEW 애드온을 설치합니다:

  1. LabVIEW 2013을 설치합니다.
  2. ni.comLabVIEW 모듈 및 툴킷 호환성 정보 섹션에서 애드온이 LabVIEW 2013과 호환되는지 확인할 수 있습니다.
  3. 애드온의 설치 미디어를 삽입하고, 화면에 나타나는 지시를 따르십시오.
  4. 애드온에 대한 더 자세한 정보는 애드온의 설치 미디어에있는 readme 파일을 참조하십시오.

찾을 수 없는 SubVI, 팔레트, 프로퍼티 노드 검색하기(Windows)

LabVIEW가 특정 SubVI, 팔레트 또는 프로퍼티 노드를 찾을 수 없는 경우, 원인은 다음과 같습니다:

  • VI가 사용하는 드라이버의 LabVIEW 2013 버전을 설치하지 않았습니다. 하드웨어와 통신하려면 LabVIEW 2013은 관련 디바이스 드라이버의 LabVIEW 2013 버전을 필요로 합니다. 드라이버가 LabVIEW 2013과 실행되도록 업데이트하지 않는 경우, 관련 드라이버 VI, 팔레트 및 프로퍼티 노드를 사용할 수 없어 LabVIEW가 디바이스와 통신할 수 없습니다. 이 문제를 해결하려면 다음 소스 중 하나를 사용하여 관련 드라이버를 다시 설치합니다:
    • 대부분의 NI 디바이스—LabVIEW 플랫폼 DVD에 포함되어 있는 NI 디바이스 드라이버 DVD를 사용합니다.
    • NI 디바이스 드라이버 DVD에 포함되지 않은 NI 디바이스—디바이스와 함께 배송된 드라이버 미디어를 사용하거나, ni.com/drivers에서 최신 버전의 드라이버를 다운로드합니다.
    • 타사 디바이스ni.comInstrument Driver Network에서 타사 인스트루먼트용 드라이버를 검색하여 다운로드합니다.
  • VI가 사용하는 드라이버를 설치한 후에 모듈 또는 툴킷을 설치했습니다. 디바이스 드라이버를 설치한 후 LabVIEW FPGA 또는 LabVIEW Real-Time Module과 같은 애드온을 설치하는 경우, 디바이스 드라이버를 변경해야 모듈이 디바이스 드라이버 및 관련 VI를 인식할 수 있습니다. 다음 단계를 완료하여 디바이스 드라이버를 변경합니다:
    1. 제어판의 프로그램 및 기능으로 갑니다.
    2. 프로그램 리스트에서 National Instruments 소프트웨어를 선택합니다.
    3. 각 디바이스 드라이버를 선택하고 변경을 선택합니다.
  • VI가 LabVIEW 이전 버전의 user.lib 디렉토리에 있는 파일을 필요로 합니다. LabVIEW 이전 버전에서 사용자 VI를 생성한 경우, 이 VI를 LabVIEW 2013의 user.lib 디렉토리에 복사해야 다른 VI가 이 VI를 계속해서 SubVI로 사용할 수 있습니다.

NI-DAQmx를 LabVIEW와 함께 사용하기(OS X)

NI-DAQmx Base는 OS X에서 LabVIEW 2013과 함께 사용할 수 있는 유일한 NI-DAQmx 버전입니다. 다음 단계를 완료하여 OS X에서 LabVIEW 2013용 NI-DAQmx Base를 사용합니다:

  1. ni.comNI-DAQmx 및 NI-DAQ 드라이버 지원 페이지를 참조하여 NI-DAQmx Base가 사용자 디바이스를 지원하는지 확인하십시오.
  2. ni.com에서 NI-DAQmx Base 소프트웨어를 다운로드합니다.

찾을 수 없는 SubVI, 팔레트, 프로퍼티 노드 검색하기(OS X)

LabVIEW가 특정 SubVI, 팔레트 또는 프로퍼티 노드를 찾을 수 없는 경우, 원인은 다음과 같습니다:

  • VI가 사용하는 드라이버의 LabVIEW 2013 버전을 설치하지 않았습니다. 하드웨어와 통신하려면 LabVIEW 2013은 관련 디바이스 드라이버의 LabVIEW 2013 버전을 필요로 합니다. 드라이버가 LabVIEW 2013과 실행되도록 업데이트하지 않는 경우, 관련 드라이버 VI, 팔레트 및 프로퍼티 노드를 사용할 수 없어 LabVIEW가 디바이스와 통신할 수 없습니다. 이 문제를 해결하려면 다음 소스 중 하나를 사용하여 관련 드라이버를 다시 설치합니다:
    • NI-VISA와 GPIB 디바이스—LabVIEW 기본 설치에는 NI-VISA and GPIB 또는 NI-488.2 인터페이스가 포함됩니다. 이러한 드라이버를 설치하지 않도록 이전에 설치 과정을 변경한 경우, LabVIEW 2013 DVD를 삽입하고 Installation Type에서 Customize를 클릭하고 LabVIEW에서 찾을 수 없는 드라이버를 선택합니다.
    • NI 디바이스에 사용하는 드라이버의 최신 버전ni.com/drivers에서 드라이버의 최신 버전을 다운로드할 수 있습니다.
    • NI-DAQmx Baseni.com에서 NI-DAQmx Base 소프트웨어를 다운로드합니다.
    • 타사 디바이스ni.comInstrument Driver Network에서 타사 인스트루먼트용 드라이버를 검색하여 다운로드합니다.
  • VI가 LabVIEW 이전 버전의 user.lib 디렉토리에 있는 파일을 필요로 합니다. LabVIEW 이전 버전에서 사용자 VI를 생성한 경우, 이 VI를 LabVIEW 2013의 user.lib 디렉토리에 복사해야 다른 VI가 이 VI를 계속해서 SubVI로 사용할 수 있습니다.

설치 미디어 설치하기(Linux)

다음 단계를 완료하여 LabVIEW 2013 설치 미디어를 설치합니다.

  1. 시스템에 root로 로그인합니다.
  2. LabVIEW 2013 설치 미디어를 삽입합니다.
  3. 미디어가 자동으로 설치되지 않는 경우, mount /mnt/cdrom을 사용하여 미디어를 설치합니다.
  4. 현재 디렉토리를 마운트된 미디어로 변경하려면, 다음 명령을 입력합니다:
    cd /mnt/cdrom

이제 LabVIEW 설치 설명서의 설명대로 설치 스크립트를 실행할 수 있습니다.

NI-DAQmx를 LabVIEW와 함께 사용하기(Linux)

NI-DAQmx Base는 Linux에서 LabVIEW 2013과 함께 사용할 수 있는 유일한 NI-DAQmx 버전입니다. 다음 단계를 완료하여 Linux에서 LabVIEW 2013용 NI-DAQmx Base를 사용합니다:

  1. ni.comNI-DAQmx 및 NI-DAQ 지원 페이지를 참조하여 NI-DAQmx Base가 사용자 디바이스를 지원하는지 확인하십시오.
  2. ni.com에서 NI-DAQmx Base 소프트웨어를 다운로드합니다.

LabVIEW 실행시 발생하는 일반적인 에러(Linux)

에러예상되는 원인과 해결책
Xlib: connection to :0.0 refused by server예상되는 원인―디스플레이 서버에서 윈도우를 열 수 있는 권한이 없는 사용자로 LabVIEW를 실행하려고 합니다. 이러한 에러는 일반적으로 임시로 root (superuser)와 같이 다른 사용자가 되기 위해 su 명령을 실행할 때 발생합니다.

해결책su 명령을 빠져나간 후 로그인 사용자로 LabVIEW를 실행하거나 xhost 또는 xauth 명령을 사용하여 디스플레이 서버에서 윈도우를 열 수 있는 권한을 얻습니다.
client is not authorized to connect to server
internal error during connection authorization check

64비트 시스템의 실행 에러― LabVIEW가 64비트 Linux 시스템에서 시작하지 않는 경우, 배포판에 32비트 호환성 라이브러리를 설치했는지 확인하십시오.

찾을 수 없는 SubVI, 팔레트, 프로퍼티 노드 검색하기(Linux)

LabVIEW가 특정 SubVI, 팔레트 또는 프로퍼티 노드를 찾을 수 없는 경우, 원인은 다음과 같습니다:

  • 드라이버의 LabVIEW 2013 버전을 설치하지 않았습니다. 하드웨어와 통신하려면 LabVIEW 2013은 관련 디바이스 드라이버의 LabVIEW 2013 버전을 필요로 합니다. 드라이버가 LabVIEW 2013과 실행되도록 업데이트하지 않는 경우, 관련 드라이버 VI, 팔레트 및 프로퍼티 노드를 사용할 수 없어 LabVIEW가 디바이스와 통신할 수 없습니다. 이 문제를 해결하려면 다음 소스 중 하나를 사용하여 관련 드라이버를 다시 설치합니다:
    • NI-VISA 드라이버—LabVIEW의 INSTALL 스크립트는 이 드라이버를 설치하도록 입력요청합니다. LabVIEW를 설치하는 과정에서 이 드라이버를 설치하지 않도록 선택한 경우, INSTALL 스크립트를 다시 실행해야 합니다.
    • 기타 NI 디바이스—디바이스와 함께 배송된 드라이버 미디어를 사용하거나, ni.com/drivers에서 최신 버전의 드라이버를 다운로드합니다.
    • NI-DAQmx Baseni.com에서 NI-DAQmx Base 소프트웨어를 다운로드합니다.
    • 타사 디바이스ni.comInstrument Driver Network에서 타사 인스트루먼트용 드라이버를 검색하여 다운로드합니다.
  • VI가 LabVIEW 이전 버전의 user.lib 디렉토리에 있는 파일을 필요로 합니다. LabVIEW 이전 버전에서 사용자 VI를 생성한 경우, 이 VI를 LabVIEW 2013의 user.lib 디렉토리에 복사해야 다른 VI가 이 VI를 계속해서 SubVI로 사용할 수 있습니다.

추가적인 도움(모든 플랫폼)

LabVIEW 설치 과정의 문제 해결을 위한 추가적인 도움은 다음 리소스를 참조하십시오:

  • ni.com/gettingstarted―NI 제품군에 대한 더 자세한 설치 및 설정 설명을 제공합니다.
  • ni.com/support―유효한 소프트웨어 서비스 계약을 가진 경우 이용할 수 있는 NI 엔지니어와의 일대일 실시간 채팅을 비롯하여 다양한 기술지원 리소스를 설명합니다.

 

고객평가! 열등 매우 나쁨  |  매우 좋음 우수   아니오
 문서 품질?  
 질문에 대해 충분한 답변이 되었습니까?  
고객 의견 추가 1 2 3 4 5 제출