图标编辑器对话框



LabVIEW 2018帮助


版本日期:2018年3月
产品编号:371361R-0118
查看产品信息

下载帮助(仅限Windows)


LabVIEW 2016帮助
LabVIEW 2017帮助
LabVIEW 2018帮助
LabVIEW 2019帮助
LabVIEW 2020帮助

必需:基础版开发系统

通过以下方法可显示对话框:

  • 双击前面板、程序框图或控件编辑器窗口右上角的图标
  • 双击前面板、程序框图或控件编辑器窗口右上角的图标,在快捷菜单中选择编辑图标
  • 选择文件»VI属性文件»控件属性,可分别显示VI属性控件属性对话框。 在类别下拉菜单中选择常规,然后单击编辑图标按钮。
  • 右键单击项目浏览器窗口中的项目库、状态图、类或XControl,在快捷菜单中选择属性,可显示相应的属性对话框。 单击常规设置页上的编辑按钮。

该对话框还可用于创建和编辑图标

注:图标编辑器对话框可显示24位彩色图标。 但是,LabVIEW仅在程序框图上显示8位彩色图标。 因此,在该对话框中创建的图标可能与程序框图上显示的图标略有不同。

该对话框包括以下部分:

  • 模板—显示作为图标背景的图标模板。 该页显示LabVIEW Data\Icon Templates目录下的所有.png.bmp.jpg文件。
    • 类别—列出可以从中选择的图标模板的类别。 这些类别的名称对应于LabVIEW Data\Icon Templates目录中子文件夹的名称。 所有模板类别始终可见,并包含LabVIEW Data\Icon Templates目录中的所有图标模板。
    • 按关键词过滤模板—指定用于过滤图标模板列表的关键词。 图标编辑器对话框显示名称中包含指定关键词的所有图标模板。
    • 从磁盘刷新模板—更新模板的内部缓存。 从库中添加或删除模板时使用该按钮。
  • 图标文本—指定要在图标中显示的文本。
    • 行文本—为图标指定一行文本。
    • 线条颜色—指定图标的相应文本行的颜色。
    • 字体—指定在图标文本页面上输入的所有文本的字体。
    • 对齐—指定在图标文本页面上输入的所有文本的对齐。
    • 大小—指定在图标文本页面上输入的所有文本的字体大小。
    • 文本垂直居中—指定是否在图标中垂直居中放置文本行。 如使用带标识栏的图标模板并勾选该复选框,图标编辑器对话框在图标的主体部分将文本内容垂直居中对齐。
    • 大写文本—指定是否在图标文本页面上大写所有输入的文本。
  • 符号—显示可包含在图标中的符号图标编辑器对话框可显示LabVIEW Data\Glyphs目录下的所有.png.bmp.jpg文件。 默认情况下,该页包含ni.com上的图标库中的所有符号。 选择工具»同步ni.com图标库可显示同步图标库对话框将LabVIEW Data\Glyphs目录与最新的图标库符号保持同步。
    提示:选择编辑»从文件导入符号时,可显示用于选择并导入特定图形文件的对话框。
    • 类别—列出可以从中选择的符号的类别。 这些类别的名称对应于LabVIEW Data\Glyphs目录中子文件夹的名称。 全部符号类别始终可见,并包含LabVIEW Data\Glyphs目录中的所有符号。
    • 按关键词过滤符号—指定用于过滤符号列表的关键词。 图标编辑器对话框显示名称中包含指定关键词的所有符号。
    • 从磁盘刷新符号—更新符号的内部缓存。 从库中添加或删除符号时使用该按钮。
  • 图层—显示图标的所有图层。 如该页未显示,选择图层»显示图层页可显示该页。
    • 图标文本—显示图标文本图层的预览、名称、透明度和可见性。 该图层包含所有在图标编辑器对话框图标文本页输入的文本。 用户只能更改该图层的透明度和可见性。
    • 用户图层—显示所有用户图层的预览、名称、透明度和可见性。 单击图层页相关的预览,或使用移动工具在图标编辑器预览区域选择图层,都可选择用户图层。
      • 添加图层—添加用户图层。
      • 删除图层—删除所选图层。
      • 上移—上移所选图层。
      • 下移—下移所选图层。
    • 图标模板—显示图标模板图层的预览、名称、透明度和可见性。 该图层包含在图标编辑器对话框模板页选中的图标模板。 用户只能更改该图层的透明度和可见性。
  • 预览—显示图标的放大预览。 预览将根据用户在图标编辑器对话框中所作更改实时更新。
  • 图标—显示图标的实际大小预览。 图标将根据用户在图标编辑器对话框中所作更改实时更新。
  • RGB—显示光标所在位置像素的RGB颜色组成。
  • XYZ—显示光标所在位置像素的X-Y位置。 Z值表示图标中的用户图层总数。
  • 工具—显示用于手动修改图标的编辑工具。 如果在使用编辑工具时左键单击,则LabVIEW将使用线条颜色。 如果在使用编辑工具时左键单击,则LabVIEW将使用填充颜色
  • 水平翻转—水平翻转所选用户图层。 如未选中某个图层,该工具将翻转所有图层。
    注:也可按下<F>键,翻转选中的图层。
  • 顺时针旋转—顺时针旋转所选用户图层。 如未选中某个图层,该工具将翻转所有用户图层。
    注:也可按下<R>键,翻转选中的图层。
  • 线条颜色—指定线或边界使用的颜色。 单击线条颜色矩形,均会显示颜色选择器,可在选择器中选择新颜色
  • 填充颜色—指定填充区域使用的颜色。 单击填充颜色矩形,均会显示颜色选择器,可在选择器中选择新颜色
  • 交换颜色—交换线条颜色填充颜色

如需创建自定义编辑环境,可修改图标编辑器对话框。 要修改图标编辑器对话框,请从ni.com下载图标编辑器源文件。 创建自定义图标编辑器时,可使用labview\resource\plugins\IconEditor\Discover Who Invoked the Icon Editor.vi目录中的“搜索图标库调用方”VI获取当前编辑项图标的名称、路径和应用程序引用。 通过该信息可自定义图标。 例如,依据VI和库类型为图标添加自定义符号。

创建自定义图标编辑器前,必须配置VI在调用时打开前面板。 对于简单VI则无需在打开前重新排列前面板,可使用执行:调用时显示前面板属性。 对于复杂VI则需在打开前重新排列前面板,可使用前面板:打开方法。

文章是否对您有帮助?

没有帮助