创建项目库图标



LabVIEW 2018帮助


版本日期:2018年3月
产品编号:371361R-0118
查看产品信息

下载帮助(仅限Windows)


LabVIEW 2016帮助
LabVIEW 2017帮助
LabVIEW 2018帮助
LabVIEW 2019帮助
LabVIEW 2020帮助

用户可创建一个图标,图形化表示项目库、状态图、XControl。使用图标编辑器对话框创建或编辑图标。

LabVIEW将为库中所有对象使用库图标。NI建议为库图标创建特定标识。库中每个对象的图标都包括该特殊标识,可修改图标的主体部分,提供对象的特定信息。

创建项目库图标

按照下列步骤,为新建项目库创建图标。

  1. 右键单击项目浏览器窗口中的项目库项,从快捷菜单中选择属性,打开相应的项目库属性对话框。LabVIEW在新项目库的默认图标上添加特定标识。请参考常规设置VI图标模板部分的默认项目库图标。
  2. 单击常规设置页上的编辑图标按钮,打开图标编辑器对话框。
  3. (可选)使用图标编辑器对话框右边的填充工具,在图标的特殊标识位置填充不同的颜色。
  4. 使用文本工具在图标的特殊标识处输入文本。文本处于活动状态时,可使用方向键移动文本。
  5. (可选)选择文件»另存为»模板,打开另存图标为对话框,将图标另存为模板供日后使用。LabVIEW将图形模板保存为256色.png文件。
  6. 单击确定按钮,将图标信息与项目库一同保存并关闭图标编辑器对话框。该图标将以256色图标显示在项目库属性对话框的常规设置页。
  7. 单击确认按钮,关闭项目库属性对话框。
提示:  可使用项目库属性对话框的常规设置页的将图标应用于VI按钮,自动将现有项目库的图标应用于项目库中的VI。

创建项目库VI的图标

按照下列步骤,为项目库中的新建VI创建图标。

  1. 右键单击项目浏览器窗口的项目库项,然后从快捷菜单中选择新建»VI,创建一个新VI。注意,前面板右上角的VI图标也包含项目库图标。
  2. 双击VI图标,打开图标编辑器对话框。
  3. 如未显示该页,选择图层»显示图层页,打开图层页。注意该页上的下列选项:
    • 项目库图标显示为用户图层,名为NI_Library
      注:下次修改项目库图标时,LabVIEW将恢复之前对NI_Library用户层的透明度或可见性的任何改动。如要永久修改NI_Library用户层的透明度和可见性,直接将改用应用于项目库图标。
    • NI_IconNumber用户图层包含的数字表示启动LabVIEW后打开新VI的个数,最大值为9。
      注: 如要取消这些数字,选择工具»选项»前面板,取消勾选对新建VI的图标使用数字(1-9)复选框。
    • VI Icon用户图层包含宽度为1像素的黑色图标外框。
    • VI图标使用白色带边框模板,如图层页的图标模板部分所示。
  4. (可选)单击NI_IconNumber用户图层预览,按下<Delete>键删除图层。
  5. 图标文本页,在图标的主体部分输入四行图标文本。可配置文本的字体、对齐方式、大小和颜色。如勾选文本垂直居中复选框,图标编辑器对话框在图标的主体部分将文本内容居中对齐。
  6. 符号页上,拖放符号至预览区域。

    按下<F>键或<R>键水平反转符号或顺时针翻转符号。也可双击符号,将符号放在图标的左上角。可按类型或关键词浏览符号。
  7. 使用移动工具移动符号。每个符号都分别位于不同的图层上,分别移动。选中一个符号后,图标的其他部分以灰色显示。用户可确定将要移动的对象。
  8. 如有需要,使用图标编辑器对话框右边的编辑工具编辑图标。

    图标编辑器对话框为不连续的编辑工具操作创建新用户图层。选择图层»创建新图层,在连续使用编辑工具时创建一个新的用户图层。
    注:不能使用图标编辑器对话框右边的编辑工具修改图标模板或图标文本。使用模板页和图标文本页修改图标模板和图标文本。
  9. 使用图层页配置图标图层的名称、透明度、可见性和顺序。
  10. 单击确定按钮,将图标信息与VI一同保存并关闭图标编辑器对话框。

文章是否对您有帮助?

没有帮助