Modifying an Instrument Driver

You might want to modify an instrument driver that you received from National Instruments or elsewhere. If you want to modify the instrument driver program file, you must have the .c file for the instrument driver.

Before modifying an instrument driver, familiarize yourself with the concepts in the IVI Driver Development Help.

You can modify the following four parts of an instrument driver:

  • You can modify the function tree by selecting the .fp file using the File»Open»Function Tree (*.fp) command, selecting Instrument»Edit, right-clicking the Instruments folder and selecting Edit Instrument, or selecting Tools»Edit Function Tree from a Source window that contains the instrument driver source or include file.
  • You can modify the function panels by selecting Options»Edit Function Panel from a Function Panel window, selecting Edit»Edit Function Panel Window from a Function Tree Editor window, or selecting Tools»Edit Function Panel from a Source window that contains the instrument driver source or include file when the text cursor is over the name of the function in the driver.
  • You can modify the instrument driver program file by selecting Instrument»Edit in a Function Panel window, selecting Tools»Go to Definition from a Function Panel Editor window, or selecting Go to Definition from the context menu in the Function Tree Editor window.
  • You can modify the instrument driver include file by selecting the .h file using the File»Open»Include (*.h) command, selecting Tools»Go to Declaration from a Function Panel Editor window, or selecting Go to Declaration from the context menu of the Function Tree Editor window.

WAS THIS ARTICLE HELPFUL?

Not Helpful