TestStand File Diff and Merge Utility

TestStand 2019 Help

Edition Date: May 2019

Part Number: 370052AA-01

»View Product Info
Download Help (Windows Only)

Use the TestStand File Diff and Merge utility to compare and merge non-type differences among two or three sequence files and compare type differences among two sequence files or type palette files You can launch this utility in the following ways:

  • (Windows 8.1) Click the NI Launcher tile on the Start screen and select TestStand»Tools»TestStand File Diff and Merge Utility.
  • (Windows 10 or 7) Select Start»All Programs»National Instruments»TestStand Shared»TestStand File Diff and Merge Utility.
  • Run <TestStand>\Bin\FileDiffer.exe.

In the Sequence Editor, you can select the Edit»Diff Sequence File Against and Edit»Diff Against Saved Version menu options to launch the TestStand File Diff and Merge Utility to compare an opened sequence file to a file on disk.

The Select Files dialog box launches when you launch the utility. Use the Diff tab of the Select Files dialog box to specify two sequence files or type palette files you want to compare. Use the Merge tab to specify three sequence files you want to compare—a base file from which modified versions originate and two modified versions—and a fourth sequence file to become the resulting merged file to create.

Click the Options button in the Select Files dialog box to launch the File Differ Options dialog box, in which you can configure settings for the utility, including options for loading and automatically merging types, managing type conflict resolution, and so on.

When you specify files to compare in the Select Files dialog box and click OK, the utility launches the main window, which contains the following information:

  • File List—The specified files you are comparing and a count of changes, insertions, and deletions for each file.
  • Differences Table—Displays the differences grouped by sequences, file global variables, file properties, and types for each specified file.
  • Filters Tab—Hide properties with no differences in the Differences window.

Source Code Control

TestStand includes a shared launching application you can use with third-party source code control (SCC) providers that support launching an external application to perform two- and three-way file diff and merge operations. The launching application determines the active version of TestStand and launches the corresponding TestStand diff application that version of TestStand installs. Using the launching application alleviates the requirement to reconfigure the SCC provider each time you activate a different version of TestStand. Launch the application by running <National Instruments>\Shared\TestStand\FileDifferLauncher.exe.

Command-Line Usage

You can also specify files to compare using command-line arguments for the application. You typically use the application to compare files in a source code control system. For example, use the following command-line syntax to specify file paths to a base file, two modified versions, and the resulting merged file to create:

FileDiffer.exe "C:\My Documents\File1.seq" "C:\My Documents\File2.seq" "C:\My Documents\File3.seq" "C:\My Documents\Merged.seq"

Use the following command-line syntax to launch a dialog box that lists all the command-line arguments you can use for the application.

FileDiffer.exe /?

or

FileDiffer.exe /help

To launch the File Diff and Merge Utility in a specific TestStand environment, use the following command line argument:

/env <environment path>

where <environment path> is the location of the .tsenv file that defines the environment.

Note Note  The TestStand File Diff and Merge Utility does not require a license for build or analysis purposes, as defined by the License Agreement. If you do not have a license, you can diff, but not save, sequence files.

The following command-line tokens are supported in the help.

  • /env <environment path>—Specify the TestStand environment.
  • /matchStepsByID:{Y|N}—Require step IDs to match. Provide N for disabling the option.
  • /TypeMerging:{Y|N}—Enable or disable automatic type merge.
  • /ProcessModelLoading:{Y|N}—Enable or disable process model loading.
  • /TypePaletteLoading:{Y|N}—Enable or disable loading type palettes.
  • /IgnoreShared:{Y|N}—Enable or disable ignoring differences in variables with the shared property.
  • /AutoResolveShared:{N|Base|File1|File2}—Automatically resolve ignored shared conflicts. Requires /IgnoreShared:Y.
  • /IgnoredMinorModule:{Y|N}—Enable or disable ignoring minor module differences.
  • /AutoResolveMinorModule:{N|Base|File1|File2}—Automatically resolve ignored minor module conflicts. Requires /IgnoreMinorModule:{Base|File1|File2}.
  • /GenerateReport <reportPath.xml>—Automatically generate the diff report and then exit. To have this run synchronously from a batch script use the 'start' command with the '/wait' parameter to launch the process.

WAS THIS ARTICLE HELPFUL?

Not Helpful