From 12:00 AM CDT Sunday, October 17 - 11:30 AM CDT Sunday, October 17, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Sequence Hierarchy Window

TestStand 2019 Help

Edition Date: May 2019

Part Number: 370052AA-01

»View Product Info
Download Help (Windows Only)

Use the Sequence Hierarchy window in the TestStand Sequence Editor to display a graph of the sequence call and callback sequence relationships among sequence files and sequences to more easily visualize, navigate, and maintain test sequences. The Sequence Hierarchy window does not provide a way to edit Sequence Call steps and does not show execution flow while running.

Use the options on the Sequence Hierarchy toolbar to configure the layout and horizontal and vertical direction of the graph and to arrange the nodes and links. Adjust the default graph layout to your needs before printing or saving the graph to disk, if necessary.

Use the following methods to open the Sequence Hierarchy window:

  • Select View»Sequence File»Display File Hierarchy to display the hierarchy of all the sequences in the current sequence file or select View»Sequence File»Display Hierarchy Using»<Entry Point Name> to display the hierarchy from that entry point using the current sequence file as the client sequence file.
  • Right-click the list of steps on the Steps pane of the Sequence File window and select Display File Hierarchy from the context menu to display the hierarchy of all sequences in the sequence file or Display Hierarchy Using»<Entry Point Name> from the context menu to display the hierarchy from that entry point using the current sequence file as a client sequence file.
  • Right-click one or more sequences in the list of sequences on the Sequences pane of the Sequence File window and select Display Sequence Hierarchy from the context menu to display the hierarchy of the selected sequence or sequences, select Display File Hierarchy from the context menu to display the hierarchy of all the sequences in the sequence file, or select Display Hierarchy Using»<Entry Point Name> from the context menu to display the hierarchy from that entry point using the current sequence file as a client sequence file.

    If you do not select any sequences, the Display File Hierarchy option is available, and the Display Sequence Hierarchy option is disabled. If you select one or more sequences, the Display File Hierarchy is disabled, and the Display Sequence Hierarchy option is available.

  • Right-click a sequence file in the list of sequence files on the Windows pane or on the Workspace pane and select Display File Hierarchy from the context menu to display the hierarchy of all sequences in the sequence file, or select Display Hierarchy Using»<Entry Point Name> from the context menu to display the hierarchy from that entry point using the current sequence file as a client sequence file.
Note Note  When you select Display Hierarchy Using»<Entry Point Name>, the graph starts at the given Execution entry point. The list of entry points varies according to the process model the sequence file uses, except when you open the Sequence Hierarchy window from the Workspace pane, in which case the graph uses the station process model.

The Sequence Hierarchy window contains the following panes:

  • Call Graph—The sequence call graph.
  • Legend—The sequence files the Sequence Hierarchy window uses when creating the graph, the types of sequence calls, and the different sequence types the sequence files use.
  • Graph Overview—Shows a reduced-scale view of the graph and supports panning and zooming of the graph.

To restore hidden Call Graph, Legend, and Graph Overview panes, right-click the Sequence Hierarchy window and select the pane you want to restore, or select the hidden pane from the View submenu of the context menu. You can also select View»Hierarchy»Call Graph, Legend, or Overview to restore the hidden panes.


See Also

Sequence File Window

Sequences Pane

Sequences Pane Context Menu

Steps Pane

Toolbar Buttons and Shortcuts

Windows Pane

Workspace Pane

WAS THIS ARTICLE HELPFUL?

Not Helpful