TestStand Offline Results Processing Utility

TestStand 2017 Help

Edition Date: November 2017

Part Number: 370052W-01

»View Product Info

Download Help (Windows Only)
NI TestStand 2014 Help
NI TestStand 2014 SP1 Help
TestStand 2016 Help
TestStand 2016 SP1 Help
TestStand 2017 Help

You can launch the TestStand Offline Results Processing Utility in the following ways:

  • Select Tools»Offline Results Processing Utility in the TestStand Sequence Editor.
  • (Windows 8.1) Click the NI Launcher tile on the Start screen and select TestStand»Tools»Offline Results Processing Utility.
  • (Windows 10 or 7) Select Start»All Programs»National Instruments»TestStand»Tools»TestStand Offline Results Processing Utility.

Use this utility to process raw results files into reports and database tables at a time other than when sequence execution occurs, such as overnight, or on a different computer. Use this utility in situations in which performance is more important than immediately processing results. You can use 64-bit TestStand to process files that 32-bit TestStand generates and vice versa. If 32-bit TestStand returns out of memory errors while processing a TSR file, process the file with 64-bit TestStand, which can use more memory during processing.

Select Profile»New or right-click in the Profiles pane and select New Profile from the context menu to create a profile. Use profiles to define a set of raw results files to process, to specify the result processing configuration set to use to process results, to specify the sequence file to use as the callback sequence file when processing the raw results files, and to track the set of files the utility has already processed. Use the inbox of a profile to specify where to store raw results files to process, and use the outbox of a profile to specify where to store raw results files and reports after processing. You can configure the number of files the utility processes simultaneously.

The utility creates a new execution to process raw results files into reports and database tables. This execution calls callbacks for offline results processing in the same manner as normal results processing. Use the Default Callback File option in the TestStand Offline Results Processing Utility Settings dialog box to specify a default callback file for all profiles, or specify a callback file for each profile in the profile grid.

The utility selects the callback file used to process results based on the following criteria:

  1. If you specify a callback file for a profile, the utility will use that callback file to process results.
  2. If you do not specify a callback file for a profile, the utility will use the default callback file to process results.
  3. If you do not specify a callback file for a profile and do not specify a default callback file, the utility will not use any callback file.

When files exist in the inbox of a profile, the utility will load both the specified callback file for the profile and the default callback file, even when the profile is paused. The utility will unload the callback files shortly after the last file is moved out of the inbox.

Which callbacks are called during offline results processing depends on the plug-ins used to deserialize. The same callbacks would be called during normal results processing for the same plug-ins.

Note Note  When the utility generates a report after processing, it adds a TestStand Results (TSR) ID to each report file name. The TSR ID is a unique string identifying the raw results file from which the report was generated. After processing a raw results file, the utility automatically moves the file to the outbox. If another raw results file with the same name exists in the outbox, the utility automatically appends the TSR ID to the end of the name of the processed file.

The Report List pane displays the list of reports the utility generated from the raw results file of the same name. Use the Next Report and Previous Report buttons to show the next or previous unread report. An unread report is one that the utility has not opened during the current session. This pane also uses the same controls as the Report pane in the sequence editor Execution window.

Select File»Settings to launch the TestStand Offline Results Processing Utility Settings dialog box, in which you set utility configuration options. If you are processing TSR files with a large number of results, use the Number of Files Processed Simultaneously option in this dialog box to reduce memory usage.

The status bar of the utility displays the default callback file and the report you selected in the Report List pane.

You can use command-line arguments or a Call Executable step with command-line arguments in a sequence to launch the offline results processing utility.

You can also use scheduled tasks in Microsoft Windows to launch the offline results processing utility with command-line arguments. The utility is located at <TestStand>\Components\Tools\Offline Results Processing Utility\OfflineResultsProcessingUtility.exe. If you want the offline results processing utility to run a specified amount of time, create two tasks and specify the /quit argument for the second task to stop the utility immediately. Refer to Microsoft documentation for more information about scheduling tasks.

Note Note  National Instruments provides the utility source code only for informational purposes and does not recommend rebuilding the utility from the source code.

See Also

Call Executable step

Execution window

Profiles pane

Report pane

TestStand Offline Results Processing Utility command-line arguments

TestStand Offline Results Processing Utility context menu

TestStand Offline Results Processing Utility Settings dialog box

WAS THIS ARTICLE HELPFUL?

Not Helpful