Associating Existing Menus

LabVIEW 2018 Help


Edition Date: March 2018
Part Number: 371361R-01
View Product Info

DOWNLOAD (Windows Only)


LabVIEW 2016 Help
LabVIEW 2017 Help
LabVIEW 2018 Help
LabVIEW 2019 Help
LabVIEW 2020 Help

You can use an existing run-time menu (.rtm) file with more than one VI.

Complete the following steps to associate an existing .rtm file with a VI.

  1. Select Edit»Run-Time Menu to display the Menu Editor dialog box.
  2. Select File»Open in the Menu Editor dialog box.
  3. Navigate to the menu file you want to associate with the VI and click the OK button. Notice that the path to the menu file is displayed in the title bar of the Menu Editor dialog box.
  4. Close the Menu Editor dialog box.
  5. When asked if you want to change the run-time menu to the selected menu file, click the Yes button.

Complete the following steps to disassociate a run-time menu from a VI.

  1. Select Edit»Run-Time Menu to display the Menu Editor dialog box.
  2. Select Default from the Menu Type pull-down menu. Notice that a file path no longer appears on the title bar of the Menu Editor dialog box.
  3. Close the Menu Editor dialog box.
  4. When asked if you want to change the run-time menu to the Default menu, click the Yes button.

You can customize menus statically and programmatically.

WAS THIS ARTICLE HELPFUL?

Not Helpful