Viewing Files in a Project

LabVIEW 2018 Help


Edition Date: March 2018
Part Number: 371361R-01
View Product Info

DOWNLOAD (Windows Only)


LabVIEW 2016 Help
LabVIEW 2017 Help
LabVIEW 2018 Help
LabVIEW 2019 Help
LabVIEW 2020 Help

The Project Explorer window includes two pages. The Items page displays the contents of the project. The Files page displays the project items that have a corresponding file on disk. You can switch from one page to the other by right-clicking a folder or item under a target and selecting Show in Items View or Show in Files View from the shortcut menu.

When you add a file to a LabVIEW project, LabVIEW includes a reference to the file on disk. From the Items page in the Project Explorer window, select Project»Show Item Paths to display the Paths column and view the file path. You also can right-click the project root and select View»Full Paths from the shortcut menu to display the Paths column and view the file path. Use the Path property to return the location of a file on disk programmatically.

Use the Files page in the Project Explorer window to view the disk location of project files. You can organize filenames and folders on the Files page and perform disk operations such as rename, reorganize, and remove. For example, if you rename a file on the Files page, LabVIEW renames that file on disk. You also can use the Project File Information dialog box to view the disk location of project files. Select Project»File Information to display the Project File Information dialog box. You also can right-click the project root and select View»File Information from the shortcut menu to display the Project File Information dialog box.

WAS THIS ARTICLE HELPFUL?

Not Helpful