4. Convert Your VIs and Address Behavior Changes

LabVIEW 2018 Help


Edition Date: March 2018
Part Number: 371361R-01
View Product Info

DOWNLOAD (Windows Only)


LabVIEW 2016 Help
LabVIEW 2017 Help
LabVIEW 2018 Help
LabVIEW 2019 Help
LabVIEW 2020 Help

Mass compiling your VIs in LabVIEW 2018 converts the VIs to the new version of LabVIEW and creates an error log to help you identify VIs that are broken. You can use this information in conjunction with the Upgrade and Compatibility Issues topic to identify and correct behavior changes associated with the new version of LabVIEW.

Note  If you mass compiled your VIs when you upgraded to LabVIEW 2017, you can skip this step because LabVIEW 2017 and later supports backward compatibility for the LabVIEW Run-Time Engine.

a. Mass Compile Your VIs in the New Version of LabVIEW

Mass compiling VIs simultaneously converts and saves the VIs in LabVIEW 2018. However, after mass compiling the VIs, you no longer can open the VIs in a previous version of LabVIEW without selecting File»Save for Previous Version for each VI or project. Therefore, mass compile only the VIs that you want to convert to the new version of LabVIEW. To help identify any problems that arose from upgrading, create a mass compile log by placing a checkmark in the Log Results checkbox of the Mass Compile dialog box.

Note  When you mass compile VIs that contain FPGA or real-time resources, the Mass Compile dialog box may report the VIs as non-executable VIs. To check for errors, you must open the VIs under the FPGA or RT target in a LabVIEW project with the required FPGA or real-time resources.

b. Fix Any Broken VIs

Differences between your previous version of LabVIEW and LabVIEW 2018 can occasionally cause some VIs to break if they use modified features. To quickly identify and fix broken VIs in LabVIEW 2018, complete the following steps:

  1. To identify VIs that broke during upgrading, compare the mass compile error log you created in the previous step to the log you created when testing the existing behavior of the VIs.
  2. To determine whether updates to LabVIEW caused each VI to break, refer to the section of the Upgrade and Compatibility Issues topic for each version of LabVIEW between your previous version and LabVIEW 2018.

c. Identify and Correct Behavior Changes

Although NI invests significant effort to avoid changing the behavior of VIs between different versions of LabVIEW, improvements and bug fixes occasionally do alter the behavior of VIs. To quickly identify whether the new version of LabVIEW changes the behavior of your VIs, use one or more of the following tools:

  • Run the VI Analyzer Upgrade Tests—For large sets of VIs, these tests provide an efficient way to identify many behavior changes caused by upgrading. Complete the following steps to obtain and use these tests:
    1. Download the VI Analyzer Upgrade Tests for all versions of LabVIEW later than your previous version from the NI website at ni.com.
    2. Open and run the tests by selecting Tools»VI Analyzer»Analyze VIs and starting a new VI Analyzer task. To analyze an entire project at once, select this menu option from the Project Explorer window rather than from a single VI.
    3. Resolve test failures by referring to the Upgrade and Compatibility Issues section for the version of LabVIEW that corresponds to the tests. For example, if the LabVIEW 2015 Upgrade VI Analyzer tests locate a potential behavior change, refer to the Upgrading from LabVIEW 2014 section of that topic.
  • Read the upgrade documentation
    • Upgrade and Compatibility Issues topic—Lists changes that may break or affect the behavior of your VIs. Refer to the subsections for each version of LabVIEW beginning with your previous version.
      Tip  To quickly locate deprecated objects and other objects mentioned in the Upgrade and Compatibility Issues topic, open your upgraded VIs and select Edit»Find and Replace.
    • LabVIEW 2018 Known Issues list—Lists bugs discovered before and throughout the release of LabVIEW 2018. Refer to the Upgrade - Behavior Change and Upgrade - Migration sections, if available, to identify workarounds for any bugs that may affect the behavior of upgraded VIs.
    • Module and toolkit documentation—Lists upgrade issues specific to some modules and toolkits, such as the LabVIEW FPGA Module and the LabVIEW Real-Time Module.
    • Driver readme files—Lists upgrade issues specific to each driver. To locate each readme, refer to the installation media for the driver.
      Tip  To determine whether a behavior change resulted from a driver update rather than an update to LabVIEW, test your VIs in the previous version of LabVIEW after installing LabVIEW 2018.
  • Run your own tests—Perform the same tests on the VIs in LabVIEW 2018 that you performed in the previous version and compare the results. If you identify new behaviors, refer to the upgrade documentation to diagnose the source of the change.
Previous: Install LabVIEW, Add-Ons, and Device Drivers Next: Troubleshooting Common Upgrade Issues

WAS THIS ARTICLE HELPFUL?

Not Helpful