Covering Requirements in a DOORS Module

NI Requirements Gateway 2018 Help

Edition Date: March 2018

Part Number: 371714F-01

»View Product Info
Download Help (Windows Only)

Complete the following steps to add to a project an upstream IBM Rational DOORS document that specifies requirements imported from a DOORS module and to add a downstream Text document that covers the requirements.

Note Note  You must have a supported version of DOORS installed to complete this tutorial. Refer to the Readme.html file for more information about supported DOORS versions.

Defining Requirements in a DOORS Module

Complete the following steps to define requirements in a DOORS module.

  1. Complete the following steps to import an existing project in DOORS.
    1. Launch DOORS and log in to the database. You must have adequate privileges to create projects.
    2. Select File»Restore»Project to launch the Restore Project dialog box.
    3. Click Browse and open <Requirements Gateway Public>\Tutorials\RequirementsGatewayTutorial.dpa.
    4. Click OK in the Restore Project dialog box. DOORS displays the content of the project in the Restore Project dialog box. Click OK to create the RequirementsGatewayTutorial project in the database.
  2. Complete the following steps to define requirements in the Formal module window.
    1. Double-click the Requirements module to open the Formal module window.
      Note Note  The Requirements module contains information similar to the content of the text specification document, ProductSpec.txt, used in Chapter 2, Managing Requirements, of the Getting Started with NI Requirements Gateway manual. The DOORS Advanced type uses attribute values to determine whether an object is a requirement and to specify the requirement ID.
    2. In the Formal module window, select Insert»Column to launch the New Column dialog box.
    3. Select Object Type from the Attribute pull-down menu and enter ObjectType in the Column Title control.
    4. Click OK to close the New Column dialog box. DOORS adds a new column to the view.
    5. Repeat steps b through d to add another column in the display for the ReqID object attribute. The DOORS Advanced type interprets objects with the ObjectType object attribute set to Requirement as a requirement, and uses the ReqID object attribute value as the requirement ID.
  3. Select View»Save As to launch the Save As dialog box.
  4. Enter Requirements Gateway Advanced in the Name control and click OK to save the changes to the view and close the Save As dialog box.
  5. Select File»Close to close the Formal module window.

Adding a DOORS Document to a Project

Complete the following steps to add a DOORS document to a project.

  1. In Requirements Gateway, select File»New to launch the Create a New Project and Save As dialog box, and navigate to the <Requirements Gateway Public>\Tutorials directory.
  2. Enter DOORS Project in the File name control and click Save. Requirements Gateway launches the Project pane of the Configuration dialog box.
  3. Click Add a document to add a new document on the Project Configuration pane.
  4. On the Details tab, enter Product Specification in the Name control and select Doors Advanced from the Type of Analysis pull-down menu.
  5. Complete the following steps to specify the DOORS module to use for the new document.
    1. In the File or Directory column on the Details tab, click File Browse to launch the Select DOORS module dialog box.
    2. Enter a DOORS username and password in the DOORS login section.
    3. Click Update DOORS tree. Requirements Gateway accesses the DOORS database and lists the projects and modules in the tree view.
    4. Select the DOORS Database»RequirementsGatewayTutorial»Requirements element in the tree view.
    5. Click OK to close the Select DOORS module dialog box.
  6. Click Add a document to add a second document object on the Project Configuration pane. Place the document below the Product Specification document.
  7. On the Details tab, enter Covering Specification in the Name control, select Text from the Type of Analysis pull-down menu, click File Browse in the File or Directory column, and navigate to <Requirements Gateway Public>\Tutorials\CoveringSpec.txt in the File or Directory column.
  8. Click Add a cover to add a covering link. Click the Covering Specification document and then click the Product Specification document to create an arrow between the two documents.
  9. Click OK to close the Configuration dialog box.
  10. Click Yes when Requirements Gateway prompts you to reanalyze the project.
  11. In the Coverage Analysis view, expand the Product Specification document in the Selection column. Requirements Gateway displays the RequirementsGatewayTutorial.dpa file under the Product Specification document.
  12. Select the Covering Specification document in the Selection column. The Downstream Coverage Information column indicates that the Covering Specification document covers 100% of the requirements in the Product Specification document.
    Note Note  If you complete this tutorial before you complete the tutorial in Chapter 2, Managing Requirements, of the Getting Started with NI Requirements Gateway manual, Requirements Gateway displays the coverage as 90%.

Exporting Traceability Information to DOORS

Export documents and traceability links from covering documents in a Requirements Gateway project back to the DOORS database so you can access the Requirements Gateway analysis directly in DOORS. The DOORS types create a new module for the covering document and links the references in the document to the requirements in DOORS.

Complete the following steps to export the Covering Specification document to the DOORS database.

  1. In the Management view, select the Covering Specification document.
  2. Click Export Document to DOORS on the toolbar in the main window to launch the Export Document to DOORS dialog box.
  3. Complete the following steps to use the Export Document to DOORS dialog box to configure how to store the information in DOORS.
    1. Select the RequirementsGatewayTutorial element in the Target tree view.
    2. Enter Covering Module in the New module control.
    3. Click Export to launch a confirmation dialog box that lists the new elements to export to DOORS.
    4. Click Export again.
    5. Click OK when Requirements Gateway displays a message that the operation completed.
      Note Note  If you did not close the Formal module window for the Requirements Module in DOORS, Requirements Gateway cannot export the Covering Specification document and create links. If the export operation fails, close the Formal module window and repeat steps 2 and 3.
    6. Click Close to close the Export Document to DOORS dialog box.
  4. In DOORS, select View»Refresh to display the Covering Module in the database.
  5. Double-click Covering Module to display the module in the Formal module window. The content of the module mirrors the traceability information that Requirements Gateway displays, and links exist between the Covering Module and the Requirements Module.
  6. Select File»Close to close the Formal module window and then select File»Exit to exit DOORS.
  7. Close the project file in Requirements Gateway.

WAS THIS ARTICLE HELPFUL?

Not Helpful